mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
x11-toolkits/iwidgets: upgrade to 4.1.1 and correct licence
license.terms says: Permission to use, copy, modify, distribute and license this software and its documentation for any purpose, and without fee or written agreement with DSC, is hereby granted, provided that the above copyright notice appears in all copies and that both the copyright notice and warranty disclaimer below appear in supporting documentation, and that the names of DSC Technologies Corporation or DSC Communications Corporation not be used in advertising or publicity pertaining to the software without specific, written prior permission. Therefore it is packageable. PR: 286265 Approved by: Chris Hutchinson (maintainer)
This commit is contained in:
parent
093b402a7d
commit
4517e253e5
7 changed files with 258 additions and 257 deletions
|
@ -1,9 +1,7 @@
|
||||||
PORTNAME= iwidgets
|
PORTNAME= iwidgets
|
||||||
PORTVERSION= 4.0.1
|
PORTVERSION= 4.1.1
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= x11-toolkits tk
|
CATEGORIES= x11-toolkits tk
|
||||||
MASTER_SITES= SF/incrtcl/%5BIncr%20Widgets%5D/${PORTVERSION}
|
MASTER_SITES= SF/incrtcl/%5BIncr%20Widgets%5D/${PORTVERSION}
|
||||||
DISTNAME= iwidgets${PORTVERSION}
|
|
||||||
|
|
||||||
MAINTAINER= portmaster@bsdforge.com
|
MAINTAINER= portmaster@bsdforge.com
|
||||||
COMMENT= Iwidgets - [incr Widgets] companion to [incr Tk]
|
COMMENT= Iwidgets - [incr Widgets] companion to [incr Tk]
|
||||||
|
@ -12,33 +10,32 @@ WWW= https://sourceforge.net/projects/incrtcl/
|
||||||
LICENSE= DTSTECH
|
LICENSE= DTSTECH
|
||||||
LICENSE_NAME= DTSTECH
|
LICENSE_NAME= DTSTECH
|
||||||
LICENSE_FILE= ${WRKSRC}/license.terms
|
LICENSE_FILE= ${WRKSRC}/license.terms
|
||||||
LICENSE_PERMS= auto-accept
|
LICENSE_PERMS= auto-accept dist-mirror dist-sell pkg-mirror pkg-sell
|
||||||
|
|
||||||
LIB_DEPENDS= libitk.so:x11-toolkits/itk
|
LIB_DEPENDS= libitk.so:x11-toolkits/itk
|
||||||
|
|
||||||
NO_BUILD= yes
|
NO_BUILD= yes
|
||||||
USES= tk:tea
|
USES= tk:tea
|
||||||
CONFIGURE_ARGS= --with-itcl=${LOCALBASE}
|
CONFIGURE_ARGS= --with-itcl=${LOCALBASE}/lib/itcl${ITCLVER} \
|
||||||
SUB_LIST= IWIDGETS=${DISTNAME}
|
--with-itk=${LOCALBASE}/lib/itk${ITCLVER}
|
||||||
|
ITCLVER= 3.4
|
||||||
|
SUB_LIST= IWIDGETS=${TCL_PKG}
|
||||||
SUB_FILES= pkg-message
|
SUB_FILES= pkg-message
|
||||||
PLIST_SUB= IWIDGETS=${DISTNAME}
|
|
||||||
MAKE_ARGS+= INSTALL_ROOT=${STAGEDIR}
|
MAKE_ARGS+= INSTALL_ROOT=${STAGEDIR}
|
||||||
|
|
||||||
PORTDOCS= CHANGES ChangeLog README iwidgets.ps
|
PORTDOCS= CHANGES ChangeLog README iwidgets.ps
|
||||||
|
|
||||||
OPTIONS_DEFINE= DOCS
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
.include <bsd.port.options.mk>
|
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${RM} ${STAGEDIR}${PREFIX}/lib/iwidgets
|
${RM} ${STAGEDIR}${PREFIX}/lib/iwidgets
|
||||||
${LN} -s ${DISTNAME} ${STAGEDIR}${PREFIX}/lib/iwidgets
|
${LN} -s ${TCL_PKG} ${STAGEDIR}${PREFIX}/lib/iwidgets
|
||||||
.if ${PORT_OPTIONS:MDOCS}
|
|
||||||
|
post-install-DOCS-on:
|
||||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
${INSTALL_DATA} ${WRKSRC}/doc/iwidgets.ps ${STAGEDIR}${DOCSDIR}
|
${INSTALL_DATA} ${WRKSRC}/doc/iwidgets.ps ${STAGEDIR}${DOCSDIR}
|
||||||
.for f in CHANGES ChangeLog README
|
.for f in CHANGES ChangeLog README
|
||||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
|
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
|
||||||
.endfor
|
.endfor
|
||||||
.endif
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,4 +1,3 @@
|
||||||
SHA256 (itcl3.2.1_src.tgz) = 9a225564fc94beef4cc0e627a368d9d2b4425c58b93d5a787c9836d6cceed2ad
|
TIMESTAMP = 1745225981
|
||||||
SIZE (itcl3.2.1_src.tgz) = 427026
|
SHA256 (iwidgets-4.1.1.tar.gz) = 572fd8eed70786b1fbff6e7fec62eab7bd731beea074022d1b5a480ecf2df586
|
||||||
SHA256 (iwidgets4.0.1.tar.gz) = b0e9cb74370f863e17a05df81fd70af3a39a1cfb733181c61669b30ad7799426
|
SIZE (iwidgets-4.1.1.tar.gz) = 720630
|
||||||
SIZE (iwidgets4.0.1.tar.gz) = 647960
|
|
||||||
|
|
|
@ -1,37 +0,0 @@
|
||||||
--- Makefile.in.orig 2024-02-27 13:21:17 UTC
|
|
||||||
+++ ./Makefile.in
|
|
||||||
@@ -9,7 +9,7 @@
|
|
||||||
|
|
||||||
# Current [incr Widgets] version; used in various names.
|
|
||||||
|
|
||||||
-ITCL_VERSION = @ITCL_VERSION@
|
|
||||||
+ITCL_VERSION = 3.3
|
|
||||||
IWIDGETS_VERSION = @VERSION@
|
|
||||||
|
|
||||||
#----------------------------------------------------------------
|
|
||||||
@@ -48,7 +48,7 @@
|
|
||||||
BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
|
|
||||||
|
|
||||||
# Top-level directory in which to install manual entries:
|
|
||||||
-MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man/mann
|
|
||||||
+MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/share/man/mann
|
|
||||||
|
|
||||||
# Directory containing Tcl source code (for library used during test):
|
|
||||||
TCL_SRC_DIR = @TCL_SRC_DIR@
|
|
||||||
@@ -78,11 +78,11 @@
|
|
||||||
# modify any of this stuff by hand.
|
|
||||||
#----------------------------------------------------------------
|
|
||||||
|
|
||||||
-INSTALL = $(TCLSH_PROG) `$(CYGPATH) $(ITCL_SRC_DIR)/../config/installFile.tcl` -c
|
|
||||||
-INSTALL_PROGRAM = $(INSTALL)
|
|
||||||
-INSTALL_DATA = $(INSTALL) -m 644
|
|
||||||
-INSTALL_SCRIPT = $(INSTALL) -m 555
|
|
||||||
-MKINSTALLDIRS = $(ITCL_SRC_DIR)/../config/mkinstalldirs
|
|
||||||
+INSTALL=install -c
|
|
||||||
+INSTALL_PROGRAM=install -s -m 555
|
|
||||||
+INSTALL_DATA=install -m 0644
|
|
||||||
+INSTALL_SCRIPT=install -m 555
|
|
||||||
+MKINSTALLDIRS=/bin/mkdir -p
|
|
||||||
RANLIB = @RANLIB@
|
|
||||||
LN_S = ln -s
|
|
||||||
TOP_DIR = $(srcdir)
|
|
54
x11-toolkits/iwidgets/files/patch-configure
Normal file
54
x11-toolkits/iwidgets/files/patch-configure
Normal file
|
@ -0,0 +1,54 @@
|
||||||
|
--- configure.orig 2018-03-22 16:21:09 UTC
|
||||||
|
+++ configure
|
||||||
|
@@ -2029,13 +2029,6 @@ fi
|
||||||
|
ITCL_LIB_DIR=$itcl_SRC_DIR/library
|
||||||
|
fi
|
||||||
|
|
||||||
|
-if test -z "$ITCL_LIB_DIR"; then
|
||||||
|
- { { echo "$as_me:$LINENO: error: Can't find Itcl source. Use --with-itcl to specify the the toplevel incr Tcl directory on your system. This directory should contain library/itcl.tcl." >&5
|
||||||
|
-echo "$as_me: error: Can't find Itcl source. Use --with-itcl to specify the the toplevel incr Tcl directory on your system. This directory should contain library/itcl.tcl." >&2;}
|
||||||
|
- { (exit 1); exit 1; }; }
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-
|
||||||
|
# Check whether --with-itk or --without-itk was given.
|
||||||
|
if test "${with_itk+set}" = set; then
|
||||||
|
withval="$with_itk"
|
||||||
|
@@ -2045,8 +2038,8 @@ ITK_LIB_DIR=""
|
||||||
|
fi;
|
||||||
|
|
||||||
|
ITK_LIB_DIR=""
|
||||||
|
-if test -r $itk_search/library/itk.tcl; then
|
||||||
|
- ITK_LIB_DIR=$itk_search/library
|
||||||
|
+if test -r $itk_search/itk.tcl; then
|
||||||
|
+ ITK_LIB_DIR=$itk_search
|
||||||
|
ITK_SRC_DIR=$itk_search
|
||||||
|
fi
|
||||||
|
|
||||||
|
@@ -3617,26 +3610,6 @@ echo $ECHO_N "checking system version (for dynamic loa
|
||||||
|
system=NEXTSTEP-`awk '/3/,/3/' /usr/lib/NextStep/software_version`
|
||||||
|
else
|
||||||
|
system=`uname -s`-`uname -r`
|
||||||
|
- if test "$?" -ne 0 ; then
|
||||||
|
- echo "$as_me:$LINENO: result: unknown (can't find uname command)" >&5
|
||||||
|
-echo "${ECHO_T}unknown (can't find uname command)" >&6
|
||||||
|
- system=unknown
|
||||||
|
- else
|
||||||
|
- # Special check for weird MP-RAS system (uname returns weird
|
||||||
|
- # results, and the version is kept in special file).
|
||||||
|
-
|
||||||
|
- if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
|
||||||
|
- system=MP-RAS-`awk '{print }' /etc/.relid'`
|
||||||
|
- fi
|
||||||
|
- if test "`uname -s`" = "AIX" ; then
|
||||||
|
- system=AIX-`uname -v`.`uname -r`
|
||||||
|
- fi
|
||||||
|
- if test "${TEA_PLATFORM}" = "windows" ; then
|
||||||
|
- system=windows
|
||||||
|
- fi
|
||||||
|
- echo "$as_me:$LINENO: result: $system" >&5
|
||||||
|
-echo "${ECHO_T}$system" >&6
|
||||||
|
- fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
# Step 2: check for existence of -ldl library. This is needed because
|
|
@ -1,12 +0,0 @@
|
||||||
--- configure Thu Nov 29 15:51:34 2001
|
|
||||||
+++ configure Tue May 16 17:36:14 2006
|
|
||||||
@@ -818,9 +818,4 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
-if test -z "$ITCL_LIB_DIR"; then
|
|
||||||
- { echo "configure: error: Can't find Itcl source. Use --with-itcl to specify the the toplevel incr Tcl directory on your system. (This directory should contain itcl/library/itcl.tcl, itk/library/itk.tcl, and config/mkinstalldirs.)" 1>&2; exit 1; }
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-
|
|
||||||
#--------------------------------------------------------------------
|
|
||||||
# Needed for running the test suite
|
|
|
@ -2,7 +2,7 @@
|
||||||
{ type: install
|
{ type: install
|
||||||
message: <<EOM
|
message: <<EOM
|
||||||
Iwidgets is a "mega-widget" set built using itk. It includes
|
Iwidgets is a "mega-widget" set built using itk. It includes
|
||||||
a set of megawidgets, installed in %%PREFIX%%/lib/iwidgets4.0.1
|
a set of megawidgets, installed in %%PREFIX%%/lib/%%IWIDGETS%%
|
||||||
(and symlinked to %%PREFIX%%/lib/iwidgets), a set of man pages
|
(and symlinked to %%PREFIX%%/lib/iwidgets), a set of man pages
|
||||||
describing the various widgets, some scripts in
|
describing the various widgets, some scripts in
|
||||||
%%PREFIX%%/lib/%%IWIDGETS%%/scripts and some demo files in
|
%%PREFIX%%/lib/%%IWIDGETS%%/scripts and some demo files in
|
||||||
|
|
|
@ -1,195 +1,195 @@
|
||||||
lib/%%IWIDGETS%%/demos/buttonbox
|
|
||||||
lib/%%IWIDGETS%%/demos/calendar
|
|
||||||
lib/%%IWIDGETS%%/demos/canvasprintbox
|
|
||||||
lib/%%IWIDGETS%%/demos/canvasprintdialog
|
|
||||||
lib/%%IWIDGETS%%/demos/catalog
|
|
||||||
lib/%%IWIDGETS%%/demos/checkbox
|
|
||||||
lib/%%IWIDGETS%%/demos/combobox
|
|
||||||
lib/%%IWIDGETS%%/demos/dateentry
|
|
||||||
lib/%%IWIDGETS%%/demos/datefield
|
|
||||||
lib/%%IWIDGETS%%/demos/demo.html
|
|
||||||
lib/%%IWIDGETS%%/demos/dialog
|
|
||||||
lib/%%IWIDGETS%%/demos/dialogshell
|
|
||||||
lib/%%IWIDGETS%%/demos/disjointlistbox
|
|
||||||
lib/%%IWIDGETS%%/demos/entryfield
|
|
||||||
lib/%%IWIDGETS%%/demos/extbutton
|
|
||||||
lib/%%IWIDGETS%%/demos/extfileselectionbox
|
|
||||||
lib/%%IWIDGETS%%/demos/extfileselectiondialog
|
|
||||||
lib/%%IWIDGETS%%/demos/feedback
|
|
||||||
lib/%%IWIDGETS%%/demos/fileselectionbox
|
|
||||||
lib/%%IWIDGETS%%/demos/fileselectiondialog
|
|
||||||
lib/%%IWIDGETS%%/demos/finddialog
|
|
||||||
lib/%%IWIDGETS%%/demos/hierarchy
|
|
||||||
lib/%%IWIDGETS%%/demos/html/buttonbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/calendar.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/canvasprintbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/canvasprintdialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/checkbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/combobox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/dateentry.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/datefield.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/dialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/dialogshell.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/disjointlistbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/entryfield.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/extbutton.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/extfileselectionbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/extfileselectiondialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/feedback.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/fileselectionbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/fileselectiondialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/finddialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/hierarchy.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/hyperhelp.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/iwidgets4.0.0UserCmds.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/labeledframe.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/labeledwidget.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/mainwindow.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/menubar.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/messagebox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/messagedialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/notebook.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/optionmenu.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/panedwindow.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/promptdialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/pushbutton.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/radiobox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/scopedobject.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/scrolledcanvas.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/scrolledframe.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/scrolledhtml.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/scrolledlistbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/scrolledtext.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/selectionbox.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/selectiondialog.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/shell.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/spindate.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/spinint.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/spinner.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/spintime.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/tabnotebook.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/tabset.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/timeentry.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/timefield.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/toolbar.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/html/watch.n.html
|
|
||||||
lib/%%IWIDGETS%%/demos/hyperhelp
|
|
||||||
lib/%%IWIDGETS%%/demos/images/box.xbm
|
|
||||||
lib/%%IWIDGETS%%/demos/images/clear.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/close.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/copy.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/cut.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/exit.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/find.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/help.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/line.xbm
|
|
||||||
lib/%%IWIDGETS%%/demos/images/mag.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/new.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/open.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/oval.xbm
|
|
||||||
lib/%%IWIDGETS%%/demos/images/paste.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/points.xbm
|
|
||||||
lib/%%IWIDGETS%%/demos/images/poly.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/print.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/ruler.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/save.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/select.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/images/text.xbm
|
|
||||||
lib/%%IWIDGETS%%/demos/iwidgets.gif
|
|
||||||
lib/%%IWIDGETS%%/demos/labeledframe
|
|
||||||
lib/%%IWIDGETS%%/demos/labeledwidget
|
|
||||||
lib/%%IWIDGETS%%/demos/mainwindow
|
|
||||||
lib/%%IWIDGETS%%/demos/menubar
|
|
||||||
lib/%%IWIDGETS%%/demos/messagebox
|
|
||||||
lib/%%IWIDGETS%%/demos/messagedialog
|
|
||||||
lib/%%IWIDGETS%%/demos/notebook
|
|
||||||
lib/%%IWIDGETS%%/demos/optionmenu
|
|
||||||
lib/%%IWIDGETS%%/demos/panedwindow
|
|
||||||
lib/%%IWIDGETS%%/demos/promptdialog
|
|
||||||
lib/%%IWIDGETS%%/demos/pushbutton
|
|
||||||
lib/%%IWIDGETS%%/demos/radiobox
|
|
||||||
lib/%%IWIDGETS%%/demos/scopedobject
|
|
||||||
lib/%%IWIDGETS%%/demos/scrolledcanvas
|
|
||||||
lib/%%IWIDGETS%%/demos/scrolledframe
|
|
||||||
lib/%%IWIDGETS%%/demos/scrolledhtml
|
|
||||||
lib/%%IWIDGETS%%/demos/scrolledlistbox
|
|
||||||
lib/%%IWIDGETS%%/demos/scrolledtext
|
|
||||||
lib/%%IWIDGETS%%/demos/selectionbox
|
|
||||||
lib/%%IWIDGETS%%/demos/selectiondialog
|
|
||||||
lib/%%IWIDGETS%%/demos/shell
|
|
||||||
lib/%%IWIDGETS%%/demos/spindate
|
|
||||||
lib/%%IWIDGETS%%/demos/spinint
|
|
||||||
lib/%%IWIDGETS%%/demos/spinner
|
|
||||||
lib/%%IWIDGETS%%/demos/spintime
|
|
||||||
lib/%%IWIDGETS%%/demos/tabnotebook
|
|
||||||
lib/%%IWIDGETS%%/demos/tabset
|
|
||||||
lib/%%IWIDGETS%%/demos/timeentry
|
|
||||||
lib/%%IWIDGETS%%/demos/timefield
|
|
||||||
lib/%%IWIDGETS%%/demos/toolbar
|
|
||||||
lib/%%IWIDGETS%%/demos/watch
|
|
||||||
lib/%%IWIDGETS%%/iwidgets.tcl
|
|
||||||
lib/%%IWIDGETS%%/license.terms
|
|
||||||
lib/%%IWIDGETS%%/pkgIndex.tcl
|
|
||||||
lib/%%IWIDGETS%%/scripts/buttonbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/calendar.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/canvasprintbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/canvasprintdialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/checkbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/colors.itcl
|
|
||||||
lib/%%IWIDGETS%%/scripts/combobox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/dateentry.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/datefield.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/dialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/dialogshell.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/disjointlistbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/entryfield.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/extbutton.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/extfileselectionbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/extfileselectiondialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/feedback.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/fileselectionbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/fileselectiondialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/finddialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/hierarchy.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/hyperhelp.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/labeledframe.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/labeledwidget.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/mainwindow.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/menubar.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/messagebox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/messagedialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/notebook.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/optionmenu.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/pane.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/panedwindow.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/promptdialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/pushbutton.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/radiobox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/regexpfield.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/roman.itcl
|
|
||||||
lib/%%IWIDGETS%%/scripts/scopedobject.itcl
|
|
||||||
lib/%%IWIDGETS%%/scripts/scrolledcanvas.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/scrolledframe.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/scrolledhtml.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/scrolledlistbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/scrolledtext.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/scrolledwidget.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/selectionbox.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/selectiondialog.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/shell.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/spindate.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/spinint.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/spinner.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/spintime.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/tabnotebook.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/tabset.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/tclIndex
|
|
||||||
lib/%%IWIDGETS%%/scripts/timeentry.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/timefield.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/toolbar.itk
|
|
||||||
lib/%%IWIDGETS%%/scripts/unknownimage.gif
|
|
||||||
lib/%%IWIDGETS%%/scripts/watch.itk
|
|
||||||
lib/iwidgets
|
lib/iwidgets
|
||||||
|
lib/%%TCL_PKG%%/demos/buttonbox
|
||||||
|
lib/%%TCL_PKG%%/demos/calendar
|
||||||
|
lib/%%TCL_PKG%%/demos/canvasprintbox
|
||||||
|
lib/%%TCL_PKG%%/demos/canvasprintdialog
|
||||||
|
lib/%%TCL_PKG%%/demos/catalog
|
||||||
|
lib/%%TCL_PKG%%/demos/checkbox
|
||||||
|
lib/%%TCL_PKG%%/demos/combobox
|
||||||
|
lib/%%TCL_PKG%%/demos/dateentry
|
||||||
|
lib/%%TCL_PKG%%/demos/datefield
|
||||||
|
lib/%%TCL_PKG%%/demos/demo.html
|
||||||
|
lib/%%TCL_PKG%%/demos/dialog
|
||||||
|
lib/%%TCL_PKG%%/demos/dialogshell
|
||||||
|
lib/%%TCL_PKG%%/demos/disjointlistbox
|
||||||
|
lib/%%TCL_PKG%%/demos/entryfield
|
||||||
|
lib/%%TCL_PKG%%/demos/extbutton
|
||||||
|
lib/%%TCL_PKG%%/demos/extfileselectionbox
|
||||||
|
lib/%%TCL_PKG%%/demos/extfileselectiondialog
|
||||||
|
lib/%%TCL_PKG%%/demos/feedback
|
||||||
|
lib/%%TCL_PKG%%/demos/fileselectionbox
|
||||||
|
lib/%%TCL_PKG%%/demos/fileselectiondialog
|
||||||
|
lib/%%TCL_PKG%%/demos/finddialog
|
||||||
|
lib/%%TCL_PKG%%/demos/hierarchy
|
||||||
|
lib/%%TCL_PKG%%/demos/html/buttonbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/calendar.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/canvasprintbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/canvasprintdialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/checkbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/combobox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/dateentry.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/datefield.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/dialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/dialogshell.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/disjointlistbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/entryfield.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/extbutton.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/extfileselectionbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/extfileselectiondialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/feedback.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/fileselectionbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/fileselectiondialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/finddialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/hierarchy.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/hyperhelp.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/iwidgets4.0.0UserCmds.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/labeledframe.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/labeledwidget.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/mainwindow.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/menubar.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/messagebox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/messagedialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/notebook.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/optionmenu.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/panedwindow.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/promptdialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/pushbutton.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/radiobox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/scopedobject.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/scrolledcanvas.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/scrolledframe.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/scrolledhtml.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/scrolledlistbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/scrolledtext.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/selectionbox.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/selectiondialog.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/shell.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/spindate.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/spinint.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/spinner.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/spintime.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/tabnotebook.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/tabset.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/timeentry.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/timefield.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/toolbar.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/html/watch.n.html
|
||||||
|
lib/%%TCL_PKG%%/demos/hyperhelp
|
||||||
|
lib/%%TCL_PKG%%/demos/images/box.xbm
|
||||||
|
lib/%%TCL_PKG%%/demos/images/clear.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/close.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/copy.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/cut.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/exit.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/find.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/help.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/line.xbm
|
||||||
|
lib/%%TCL_PKG%%/demos/images/mag.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/new.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/open.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/oval.xbm
|
||||||
|
lib/%%TCL_PKG%%/demos/images/paste.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/points.xbm
|
||||||
|
lib/%%TCL_PKG%%/demos/images/poly.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/print.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/ruler.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/save.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/select.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/images/text.xbm
|
||||||
|
lib/%%TCL_PKG%%/demos/iwidgets.gif
|
||||||
|
lib/%%TCL_PKG%%/demos/labeledframe
|
||||||
|
lib/%%TCL_PKG%%/demos/labeledwidget
|
||||||
|
lib/%%TCL_PKG%%/demos/mainwindow
|
||||||
|
lib/%%TCL_PKG%%/demos/menubar
|
||||||
|
lib/%%TCL_PKG%%/demos/messagebox
|
||||||
|
lib/%%TCL_PKG%%/demos/messagedialog
|
||||||
|
lib/%%TCL_PKG%%/demos/notebook
|
||||||
|
lib/%%TCL_PKG%%/demos/optionmenu
|
||||||
|
lib/%%TCL_PKG%%/demos/panedwindow
|
||||||
|
lib/%%TCL_PKG%%/demos/promptdialog
|
||||||
|
lib/%%TCL_PKG%%/demos/pushbutton
|
||||||
|
lib/%%TCL_PKG%%/demos/radiobox
|
||||||
|
lib/%%TCL_PKG%%/demos/scopedobject
|
||||||
|
lib/%%TCL_PKG%%/demos/scrolledcanvas
|
||||||
|
lib/%%TCL_PKG%%/demos/scrolledframe
|
||||||
|
lib/%%TCL_PKG%%/demos/scrolledhtml
|
||||||
|
lib/%%TCL_PKG%%/demos/scrolledlistbox
|
||||||
|
lib/%%TCL_PKG%%/demos/scrolledtext
|
||||||
|
lib/%%TCL_PKG%%/demos/selectionbox
|
||||||
|
lib/%%TCL_PKG%%/demos/selectiondialog
|
||||||
|
lib/%%TCL_PKG%%/demos/shell
|
||||||
|
lib/%%TCL_PKG%%/demos/spindate
|
||||||
|
lib/%%TCL_PKG%%/demos/spinint
|
||||||
|
lib/%%TCL_PKG%%/demos/spinner
|
||||||
|
lib/%%TCL_PKG%%/demos/spintime
|
||||||
|
lib/%%TCL_PKG%%/demos/tabnotebook
|
||||||
|
lib/%%TCL_PKG%%/demos/tabset
|
||||||
|
lib/%%TCL_PKG%%/demos/timeentry
|
||||||
|
lib/%%TCL_PKG%%/demos/timefield
|
||||||
|
lib/%%TCL_PKG%%/demos/toolbar
|
||||||
|
lib/%%TCL_PKG%%/demos/watch
|
||||||
|
lib/%%TCL_PKG%%/iwidgets.tcl
|
||||||
|
lib/%%TCL_PKG%%/license.terms
|
||||||
|
lib/%%TCL_PKG%%/pkgIndex.tcl
|
||||||
|
lib/%%TCL_PKG%%/scripts/buttonbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/calendar.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/canvasprintbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/canvasprintdialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/checkbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/colors.itcl
|
||||||
|
lib/%%TCL_PKG%%/scripts/combobox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/dateentry.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/datefield.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/dialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/dialogshell.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/disjointlistbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/entryfield.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/extbutton.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/extfileselectionbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/extfileselectiondialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/feedback.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/fileselectionbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/fileselectiondialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/finddialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/hierarchy.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/hyperhelp.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/labeledframe.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/labeledwidget.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/mainwindow.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/menubar.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/messagebox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/messagedialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/notebook.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/optionmenu.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/pane.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/panedwindow.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/promptdialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/pushbutton.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/radiobox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/regexpfield.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/roman.itcl
|
||||||
|
lib/%%TCL_PKG%%/scripts/scopedobject.itcl
|
||||||
|
lib/%%TCL_PKG%%/scripts/scrolledcanvas.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/scrolledframe.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/scrolledhtml.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/scrolledlistbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/scrolledtext.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/scrolledwidget.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/selectionbox.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/selectiondialog.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/shell.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/spindate.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/spinint.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/spinner.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/spintime.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/tabnotebook.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/tabset.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/tclIndex
|
||||||
|
lib/%%TCL_PKG%%/scripts/timeentry.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/timefield.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/toolbar.itk
|
||||||
|
lib/%%TCL_PKG%%/scripts/unknownimage.gif
|
||||||
|
lib/%%TCL_PKG%%/scripts/watch.itk
|
||||||
share/man/mann/iwidgets_buttonbox.n.gz
|
share/man/mann/iwidgets_buttonbox.n.gz
|
||||||
share/man/mann/iwidgets_calendar.n.gz
|
share/man/mann/iwidgets_calendar.n.gz
|
||||||
share/man/mann/iwidgets_canvasprintbox.n.gz
|
share/man/mann/iwidgets_canvasprintbox.n.gz
|
||||||
|
|
Loading…
Add table
Reference in a new issue