mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
net/ortp: Update version 5.2.94=>5.4.2
Changelog: https://gitlab.linphone.org/BC/public/ortp/-/tags/5.4.2 Approved by: portmgr (blanket) Sponsored by: Cybermancer Infosec
This commit is contained in:
parent
8c506cacbf
commit
43a9d3225a
4 changed files with 50 additions and 17 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= ortp
|
PORTNAME= ortp
|
||||||
DISTVERSION= 5.2.94
|
DISTVERSION= 5.4.2
|
||||||
CATEGORIES= net
|
CATEGORIES= net
|
||||||
|
|
||||||
MAINTAINER= zirias@FreeBSD.org
|
MAINTAINER= zirias@FreeBSD.org
|
||||||
|
@ -9,16 +9,20 @@ WWW= https://www.linphone.org/technical-corner/ortp.html
|
||||||
LICENSE= GPLv3
|
LICENSE= GPLv3
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||||
|
|
||||||
LIB_DEPENDS= libbctoolbox.so:net/bctoolbox
|
BUILD_DEPENDS= ${LOCALBASE}/lib/libbctoolbox.a:net/bctoolbox \
|
||||||
|
${LOCALBASE}/lib/libbcunit.a:devel/bcunit
|
||||||
|
|
||||||
USES= cmake compiler:c11
|
USES= cmake compiler:c11 ssl
|
||||||
USE_GITLAB= yes
|
USE_GITLAB= yes
|
||||||
GL_SITE= https://gitlab.linphone.org/BC
|
GL_SITE= https://gitlab.linphone.org/BC
|
||||||
GL_ACCOUNT= public
|
GL_ACCOUNT= public
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
CMAKE_ARGS= -DENABLE_DOC=NO -DENABLE_STATIC=NO -DENABLE_STRICT=NO \
|
CMAKE_ARGS= -DENABLE_DOC=NO -DENABLE_STRICT=NO \
|
||||||
-DCMAKE_PREFIX_PATH=${LOCALBASE}
|
-DCMAKE_PREFIX_PATH=${LOCALBASE} \
|
||||||
|
-DENABLE_UNIT_TESTS=NO
|
||||||
|
|
||||||
|
LDFLAGS+= -lpthread
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${RM} -r ${STAGEDIR}${PREFIX}/share/doc/${DISTNAME}
|
${RM} -r ${STAGEDIR}${PREFIX}/share/doc/${DISTNAME}
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1690555316
|
TIMESTAMP = 1743011710
|
||||||
SHA256 (ortp-5.2.94.tar.bz2) = b210f5f38b89e958e0c540caac56565b5eb5ea0e8fb291a379ed7aa72667d4b4
|
SHA256 (ortp-5.4.2.tar.bz2) = 8c57e58837207953e6c3da29421b603e6c922f889ea3f03d3124b818dc82f044
|
||||||
SIZE (ortp-5.2.94.tar.bz2) = 200732
|
SIZE (ortp-5.4.2.tar.bz2) = 265600
|
||||||
|
|
33
net/ortp/files/patch-CMakeLists.txt
Normal file
33
net/ortp/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
--- CMakeLists.txt.orig 2025-03-26 18:04:42 UTC
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
############################################################################
|
||||||
|
# Copyright (c) 2010-2023 Belledonne Communications SARL.
|
||||||
|
#
|
||||||
|
-# This file is part of oRTP
|
||||||
|
+# This file is part of oRTP
|
||||||
|
# (see https://gitlab.linphone.org/BC/public/ortp).
|
||||||
|
#
|
||||||
|
############################################################################
|
||||||
|
@@ -62,6 +62,7 @@ find_library(LIBM NAMES m)
|
||||||
|
find_package(Threads)
|
||||||
|
find_library(LIBM NAMES m)
|
||||||
|
|
||||||
|
+find_package(OpenSSL REQUIRED)
|
||||||
|
find_package(BCToolbox 5.3.0 REQUIRED)
|
||||||
|
#Mandatory to init default compilation flags
|
||||||
|
bc_init_compilation_flags(STRICT_OPTIONS_CPP STRICT_OPTIONS_C STRICT_OPTIONS_CXX ENABLE_STRICT)
|
||||||
|
@@ -217,9 +218,9 @@ install(EXPORT ${PROJECT_NAME}Targets
|
||||||
|
DESTINATION ${CMAKE_MODULES_INSTALL_DIR}
|
||||||
|
)
|
||||||
|
|
||||||
|
-install(FILES "${PROJECT_SOURCE_DIR}/README.md"
|
||||||
|
- "${PROJECT_SOURCE_DIR}/CHANGELOG.md"
|
||||||
|
- "${PROJECT_SOURCE_DIR}/LICENSE.txt"
|
||||||
|
- "${PROJECT_SOURCE_DIR}/AUTHORS.md"
|
||||||
|
+install(FILES "${PROJECT_SOURCE_DIR}/README.md"
|
||||||
|
+ "${PROJECT_SOURCE_DIR}/CHANGELOG.md"
|
||||||
|
+ "${PROJECT_SOURCE_DIR}/LICENSE.txt"
|
||||||
|
+ "${PROJECT_SOURCE_DIR}/AUTHORS.md"
|
||||||
|
DESTINATION "${CMAKE_INSTALL_DATADIR}/doc/ortp-${ORTP_VERSION}"
|
||||||
|
)
|
|
@ -1,7 +1,4 @@
|
||||||
bin/ortp_tester
|
|
||||||
include/ortp/b64.h
|
|
||||||
include/ortp/event.h
|
include/ortp/event.h
|
||||||
include/ortp/fecstream.h
|
|
||||||
include/ortp/logging.h
|
include/ortp/logging.h
|
||||||
include/ortp/nack.h
|
include/ortp/nack.h
|
||||||
include/ortp/ortp.h
|
include/ortp/ortp.h
|
||||||
|
@ -16,10 +13,9 @@ include/ortp/sessionset.h
|
||||||
include/ortp/str_utils.h
|
include/ortp/str_utils.h
|
||||||
include/ortp/telephonyevents.h
|
include/ortp/telephonyevents.h
|
||||||
include/ortp/utils.h
|
include/ortp/utils.h
|
||||||
lib/cmake/ortp/ortpConfig.cmake
|
share/Ortp/cmake/OrtpConfig.cmake
|
||||||
lib/cmake/ortp/ortpConfigVersion.cmake
|
share/Ortp/cmake/OrtpConfigVersion.cmake
|
||||||
lib/cmake/ortp/ortpTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
share/Ortp/cmake/OrtpTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||||
lib/cmake/ortp/ortpTargets.cmake
|
share/Ortp/cmake/OrtpTargets.cmake
|
||||||
lib/libortp.so
|
lib/libortp.a
|
||||||
lib/libortp.so.15
|
|
||||||
libdata/pkgconfig/ortp.pc
|
libdata/pkgconfig/ortp.pc
|
||||||
|
|
Loading…
Add table
Reference in a new issue