mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
science/py-gpaw: update 22.1.0 → 24.6.0
This commit is contained in:
parent
2a072b8f98
commit
424ad1cc02
3 changed files with 8 additions and 22 deletions
|
@ -1,13 +1,13 @@
|
||||||
PORTNAME= gpaw
|
PORTNAME= gpaw
|
||||||
DISTVERSION= 22.1.0
|
DISTVERSION= 24.6.0
|
||||||
PORTREVISION= 6
|
|
||||||
CATEGORIES= science python
|
CATEGORIES= science python
|
||||||
MASTER_SITES= PYPI
|
MASTER_SITES= PYPI
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
|
||||||
MAINTAINER= yuri@FreeBSD.org
|
MAINTAINER= yuri@FreeBSD.org
|
||||||
COMMENT= DFT and beyond within the projector-augmented wave method in chemistry
|
COMMENT= DFT and beyond within the projector-augmented wave method in chemistry
|
||||||
WWW= https://wiki.fysik.dtu.dk/gpaw/
|
WWW= https://wiki.fysik.dtu.dk/gpaw/ \
|
||||||
|
https://gitlab.com/gpaw/gpaw
|
||||||
|
|
||||||
LICENSE= GPLv3+
|
LICENSE= GPLv3+
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||||
|
@ -20,7 +20,7 @@ LIB_DEPENDS= libblas.so:math/blas \
|
||||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ase>0:science/py-ase@${PY_FLAVOR} \
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ase>0:science/py-ase@${PY_FLAVOR} \
|
||||||
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
|
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
|
||||||
${PYNUMPY} \
|
${PYNUMPY} \
|
||||||
${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR} \
|
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
|
||||||
gpaw-setups>0:science/gpaw-setups
|
gpaw-setups>0:science/gpaw-setups
|
||||||
|
|
||||||
USES= gettext-runtime localbase python shebangfix
|
USES= gettext-runtime localbase python shebangfix
|
||||||
|
@ -30,13 +30,10 @@ SHEBANG_FILES= tools/*
|
||||||
|
|
||||||
LDFLAGS= -lmpi # otherwise: ImportError: /usr/local/lib/python3.8/site-packages/_gpaw.cpython-38.so: Undefined symbol "MPI_Comm_rank"
|
LDFLAGS= -lmpi # otherwise: ImportError: /usr/local/lib/python3.8/site-packages/_gpaw.cpython-38.so: Undefined symbol "MPI_Comm_rank"
|
||||||
|
|
||||||
post-patch:
|
|
||||||
@${REINPLACE_CMD} "s|'/usr/local/|'${LOCALBASE}/|" ${WRKSRC}/gpaw/__init__.py
|
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_gpaw*.so
|
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_gpaw*.so
|
||||||
|
|
||||||
do-test: install
|
do-test: install # tests fail to run, see https://gitlab.com/gpaw/gpaw/-/issues/1273
|
||||||
@${ECHO} "== Performing a test calculation on one CPU =="
|
@${ECHO} "== Performing a test calculation on one CPU =="
|
||||||
@gpaw test
|
@gpaw test
|
||||||
@${ECHO} "== Performing a test calculation on 8 CPUs =="
|
@${ECHO} "== Performing a test calculation on 8 CPUs =="
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1642067411
|
TIMESTAMP = 1731548138
|
||||||
SHA256 (gpaw-22.1.0.tar.gz) = 2d2509e9e4b23205f5576ddfd1b0e9d9ac8cea1cf80ae1216af29513bd3cc42a
|
SHA256 (gpaw-24.6.0.tar.gz) = fb48ef0db48c0e321ce5967126a47900bba20c7efb420d6e7b5459983bd8f6f6
|
||||||
SIZE (gpaw-22.1.0.tar.gz) = 1625694
|
SIZE (gpaw-24.6.0.tar.gz) = 2000567
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- setup.py.orig 2022-01-12 10:11:02 UTC
|
|
||||||
+++ setup.py
|
|
||||||
@@ -113,7 +113,7 @@ if compiler is not None:
|
|
||||||
from sysconfig import get_config_vars
|
|
||||||
|
|
||||||
# If CC is set then the following hack will not work
|
|
||||||
- assert not os.environ.get('CC'), 'Please unset CC'
|
|
||||||
+ #assert not os.environ.get('CC'), 'Please unset CC'
|
|
||||||
|
|
||||||
vars = get_config_vars()
|
|
||||||
for key in ['CC', 'LDSHARED']:
|
|
Loading…
Add table
Reference in a new issue