audio/noise-suppression-for-voice-lv2: update 1.03 → 1.10

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2024-05-19 23:02:31 -07:00
parent c1da3eda49
commit 40d2c05bc2
4 changed files with 19 additions and 25 deletions

View file

@ -1,7 +1,6 @@
PORTNAME= noise-suppression-for-voice PORTNAME= noise-suppression-for-voice
DISTVERSIONPREFIX= v DISTVERSIONPREFIX= v
DISTVERSION= 1.03 DISTVERSION= 1.10
PORTREVISION= 2
CATEGORIES= audio CATEGORIES= audio
PKGNAMESUFFIX= -lv2 PKGNAMESUFFIX= -lv2
@ -27,6 +26,7 @@ GH_ACCOUNT= werman
EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/external/JUCE \ EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/external/JUCE \
--no-same-owner --no-same-permissions --no-same-owner --no-same-permissions
CMAKE_ON= USE_SYSTEM_JUCE
CMAKE_OFF= BUILD_TESTS CMAKE_OFF= BUILD_TESTS
CMAKE_OFF+= BUILD_VST_PLUGIN # https://github.com/werman/noise-suppression-for-voice/issues/65 CMAKE_OFF+= BUILD_VST_PLUGIN # https://github.com/werman/noise-suppression-for-voice/issues/65
CXXFLAGS+= -DJUCE_CUSTOM_VST3_SDK=1 -DJUCE_INCLUDE_PNGLIB_CODE=0 CXXFLAGS+= -DJUCE_CUSTOM_VST3_SDK=1 -DJUCE_INCLUDE_PNGLIB_CODE=0

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1686287620 TIMESTAMP = 1716182553
SHA256 (werman-noise-suppression-for-voice-v1.03_GH0.tar.gz) = 8c85cae3ebbb3a18facc38930a3b67ca90e3ad609526a0018c71690de35baf04 SHA256 (werman-noise-suppression-for-voice-v1.10_GH0.tar.gz) = 6e0c11aeb8392891750b0243c2ba695dab07654bf3f4e01adbed927b36cc690a
SIZE (werman-noise-suppression-for-voice-v1.03_GH0.tar.gz) = 19486457 SIZE (werman-noise-suppression-for-voice-v1.10_GH0.tar.gz) = 37315188

View file

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2022-07-28 08:24:44 UTC --- CMakeLists.txt.orig 2024-05-18 14:43:53 UTC
+++ CMakeLists.txt +++ CMakeLists.txt
@@ -4,7 +4,7 @@ cmake_minimum_required(VERSION 3.6) @@ -4,7 +4,7 @@ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}
include(GNUInstallDirs) include(GNUInstallDirs)
set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib) set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
@ -9,12 +9,13 @@
set(CMAKE_BINARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin) set(CMAKE_BINARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
set(MINGW_ADDITIONAL_LINKING_FLAGS "-static-libgcc -static-libstdc++ -Wl,-Bstatic -lstdc++ -lpthread -Wl,-Bdynamic") set(MINGW_ADDITIONAL_LINKING_FLAGS "-static-libgcc -static-libstdc++ -Wl,-Bstatic -lstdc++ -lpthread -Wl,-Bdynamic")
@@ -35,6 +35,7 @@ if (BUILD_VST_PLUGIN OR BUILD_VST3_PLUGIN OR BUILD_LV2 @@ -36,7 +36,8 @@ if (BUILD_VST_PLUGIN OR BUILD_VST3_PLUGIN OR BUILD_LV2
# For install JUCE copies all its headers, no one needs them. It also doesn't install actual libraries.
# On the other hand JUCE could install libraries during build process (see COPY_PLUGIN_AFTER_BUILD option). if (BUILD_VST_PLUGIN OR BUILD_VST3_PLUGIN OR BUILD_LV2_PLUGIN OR BUILD_AU_PLUGIN OR BUILD_AUV3_PLUGIN)
# So we have to manually install plugins. if (USE_SYSTEM_JUCE)
- add_subdirectory(external/JUCE EXCLUDE_FROM_ALL) - find_package(JUCE)
+ #add_subdirectory(external/JUCE EXCLUDE_FROM_ALL) + find_package(JUCE REQUIRED)
+ find_package(JUCE REQUIRED) + message("-- Found JUCE Version=${JUCE_VERSION}")
add_subdirectory(src/juce_plugin) else ()
endif () # For install JUCE copies all its headers, no one needs them. It also doesn't install actual libraries.
# On the other hand JUCE could install libraries during build process (see COPY_PLUGIN_AFTER_BUILD option).

View file

@ -1,6 +1,6 @@
--- src/juce_plugin/CMakeLists.txt.orig 2022-07-28 08:24:44 UTC --- src/juce_plugin/CMakeLists.txt.orig 2024-05-18 14:43:53 UTC
+++ src/juce_plugin/CMakeLists.txt +++ src/juce_plugin/CMakeLists.txt
@@ -87,14 +89,14 @@ function(compile_plugins formats suffix default_channe @@ -88,14 +88,14 @@ function(compile_plugins formats suffix default_channe
# JUCE has a terrible idea of installing plugin during the BUILD process instead of during the INSTALL, # JUCE has a terrible idea of installing plugin during the BUILD process instead of during the INSTALL,
# also JUCE wants to install its headers which we don't want at all. # also JUCE wants to install its headers which we don't want at all.
# So it's easier to handle it ourselves. # So it's easier to handle it ourselves.
@ -19,10 +19,3 @@
endif () endif ()
endforeach () endforeach ()
endif () endif ()
@@ -135,4 +137,4 @@ endif ()
if (FORMATS)
compile_plugins("${FORMATS}" "" 1)
-endif ()
\ No newline at end of file
+endif ()