finance/chiapos: Update to 1.0.7

PR:		260190
Reported by:	risner <risner@stdio.com> (maintainer)
This commit is contained in:
risner 2025-04-24 02:00:42 +00:00 committed by Wen Heping
parent 271cb6e766
commit 4050acabd7
5 changed files with 47 additions and 44 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= chiapos PORTNAME= chiapos
DISTVERSION= 1.0.3 DISTVERSION= 1.0.7
CATEGORIES= finance CATEGORIES= finance
MASTER_SITES= PYPI MASTER_SITES= PYPI
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@ -20,6 +20,8 @@ LICENSE_DISTFILES_MIT= ${DISTNAME}${EXTRACT_SUFX} ${DISTFILE_c} \
NOT_FOR_ARCHS= i386 powerpc NOT_FOR_ARCHS= i386 powerpc
BUILD_DEPENDS= catch>0:devel/catch
USES= cmake:noninja USES= cmake:noninja
USE_GITHUB= nodefault USE_GITHUB= nodefault
GH_TUPLE= jarro2783:cxxopts:302302b30839505703d37fb82f536c53cf9172fa:c/src-ext/cxxopts \ GH_TUPLE= jarro2783:cxxopts:302302b30839505703d37fb82f536c53cf9172fa:c/src-ext/cxxopts \
@ -31,8 +33,6 @@ PLIST_FILES= bin/ProofOfSpace \
post-extract: post-extract:
# This example is experimental, currently broken (upstream) and unnecessary. # This example is experimental, currently broken (upstream) and unnecessary.
# The placeholder Makefile is for when/if they release a future fixed version.
@${CP} ${FILESDIR}/Hellman-Makefile ${WRKSRC}/hellman_example/Makefile
# Remove extraneous unused files to prevent confusion # Remove extraneous unused files to prevent confusion
@${RM} ${WRKSRC}/lib/FiniteStateEntropy/fetch-content-CMakeLists.txt @${RM} ${WRKSRC}/lib/FiniteStateEntropy/fetch-content-CMakeLists.txt
@${RM} ${WRKSRC}/pyproject.toml @${RM} ${WRKSRC}/pyproject.toml

View file

@ -1,6 +1,6 @@
TIMESTAMP = 1623067298 TIMESTAMP = 1638584475
SHA256 (chiapos-1.0.3.tar.gz) = d987b481a3acbff1e0d77eb713af8d99ecec2bd11c2c465528a5078a433686bd SHA256 (chiapos-1.0.7.tar.gz) = 1e10ce00730d293ed83ed3a3c630d525c9256fe4e31e64abbda7aa054b8a753f
SIZE (chiapos-1.0.3.tar.gz) = 1291513 SIZE (chiapos-1.0.7.tar.gz) = 1168757
SHA256 (jarro2783-cxxopts-302302b30839505703d37fb82f536c53cf9172fa_GH0.tar.gz) = 74e21646f3278243c9466665794d45410e63453ab7f3652acdae1d62efc4b21d SHA256 (jarro2783-cxxopts-302302b30839505703d37fb82f536c53cf9172fa_GH0.tar.gz) = 74e21646f3278243c9466665794d45410e63453ab7f3652acdae1d62efc4b21d
SIZE (jarro2783-cxxopts-302302b30839505703d37fb82f536c53cf9172fa_GH0.tar.gz) = 89640 SIZE (jarro2783-cxxopts-302302b30839505703d37fb82f536c53cf9172fa_GH0.tar.gz) = 89640
SHA256 (gulrak-filesystem-4e21ab305794f5309a1454b4ae82ab9a0f5e0d25_GH0.tar.gz) = fef3e809d584b77fd3ec677bd0d40cbe6737bbb3dbb1570fe1b2025262ea82c2 SHA256 (gulrak-filesystem-4e21ab305794f5309a1454b4ae82ab9a0f5e0d25_GH0.tar.gz) = fef3e809d584b77fd3ec677bd0d40cbe6737bbb3dbb1570fe1b2025262ea82c2

View file

@ -1,17 +1,21 @@
--- CMakeLists.txt.orig 2021-05-28 02:40:44 UTC --- CMakeLists.txt.orig 2021-12-03 19:59:40 UTC
+++ CMakeLists.txt +++ CMakeLists.txt
@@ -14,29 +14,7 @@ endif() @@ -14,33 +14,7 @@ endif()
project(chiapos C CXX ASM) project(chiapos C CXX ASM)
# CMake 3.14+ # CMake 3.14+
-include(FetchContent) -include(FetchContent)
-if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-include(${CMAKE_INSTALL_PREFIX}/share/cmake/pybind11/pybind11Config.cmake)
-else()
-FetchContent_Declare( -FetchContent_Declare(
- pybind11-src - pybind11-src
- GIT_REPOSITORY https://github.com/pybind/pybind11.git - GIT_REPOSITORY https://github.com/pybind/pybind11.git
- GIT_TAG v2.6.2 - GIT_TAG v2.7.1
-) -)
-FetchContent_MakeAvailable(pybind11-src) -FetchContent_MakeAvailable(pybind11-src)
-endif()
- -
-FetchContent_Declare( -FetchContent_Declare(
- cxxopts - cxxopts
@ -30,9 +34,11 @@
set(FSE_LIB ${CMAKE_CURRENT_SOURCE_DIR}/lib/FiniteStateEntropy/lib) set(FSE_LIB ${CMAKE_CURRENT_SOURCE_DIR}/lib/FiniteStateEntropy/lib)
set(FSE_FILES set(FSE_FILES
${FSE_LIB}/fse_compress.c ${FSE_LIB}/fse_compress.c
@@ -48,8 +26,8 @@ set(FSE_FILES @@ -51,9 +25,10 @@ set(FSE_FILES
include_directories( include_directories(
${INCLUDE_DIRECTORIES} ${INCLUDE_DIRECTORIES}
+ ${CMAKE_INSTALL_PREFIX}/include
${CMAKE_CURRENT_SOURCE_DIR}/../lib/include ${CMAKE_CURRENT_SOURCE_DIR}/../lib/include
- ${cxxopts_SOURCE_DIR}/include - ${cxxopts_SOURCE_DIR}/include
- ${gulrak_SOURCE_DIR}/include/ghc - ${gulrak_SOURCE_DIR}/include/ghc
@ -41,7 +47,7 @@
${CMAKE_CURRENT_SOURCE_DIR}/../lib/FiniteStateEntropy/lib ${CMAKE_CURRENT_SOURCE_DIR}/../lib/FiniteStateEntropy/lib
${CMAKE_CURRENT_SOURCE_DIR}/src ${CMAKE_CURRENT_SOURCE_DIR}/src
${CMAKE_CURRENT_SOURCE_DIR}/test ${CMAKE_CURRENT_SOURCE_DIR}/test
@@ -130,8 +108,6 @@ set(BLAKE3_SRC @@ -134,8 +109,6 @@ set(BLAKE3_SRC
) )
ENDIF() ENDIF()
@ -50,8 +56,25 @@
add_executable(ProofOfSpace add_executable(ProofOfSpace
src/cli.cpp src/cli.cpp
src/chacha8.c src/chacha8.c
@@ -145,33 +121,30 @@ add_executable(RunTests @@ -148,13 +121,6 @@ IF (BUILD_PROOF_OF_SPACE_STATICALLY)
${BLAKE3_SRC} target_link_libraries(ProofOfSpace -static -Wl,--whole-archive -lrt -lpthread -Wl,--no-whole-archive)
ENDIF()
-FetchContent_Declare(
- Catch2
- GIT_REPOSITORY https://github.com/catchorg/Catch2.git
- GIT_TAG v2.13.7
-)
-FetchContent_MakeAvailable(Catch2)
-
add_executable(RunTests
tests/test-main.cpp
tests/test.cpp
@@ -166,18 +132,20 @@ target_link_libraries(RunTests
PRIVATE
fse
Threads::Threads
- Catch2::Catch2
) )
+install(TARGETS ProofOfSpace DESTINATION bin) +install(TARGETS ProofOfSpace DESTINATION bin)
@ -66,24 +89,17 @@
-target_compile_features(chiapos PUBLIC cxx_std_17) -target_compile_features(chiapos PUBLIC cxx_std_17)
target_compile_features(RunTests PUBLIC cxx_std_17) target_compile_features(RunTests PUBLIC cxx_std_17)
+
if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin") if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
- target_link_libraries(chiapos PRIVATE fse Threads::Threads) target_link_libraries(chiapos PRIVATE fse Threads::Threads)
target_link_libraries(ProofOfSpace fse Threads::Threads) target_link_libraries(ProofOfSpace fse Threads::Threads)
target_link_libraries(RunTests fse Threads::Threads) @@ -185,8 +153,8 @@ elseif (${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
elseif (${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD") target_link_libraries(chiapos PRIVATE fse Threads::Threads)
- target_link_libraries(chiapos PRIVATE fse Threads::Threads)
target_link_libraries(ProofOfSpace fse Threads::Threads) target_link_libraries(ProofOfSpace fse Threads::Threads)
target_link_libraries(RunTests fse Threads::Threads)
elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD") elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
- target_link_libraries(chiapos PRIVATE fse Threads::Threads) - target_link_libraries(chiapos PRIVATE fse Threads::Threads)
target_link_libraries(ProofOfSpace fse Threads::Threads) target_link_libraries(ProofOfSpace fse Threads::Threads)
target_link_libraries(RunTests fse Threads::Threads) + include(${CMAKE_INSTALL_PREFIX}/lib/cmake/Catch2/Catch.cmake)
elseif (MSVC) elseif (MSVC)
- target_link_libraries(chiapos PRIVATE fse Threads::Threads uint128) target_link_libraries(chiapos PRIVATE fse Threads::Threads uint128)
target_link_libraries(ProofOfSpace fse Threads::Threads uint128) target_link_libraries(ProofOfSpace fse Threads::Threads uint128)
target_link_libraries(RunTests fse Threads::Threads uint128)
else()
- target_link_libraries(chiapos PRIVATE fse stdc++fs Threads::Threads)
target_link_libraries(ProofOfSpace fse stdc++fs Threads::Threads)
target_link_libraries(RunTests fse stdc++fs Threads::Threads)
endif()

View file

@ -1,6 +1,6 @@
--- setup.py.orig 2021-05-28 02:40:44 UTC --- setup.py.orig 2025-04-24 01:51:48 UTC
+++ setup.py +++ setup.py
@@ -107,9 +100,6 @@ ext_modules = [ @@ -107,9 +107,6 @@ ext_modules = [
"src/chacha8.c", "src/chacha8.c",
], ],
include_dirs=[ include_dirs=[
@ -10,21 +10,11 @@
"src", "src",
"uint128_t", "uint128_t",
".", ".",
@@ -202,6 +192,7 @@ if platform.system() == "Windows": @@ -186,6 +183,7 @@ if platform.system() == "Windows":
else: if platform.system() == "Windows":
setup( setup(
name="chiapos", name="chiapos",
+ version="1.0.3", + version="1.0.7",
author="Mariano Sorgente", author="Mariano Sorgente",
author_email="mariano@chia.net", author_email="mariano@chia.net",
description="Chia proof of space plotting, proving, and verifying (wraps C++)", description="Chia proof of space plotting, proving, and verifying (wraps C++)",
@@ -209,8 +200,7 @@ else:
python_requires=">=3.7",
long_description=open("README.md").read(),
long_description_content_type="text/markdown",
- url="https://github.com/Chia-Network/chiavdf",
- ext_modules=[CMakeExtension("chiapos", ".")],
+ url="https://github.com/Chia-Network/chiapos",
cmdclass=dict(build_ext=CMakeBuild),
zip_safe=False,
)

View file

@ -2,7 +2,4 @@ Chia's proof of space is written in C++. Includes a plotter, prover, and
verifier. It exclusively runs on 64 bit architectures. Read the Proof of verifier. It exclusively runs on 64 bit architectures. Read the Proof of
Space document to learn about what proof of space is and how it works. Space document to learn about what proof of space is and how it works.
Notes:
i386 is not supported, and would be too slow for practical use if supported.
This port is for the cmake build (binaries). This port is for the cmake build (binaries).