security/pinentry: Update to 1.3.1

https://dev.gnupg.org/T7046
This commit is contained in:
Jason E. Hale 2024-07-06 00:59:24 -04:00
parent c1dda71dec
commit 3e5923de1a
15 changed files with 79 additions and 21 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= Curses version of the GnuPG password dialog

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= EFL version of the GnuPG password dialog

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= FLTK version of the GnuPG password dialog

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= GNOME version of the GnuPG password dialog

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= GTK 2.0 version of the GnuPG password dialog

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= Qt 5 version of the GnuPG password dialog

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= Qt 6 version of the GnuPG password dialog

View file

@ -1,5 +1,5 @@
PORTNAME= pinentry
PORTREVISION= 1
PORTREVISION= 0
COMMENT= Console version of the GnuPG password dialog

View file

@ -1,12 +1,9 @@
PORTNAME= pinentry
PORTVERSION= 1.3.0
PORTVERSION= 1.3.1
PORTREVISION?= 0
CATEGORIES= security
MASTER_SITES= GNUPG/pinentry
PATCH_SITES= https://github.com/gpg/pinentry/commit/
PATCHFILES+= 844360c9c99d2f11dc4236c0ab6bdb9b56758898.patch:-p1
MAINTAINER= jhale@FreeBSD.org
COMMENT?= Collection of simple PIN or passphrase entry dialogs
WWW= https://www.gnupg.org/aegypten2
@ -117,7 +114,8 @@ USE_KDE= wayland
USE_QT= core gui widgets x11extras buildtools:build
USE_XORG= x11
PLIST_FILES= bin/pinentry-qt5 \
share/applications/org.gnupg.pinentry-qt5.desktop
share/applications/org.gnupg.pinentry-qt5.desktop \
share/pixmaps/pinentry-qt5.png
CONFIGURE_ARGS+=--enable-pinentry-qt5
.else
CONFIGURE_ARGS+=--disable-pinentry-qt5
@ -129,7 +127,8 @@ USE_CXXSTD= c++17
USE_KDE= guiaddons windowsystem
USE_QT= base
PLIST_FILES= bin/pinentry-qt \
share/applications/org.gnupg.pinentry-qt.desktop
share/applications/org.gnupg.pinentry-qt.desktop \
share/pixmaps/pinentry.png
CONFIGURE_ARGS+=--enable-pinentry-qt
.else
CONFIGURE_ARGS+=--disable-pinentry-qt
@ -171,6 +170,10 @@ CONFIGURE_ARGS+=--enable-pinentry-tty
CONFIGURE_ARGS+=--disable-pinentry-tty
.endif
# Rename icon to prevent install conflicts with the Qt6 frontend.
post-extract:
@(cd ${WRKSRC}/qt5/icons && ${MV} pinentry.png pinentry-qt5.png)
post-install:
${RM} ${STAGEDIR}${PREFIX}/bin/pinentry \
${STAGEDIR}${PREFIX}/share/info/pinentry.info

View file

@ -1,5 +1,3 @@
TIMESTAMP = 1712087076
SHA256 (pinentry-1.3.0.tar.bz2) = 9b3cd5226e7597f2fded399a3bc659923351536559e9db0826981bca316494de
SIZE (pinentry-1.3.0.tar.bz2) = 610363
SHA256 (844360c9c99d2f11dc4236c0ab6bdb9b56758898.patch) = 80804d34202a3c8c700226e77431cd4585b760de038bd84d3a1ae9813f25d924
SIZE (844360c9c99d2f11dc4236c0ab6bdb9b56758898.patch) = 3846
TIMESTAMP = 1720239644
SHA256 (pinentry-1.3.1.tar.bz2) = bc72ee27c7239007ab1896c3c2fae53b076e2c9bd2483dc2769a16902bce8c04
SIZE (pinentry-1.3.1.tar.bz2) = 611233

View file

@ -0,0 +1,19 @@
Rename icon to prevent install conflicts with the Qt6 frontend.
--- qt5/icons/Makefile.in.orig 2024-07-03 09:29:09 UTC
+++ qt5/icons/Makefile.in
@@ -350,12 +350,12 @@ EXTRA_DIST = data-error.svg \
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
EXTRA_DIST = data-error.svg \
- pinentry.png \
+ pinentry-qt5.png \
hint.svg \
password-generate.svg \
visibility.svg
-icons_DATA = pinentry.png
+icons_DATA = pinentry-qt5.png
iconsdir = $(datadir)/pixmaps
all: all-am

View file

@ -0,0 +1,13 @@
Rename icon to prevent install conflicts with the Qt6 frontend.
--- qt5/main.cpp.orig 2024-07-03 09:19:19 UTC
+++ qt5/main.cpp
@@ -422,7 +422,7 @@ main(int argc, char *argv[])
new_argc = argc;
Q_ASSERT (new_argc);
app = new QApplication(new_argc, new_argv);
- app->setWindowIcon(QIcon(QLatin1String(":/icons/pinentry.png")));
+ app->setWindowIcon(QIcon(QLatin1String(":/icons/pinentry-qt5.png")));
app->setDesktopFileName(QStringLiteral("org.gnupg.pinentry-qt5"));
(void) new KeyboardFocusIndication{app};
}

View file

@ -0,0 +1,12 @@
Rename icon to prevent install conflicts with the Qt6 frontend.
--- qt5/org.gnupg.pinentry-qt5.desktop.in.orig 2024-07-03 09:19:19 UTC
+++ qt5/org.gnupg.pinentry-qt5.desktop.in
@@ -4,6 +4,6 @@ NoDisplay=true
Categories=Qt;Utility;
Exec=@prefix@/bin/pinentry-qt5
NoDisplay=true
-Icon=pinentry
+Icon=pinentry-qt5
GenericName=Utility for entering GnuPG secrets
X-KDE-Wayland-Interfaces=org_kde_kwin_keystate

View file

@ -0,0 +1,13 @@
Rename icon to prevent install conflicts with the Qt6 frontend.
--- qt5/pinentryrc.qrc.orig 2024-07-03 09:19:19 UTC
+++ qt5/pinentryrc.qrc
@@ -2,7 +2,7 @@
<RCC version="1.0">
<qresource>
<file>icons/data-error.svg</file>
- <file>icons/pinentry.png</file>
+ <file>icons/pinentry-qt5.png</file>
<file>icons/hint.svg</file>
<file>icons/password-generate.svg</file>
<file>icons/visibility.svg</file>

View file

@ -1,6 +1,6 @@
--- secmem/secmem.c.orig 2016-04-14 14:39:51 UTC
--- secmem/secmem.c.orig 2024-02-26 14:24:12 UTC
+++ secmem/secmem.c
@@ -88,7 +88,7 @@ log_fatal(char *template, ...)
@@ -84,7 +84,7 @@ log_fatal(char *template, ...)
# define MAP_ANONYMOUS MAP_ANON
#endif