graphics/qiv: Update to 3.0.1

- Remove dead MASTER_SITES entry
- Move to gtk30
- Move inline patch to the patch file and drop the do-configure target
- Update the patch file and add a header to it

Changelog:
https://codeberg.org/ciberandy/qiv/src/branch/master/Changelog
This commit is contained in:
Danilo Egea Gondolfo 2025-04-24 12:55:56 +01:00
parent ef5d77d184
commit 3666763ec6
3 changed files with 30 additions and 25 deletions

View file

@ -1,9 +1,7 @@
PORTNAME= qiv
PORTVERSION= 2.3.3
PORTREVISION= 7
PORTVERSION= 3.0.1
CATEGORIES= graphics
MASTER_SITES= http://spiegl.de/qiv/download/ \
http://www.predatorlabs.net/dl/
MASTER_SITES= http://spiegl.de/qiv/download/
MAINTAINER= danilo@FreeBSD.org
COMMENT= Small, fast GDK/Imlib2 image viewer
@ -17,18 +15,11 @@ LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
libtiff.so:graphics/tiff
USES= gmake gnome jpeg pkgconfig tar:tgz xorg
USE_GNOME= cairo gdkpixbuf gtk20
USE_GNOME= cairo gdkpixbuf gtk30
PLIST_FILES= bin/qiv share/man/man1/qiv.1.gz
USE_XORG+= x11 xext
do-configure:
@${REINPLACE_CMD} 's|/usr/local|${PREFIX}|; \
s|gcc|${CC}|; \
s|-O2|${CFLAGS}|; \
s|libs-gdk`|libs-gdk` ${LDFLAGS}|;' \
${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/qiv ${STAGEDIR}${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/qiv.1 ${STAGEDIR}${PREFIX}/share/man/man1/

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1675115059
SHA256 (qiv-2.3.3.tgz) = ef085ffde2d48b05b3665939e5ae1e359d3a381008fb827684f7d6fd4c533704
SIZE (qiv-2.3.3.tgz) = 139301
TIMESTAMP = 1745489765
SHA256 (qiv-3.0.1.tgz) = 2b7455e63344b98e4db4ca50ff6982f5f81c309e563014d7401cccf2b3acc6bf
SIZE (qiv-3.0.1.tgz) = 139348

View file

@ -1,13 +1,27 @@
--- Makefile.orig 2017-11-03 18:27:27 UTC
Clang does not support -fthread-jumps as of now.
This fixes "cc: error: unknown argument: '-fthread-jumps'"
Replace hardcoded "gcc" with $CC
Include system $CFLAGS to the local CFLAGS variable
--- Makefile.orig 2025-04-05 22:56:41 UTC
+++ Makefile
@@ -57,8 +57,8 @@ endif
@@ -50,14 +50,13 @@ ifeq ($(origin CC),default)
######################################################################
ifeq ($(origin CC),default)
-CC = gcc
+CC = ${CC}
endif
PKG_CONFIG ?= pkg-config
#CFLAGS = -O0 -g -Wall
CFLAGS = -O2 -Wall \
INSTALL ?= install
-CFLAGS = -O2 -Wall \
- -fcaller-saves -ffast-math -fno-strength-reduce \
- -fthread-jumps #-march=pentium #-DSTAT_MACROS_BROKEN
+ -ffast-math -fno-strength-reduce \
+ #-march=pentium #-DSTAT_MACROS_BROKEN
#CFLAGS = -O2 -Wall -fomit-frame-pointer -finline-functions \
# -fcaller-saves -ffast-math -fno-strength-reduce \
# -fthread-jumps #-march=pentium #-DSTAT_MACROS_BROKEN
- -fthread-jumps
+CFLAGS := ${CFLAGS} -Wall \
+ -fcaller-saves -ffast-math -fno-strength-reduce
GDK_VERS := 3