mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
print/py-reportlab: Update version 3.2.0=>3.5.9
PR: 233017 Submitted by: wenheping2000@hotmail.com Relnotes: https://pypi.org/project/reportlab/#history
This commit is contained in:
parent
0bc13d900c
commit
322e113b8d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=485291
3 changed files with 24 additions and 29 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= reportlab
|
||||
PORTVERSION= 3.2.0
|
||||
PORTVERSION= 3.5.9
|
||||
CATEGORIES= print python
|
||||
MASTER_SITES= CHEESESHOP \
|
||||
http://www.reportlab.com/ftp/
|
||||
|
@ -24,9 +24,7 @@ USE_PYTHON= distutils autoplist
|
|||
CONFLICTS= py*-reportlab[^3]-[^3].* \
|
||||
py*-reportlab-[^3].*
|
||||
|
||||
PORTSCOUT= limit:^3\.0\.
|
||||
|
||||
PFBFER_VERSION= 20070710
|
||||
PFBFER_VERSION= 20180109
|
||||
PFBFER= pfbfer-${PFBFER_VERSION}.zip
|
||||
|
||||
MAKE_ENV= PACKAGE_PATH="${REPORTLABDIR}"
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
SHA256 (reportlab-3.2.0.tar.gz) = 72e687662bd854776407b9108483561831b45546d935df8b0477708199086293
|
||||
SIZE (reportlab-3.2.0.tar.gz) = 1948090
|
||||
SHA256 (pfbfer-20070710.zip) = fb1462ff6ce8efae58a0c496f0537c5ac16d4895c68f1640c2973db574ddb376
|
||||
SIZE (pfbfer-20070710.zip) = 677333
|
||||
TIMESTAMP = 1542585071
|
||||
SHA256 (reportlab-3.5.9.tar.gz) = f92f81314807cd860f29fe07a1a4100b03910ae6bbfca20a07e02c3b460f4f20
|
||||
SIZE (reportlab-3.5.9.tar.gz) = 2837351
|
||||
SHA256 (pfbfer-20180109.zip) = 851b431550e866b217317d09dd33b5535ae081200975ad4dd25e80be2af10fec
|
||||
SIZE (pfbfer-20180109.zip) = 737561
|
||||
|
|
|
@ -1,29 +1,25 @@
|
|||
--- setup.py.orig 2014-02-14 14:22:37 UTC
|
||||
--- setup.py.orig 2018-11-06 07:20:18 UTC
|
||||
+++ setup.py
|
||||
@@ -241,11 +241,7 @@ reportlab_files= [
|
||||
]
|
||||
@@ -288,11 +288,6 @@ reportlab_files= [
|
||||
|
||||
def get_fonts(PACKAGE_DIR, reportlab_files):
|
||||
- import sys, os, os.path, zipfile, io
|
||||
def url2data(url,returnRaw=False):
|
||||
import io
|
||||
- if isPy3:
|
||||
- import urllib.request as ureq
|
||||
- else:
|
||||
- import urllib2 as ureq
|
||||
+ import sys, os, os.path, zipfile
|
||||
rl_dir = PACKAGE_DIR['reportlab']
|
||||
if not [x for x in reportlab_files if not os.path.isfile(pjoin(rl_dir,x))]:
|
||||
infoline("Standard T1 font curves already downloaded")
|
||||
@@ -254,12 +250,7 @@ def get_fonts(PACKAGE_DIR, reportlab_fil
|
||||
infoline('not downloading T1 font curve files')
|
||||
return
|
||||
- remotehandle = ureq.urlopen(url)
|
||||
try:
|
||||
- infoline("Downloading standard T1 font curves")
|
||||
-
|
||||
- remotehandle = ureq.urlopen("http://www.reportlab.com/ftp/pfbfer-20070710.zip")
|
||||
- zipdata = io.BytesIO(remotehandle.read())
|
||||
- remotehandle.close()
|
||||
- archive = zipfile.ZipFile(zipdata)
|
||||
+ archive = zipfile.ZipFile("%%DISTDIR%%/%%PFBFER%%")
|
||||
dst = pjoin(rl_dir, 'fonts')
|
||||
raw = remotehandle.read()
|
||||
return raw if returnRaw else io.BytesIO(raw)
|
||||
@@ -308,9 +303,7 @@ def get_fonts(PACKAGE_DIR, reportlab_files):
|
||||
xitmsg = "not downloading T1 font curve files"
|
||||
else:
|
||||
try:
|
||||
- infoline("Downloading standard T1 font curves")
|
||||
- zipdata = url2data("http://www.reportlab.com/ftp/pfbfer-20180109.zip")
|
||||
- archive = zipfile.ZipFile(zipdata)
|
||||
+ archive = zipfile.ZipFile("%%DISTDIR%%/%%PFBFER%%")
|
||||
dst = pjoin(rl_dir, 'fonts')
|
||||
|
||||
for name in archive.namelist():
|
||||
for name in archive.namelist():
|
||||
|
|
Loading…
Add table
Reference in a new issue