science/arbor: Link statically to the internal libarborsup library

This library is not intended for distribution, but because port passes
BUILD_SHARED_LIBS to cmake this library ends up in the requires list.

Reported by:	pkg-devel exp-run
This commit is contained in:
Gleb Popov 2025-03-17 13:18:54 +03:00
parent 0239d61ab2
commit 3175af6687
2 changed files with 12 additions and 1 deletions

View file

@ -1,7 +1,7 @@
PORTNAME= arbor
DISTVERSIONPREFIX= v
DISTVERSION= 0.10.1
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org

View file

@ -0,0 +1,11 @@
--- sup/CMakeLists.txt.orig 2024-08-09 10:22:00 UTC
+++ sup/CMakeLists.txt
@@ -3,7 +3,7 @@ set(sup-sources
json_meter.cpp
)
-add_library(arbor-sup ${sup-sources})
+add_library(arbor-sup STATIC ${sup-sources})
if (ARB_USE_BUNDLED_FMT)
target_include_directories(arbor-sup