mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
graphics/py-fiona: fix import
PR: 285654 Reported by: Kyle Taylor <kyle.a.taylor@gmail.com> Reviewed by: rhurling
This commit is contained in:
parent
6ba2eac0c4
commit
2f59969962
2 changed files with 19 additions and 4 deletions
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= fiona
|
||||
DISTVERSION= 1.10.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -10,17 +11,22 @@ WWW= https://pypi.org/project/fiona/
|
|||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cligj>=0.4:devel/py-cligj@${PY_FLAVOR} \
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cligj>=0.5:devel/py-cligj@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}click>=8.0:devel/py-click@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}click-plugins>0:devel/py-click-plugins@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}six>=1.7:devel/py-six@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}munch>0:devel/py-munch@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}shapely>0:devel/py-shapely@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}gdal>0:graphics/py-gdal@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}attrs>=18.2:devel/py-attrs@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}attrs>=18.2:devel/py-attrs@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${PY_FLAVOR} \
|
||||
|
||||
LIB_DEPENDS+= libgdal.so:graphics/gdal
|
||||
|
||||
USES= compiler:c++11-lang python
|
||||
USE_PYTHON= autoplist distutils cython
|
||||
USES= compiler python
|
||||
USE_PYTHON= autoplist pep517 cython3
|
||||
|
||||
CONFLICTS_INSTALL= fio
|
||||
|
||||
|
|
9
graphics/py-fiona/files/patch-pyproject.toml
Normal file
9
graphics/py-fiona/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- pyproject.toml.orig 2025-03-26 21:47:52 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -1,5 +1,5 @@
|
||||
[build-system]
|
||||
-requires = ["setuptools>=67.8", "cython~=3.0.2"]
|
||||
+requires = ["setuptools", "cython~=3.0.2"]
|
||||
build-backend = "setuptools.build_meta"
|
||||
|
||||
[project]
|
Loading…
Add table
Reference in a new issue