mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
lang/tauthon: Update to latest commit after 2.8.5
Highlights: - email.generator: Fix handling of Unicode messages when not wrapping. - Support compilation by GCC 14. As these changes are very minor and upstream has not created an official patch level for them, Tauthon's internal version/patchlevel has been left unchanged at 2.8.5. This is a maintainer update (olce.freebsd.ports@certner.fr).
This commit is contained in:
parent
bf8c932a75
commit
2d8111b2b5
4 changed files with 25 additions and 62 deletions
|
@ -6,8 +6,7 @@
|
|||
# -- Olivier Certner <olce.freebsd.ports@certner.fr>
|
||||
PORTNAME= tauthon
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.8.5
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 2.8.5-20240706
|
||||
CATEGORIES= lang python
|
||||
|
||||
MAINTAINER= olce.freebsd.ports@certner.fr
|
||||
|
@ -24,7 +23,7 @@ PATHFIX_MAKEFILEIN= Makefile.pre.in
|
|||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= naftaliharris
|
||||
GH_PROJECT= tauthon
|
||||
GH_TAGNAME= b787044f7c9a3728604471119e6d6220d09d6d94
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1685108476
|
||||
SHA256 (naftaliharris-tauthon-v2.8.5_GH0.tar.gz) = 0d0f2ffd3a912768c138ee7b66e8163df3674f407c92152d09304c3240557dbf
|
||||
SIZE (naftaliharris-tauthon-v2.8.5_GH0.tar.gz) = 18465302
|
||||
TIMESTAMP = 1736502076
|
||||
SHA256 (naftaliharris-tauthon-v2.8.5-20240706-b787044f7c9a3728604471119e6d6220d09d6d94_GH0.tar.gz) = e3ae96666d452db5e5ed0d30c514a3e001293b90cb49920ff75cab72416b5dae
|
||||
SIZE (naftaliharris-tauthon-v2.8.5-20240706-b787044f7c9a3728604471119e6d6220d09d6d94_GH0.tar.gz) = 18481726
|
||||
|
|
11
lang/tauthon/files/patch-Include_patchlevel.h
Normal file
11
lang/tauthon/files/patch-Include_patchlevel.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Include/patchlevel.h.orig 2024-07-06 14:55:44 UTC
|
||||
+++ Include/patchlevel.h
|
||||
@@ -26,7 +26,7 @@
|
||||
#define PY_RELEASE_SERIAL 0
|
||||
|
||||
/* Version as a string */
|
||||
-#define PY_VERSION "2.8.5+"
|
||||
+#define PY_VERSION "2.8.5"
|
||||
/*--end constants--*/
|
||||
|
||||
/* Subversion Revision number of this file (not of the repository). Empty
|
|
@ -1,5 +1,5 @@
|
|||
--- setup.py.orig 2021-06-02 16:51:18.000000000 +0200
|
||||
+++ setup.py 2023-06-09 19:32:17.812240000 +0200
|
||||
--- setup.py.orig 2024-07-06 14:55:44 UTC
|
||||
+++ setup.py
|
||||
@@ -15,6 +15,7 @@
|
||||
from distutils.command.build_ext import build_ext
|
||||
from distutils.command.install import install
|
||||
|
@ -15,56 +15,9 @@
|
|||
-disabled_module_list = []
|
||||
+disabled_module_list = [%%DISABLED_MODULES%%]
|
||||
|
||||
def add_dir_to_list(dirlist, dir):
|
||||
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
|
||||
@@ -886,7 +887,10 @@
|
||||
missing.append('_ssl')
|
||||
exit_status = 0
|
||||
|
||||
# find out which version of OpenSSL we have
|
||||
+ openssl_major = -1
|
||||
openssl_ver = 0
|
||||
+ openssl_major_re = re.compile(
|
||||
+ '^\s*#\s*define\s+OPENSSL_VERSION_MAJOR\s+([0-9]+)' )
|
||||
openssl_ver_re = re.compile(
|
||||
'^\s*#\s*define\s+OPENSSL_VERSION_NUMBER\s+(0x[0-9a-fA-F]+)' )
|
||||
|
||||
@@ -900,17 +904,22 @@
|
||||
try:
|
||||
incfile = open(name, 'r')
|
||||
for line in incfile:
|
||||
+ m = openssl_major_re.match(line)
|
||||
+ if m:
|
||||
+ openssl_major = int(m.group(1))
|
||||
m = openssl_ver_re.match(line)
|
||||
if m:
|
||||
- openssl_ver = eval(m.group(1))
|
||||
+ openssl_ver = int(m.group(1), 0)
|
||||
except IOError, msg:
|
||||
print "IOError while reading opensshv.h:", msg
|
||||
pass
|
||||
|
||||
+ min_openssl_major = 1
|
||||
min_openssl_ver = 0x00907000
|
||||
have_any_openssl = ssl_incs is not None and ssl_libs is not None
|
||||
have_usable_openssl = (have_any_openssl and
|
||||
- openssl_ver >= min_openssl_ver)
|
||||
+ (openssl_ver >= min_openssl_ver or
|
||||
+ openssl_major >= min_openssl_major))
|
||||
|
||||
if have_any_openssl:
|
||||
if have_usable_openssl:
|
||||
@@ -935,7 +944,9 @@
|
||||
depends = ['md5.h']) )
|
||||
|
||||
min_sha2_openssl_ver = 0x00908000
|
||||
- if COMPILED_WITH_PYDEBUG or openssl_ver < min_sha2_openssl_ver:
|
||||
+ if COMPILED_WITH_PYDEBUG or \
|
||||
+ (openssl_ver < min_sha2_openssl_ver and
|
||||
+ openssl_major < min_openssl_major):
|
||||
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
|
||||
exts.append( Extension('_sha256', ['sha256module.c']) )
|
||||
exts.append( Extension('_sha512', ['sha512module.c']) )
|
||||
@@ -1284,7 +1295,7 @@
|
||||
@@ -1308,7 +1309,7 @@
|
||||
sysroot = macosx_sdk_root()
|
||||
f = os.path.join(sysroot, f[1:])
|
||||
|
||||
|
@ -73,7 +26,7 @@
|
|||
data = open(f).read()
|
||||
m = re.search(r"#s*define\s+HASHVERSION\s+2\s*", data)
|
||||
if m is not None:
|
||||
@@ -1669,9 +1680,10 @@
|
||||
@@ -1693,9 +1694,10 @@
|
||||
else:
|
||||
missing.append('linuxaudiodev')
|
||||
|
||||
|
@ -87,7 +40,7 @@
|
|||
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
|
||||
else:
|
||||
missing.append('ossaudiodev')
|
||||
@@ -2294,6 +2306,22 @@
|
||||
@@ -2294,6 +2296,22 @@
|
||||
def is_chmod_supported(self):
|
||||
return hasattr(os, 'chmod')
|
||||
|
||||
|
@ -110,7 +63,7 @@
|
|||
SUMMARY = """
|
||||
Python is an interpreted, interactive, object-oriented programming
|
||||
language. It is often compared to Tcl, Perl, Scheme or Java.
|
||||
@@ -2343,7 +2371,9 @@
|
||||
@@ -2343,7 +2361,9 @@
|
||||
platforms = ["Many"],
|
||||
|
||||
# Build info
|
||||
|
@ -121,7 +74,7 @@
|
|||
'install_lib':PyBuildInstallLib},
|
||||
# The struct module is defined here, because build_ext won't be
|
||||
# called unless there's at least one extension module defined.
|
||||
@@ -2351,8 +2381,7 @@
|
||||
@@ -2351,8 +2371,7 @@
|
||||
|
||||
# Scripts to install
|
||||
scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
|
||||
|
@ -129,5 +82,5 @@
|
|||
- 'Lib/smtpd.py']
|
||||
+ 'Tools/scripts/2to3']
|
||||
)
|
||||
sys.exit(exit_status)
|
||||
|
||||
# --install-platlib
|
||||
|
|
Loading…
Add table
Reference in a new issue