mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
x11-toolkits/wlroots016: replace override.mk with upstream fix
This commit is contained in:
parent
dffdb0825f
commit
2d64423989
6 changed files with 132 additions and 119 deletions
|
@ -1,11 +1,16 @@
|
|||
PORTNAME= wlroots
|
||||
DISTVERSION= 0.16.2
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= x11-toolkits
|
||||
PKGNAMESUFFIX= 016
|
||||
|
||||
PATCH_SITES+= https://github.com/swaywm/${GL_PROJECT}/commit/:github
|
||||
PATCHFILES+= 107f8d4cca76.patch:-p1:github # https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/4488
|
||||
PATCH_SITES+= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
|
||||
PATCHFILES+= f3ba14e49133.patch:-p1 # https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/3850
|
||||
PATCHFILES+= faa631c348d9.patch:-p1 # https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/4005
|
||||
PATCHFILES+= 822eb07eaca3.patch:-p1 # https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/4005
|
||||
PATCHFILES+= 4b4f76cc1357.patch:-p1 # https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/4614
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Modular Wayland compositor library (deprecated 0.16.* series)
|
||||
|
@ -28,12 +33,9 @@ USE_XORG= pixman
|
|||
USE_LDCONFIG= yes
|
||||
GL_SITE= https://gitlab.freedesktop.org
|
||||
MESON_ARGS= -Dexamples=false -Dbackends=${BACKENDS:ts,} -Drenderers=${RENDERERS:ts,}
|
||||
PLIST_SUB= SUFFIX=-${DISTVERSION:R}
|
||||
|
||||
.ifdef PKGNAMESUFFIX
|
||||
PORTSCOUT= limit:^0\.16\.
|
||||
PREFIX= ${LOCALBASE}/${PKGBASE} # avoid conflict with the default
|
||||
MESON_ARGS+= -Ddatadir="${LOCALBASE}/share"
|
||||
.endif
|
||||
|
||||
OPTIONS_DEFINE= DRM OPENGL VULKAN X11
|
||||
OPTIONS_DEFAULT=DRM OPENGL VULKAN X11
|
||||
|
|
|
@ -1,5 +1,13 @@
|
|||
TIMESTAMP = 1676068199
|
||||
SHA256 (wlroots-0.16.2.tar.bz2) = afea2cc740344c4e86749cf4908e07692e183cb14a3db854d24dec454c664b88
|
||||
SIZE (wlroots-0.16.2.tar.bz2) = 437628
|
||||
SHA256 (107f8d4cca76.patch) = cf5e96c4677ff544e7ae138a0b57e7d749fd4dc9260f00ed42ba3f23190f5d49
|
||||
SIZE (107f8d4cca76.patch) = 1369
|
||||
SHA256 (f3ba14e49133.patch) = fb61329725f9482eae15100ae46c59159f39abc3324937e92fdf5065155944a9
|
||||
SIZE (f3ba14e49133.patch) = 1976
|
||||
SHA256 (faa631c348d9.patch) = b0a73d15b38655e4af464be3a9ca684f8d72ed724624c1f3f9bdbee894bc2335
|
||||
SIZE (faa631c348d9.patch) = 802
|
||||
SHA256 (822eb07eaca3.patch) = 2cdf10f6d66bfe1d2f50ebd05cb1fd1157b58859ff059c953cfcef899f01f634
|
||||
SIZE (822eb07eaca3.patch) = 609
|
||||
SHA256 (4b4f76cc1357.patch) = 163500bf90d39365a6ce8a9d24d48b2e65135d2f548c9532d933ed19b1097d53
|
||||
SIZE (4b4f76cc1357.patch) = 2512
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
WLR_SUFFIX= 016
|
||||
WLR_SOVERSION= 11
|
||||
|
||||
LIB_DEPENDS:= ${LIB_DEPENDS:S/wlroots.so/&.${WLR_SOVERSION}/:S/wlroots$/&${WLR_SUFFIX}/}
|
||||
|
||||
USES+= localbase # -isystem
|
||||
CONFIGURE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/wlroots${WLR_SUFFIX}/libdata/pkgconfig"
|
||||
MAKE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/wlroots${WLR_SUFFIX}/libdata/pkgconfig"
|
|
@ -1,103 +1,102 @@
|
|||
include/wlr/backend.h
|
||||
%%DRM%%include/wlr/backend/drm.h
|
||||
include/wlr/backend/headless.h
|
||||
include/wlr/backend/interface.h
|
||||
%%DRM%%include/wlr/backend/libinput.h
|
||||
include/wlr/backend/multi.h
|
||||
include/wlr/backend/session.h
|
||||
include/wlr/backend/wayland.h
|
||||
%%X11%%include/wlr/backend/x11.h
|
||||
include/wlr/config.h
|
||||
include/wlr/interfaces/wlr_buffer.h
|
||||
include/wlr/interfaces/wlr_keyboard.h
|
||||
include/wlr/interfaces/wlr_output.h
|
||||
include/wlr/interfaces/wlr_pointer.h
|
||||
include/wlr/interfaces/wlr_switch.h
|
||||
include/wlr/interfaces/wlr_tablet_pad.h
|
||||
include/wlr/interfaces/wlr_tablet_tool.h
|
||||
include/wlr/interfaces/wlr_touch.h
|
||||
include/wlr/render/allocator.h
|
||||
include/wlr/render/dmabuf.h
|
||||
include/wlr/render/drm_format_set.h
|
||||
%%OPENGL%%include/wlr/render/egl.h
|
||||
%%OPENGL%%include/wlr/render/gles2.h
|
||||
include/wlr/render/interface.h
|
||||
include/wlr/render/pixman.h
|
||||
%%VULKAN%%include/wlr/render/vulkan.h
|
||||
include/wlr/render/wlr_renderer.h
|
||||
include/wlr/render/wlr_texture.h
|
||||
include/wlr/types/wlr_buffer.h
|
||||
include/wlr/types/wlr_compositor.h
|
||||
include/wlr/types/wlr_cursor.h
|
||||
include/wlr/types/wlr_damage_ring.h
|
||||
include/wlr/types/wlr_data_control_v1.h
|
||||
include/wlr/types/wlr_data_device.h
|
||||
include/wlr/types/wlr_drm.h
|
||||
%%DRM%%include/wlr/types/wlr_drm_lease_v1.h
|
||||
include/wlr/types/wlr_export_dmabuf_v1.h
|
||||
include/wlr/types/wlr_foreign_toplevel_management_v1.h
|
||||
include/wlr/types/wlr_fullscreen_shell_v1.h
|
||||
include/wlr/types/wlr_gamma_control_v1.h
|
||||
include/wlr/types/wlr_idle.h
|
||||
include/wlr/types/wlr_idle_inhibit_v1.h
|
||||
include/wlr/types/wlr_idle_notify_v1.h
|
||||
include/wlr/types/wlr_input_device.h
|
||||
include/wlr/types/wlr_input_inhibitor.h
|
||||
include/wlr/types/wlr_input_method_v2.h
|
||||
include/wlr/types/wlr_keyboard.h
|
||||
include/wlr/types/wlr_keyboard_group.h
|
||||
include/wlr/types/wlr_keyboard_shortcuts_inhibit_v1.h
|
||||
include/wlr/types/wlr_layer_shell_v1.h
|
||||
include/wlr/types/wlr_linux_dmabuf_v1.h
|
||||
include/wlr/types/wlr_matrix.h
|
||||
include/wlr/types/wlr_output.h
|
||||
include/wlr/types/wlr_output_damage.h
|
||||
include/wlr/types/wlr_output_layout.h
|
||||
include/wlr/types/wlr_output_management_v1.h
|
||||
include/wlr/types/wlr_output_power_management_v1.h
|
||||
include/wlr/types/wlr_pointer.h
|
||||
include/wlr/types/wlr_pointer_constraints_v1.h
|
||||
include/wlr/types/wlr_pointer_gestures_v1.h
|
||||
include/wlr/types/wlr_presentation_time.h
|
||||
include/wlr/types/wlr_primary_selection.h
|
||||
include/wlr/types/wlr_primary_selection_v1.h
|
||||
include/wlr/types/wlr_region.h
|
||||
include/wlr/types/wlr_relative_pointer_v1.h
|
||||
include/wlr/types/wlr_scene.h
|
||||
include/wlr/types/wlr_screencopy_v1.h
|
||||
include/wlr/types/wlr_seat.h
|
||||
include/wlr/types/wlr_server_decoration.h
|
||||
include/wlr/types/wlr_session_lock_v1.h
|
||||
include/wlr/types/wlr_single_pixel_buffer_v1.h
|
||||
include/wlr/types/wlr_subcompositor.h
|
||||
include/wlr/types/wlr_surface.h
|
||||
include/wlr/types/wlr_switch.h
|
||||
include/wlr/types/wlr_tablet_pad.h
|
||||
include/wlr/types/wlr_tablet_tool.h
|
||||
include/wlr/types/wlr_tablet_v2.h
|
||||
include/wlr/types/wlr_text_input_v3.h
|
||||
include/wlr/types/wlr_touch.h
|
||||
include/wlr/types/wlr_viewporter.h
|
||||
include/wlr/types/wlr_virtual_keyboard_v1.h
|
||||
include/wlr/types/wlr_virtual_pointer_v1.h
|
||||
include/wlr/types/wlr_xcursor_manager.h
|
||||
include/wlr/types/wlr_xdg_activation_v1.h
|
||||
include/wlr/types/wlr_xdg_decoration_v1.h
|
||||
include/wlr/types/wlr_xdg_foreign_registry.h
|
||||
include/wlr/types/wlr_xdg_foreign_v1.h
|
||||
include/wlr/types/wlr_xdg_foreign_v2.h
|
||||
include/wlr/types/wlr_xdg_output_v1.h
|
||||
include/wlr/types/wlr_xdg_shell.h
|
||||
include/wlr/util/addon.h
|
||||
include/wlr/util/box.h
|
||||
include/wlr/util/edges.h
|
||||
include/wlr/util/log.h
|
||||
include/wlr/util/region.h
|
||||
include/wlr/version.h
|
||||
include/wlr/xcursor.h
|
||||
%%X11%%include/wlr/xwayland.h
|
||||
%%X11%%include/wlr/xwayland/server.h
|
||||
%%X11%%include/wlr/xwayland/xwayland.h
|
||||
lib/libwlroots.so
|
||||
lib/libwlroots.so.11
|
||||
libdata/pkgconfig/wlroots.pc
|
||||
include/wlroots%%SUFFIX%%/wlr/backend.h
|
||||
%%DRM%%include/wlroots%%SUFFIX%%/wlr/backend/drm.h
|
||||
include/wlroots%%SUFFIX%%/wlr/backend/headless.h
|
||||
include/wlroots%%SUFFIX%%/wlr/backend/interface.h
|
||||
%%DRM%%include/wlroots%%SUFFIX%%/wlr/backend/libinput.h
|
||||
include/wlroots%%SUFFIX%%/wlr/backend/multi.h
|
||||
include/wlroots%%SUFFIX%%/wlr/backend/session.h
|
||||
include/wlroots%%SUFFIX%%/wlr/backend/wayland.h
|
||||
%%X11%%include/wlroots%%SUFFIX%%/wlr/backend/x11.h
|
||||
include/wlroots%%SUFFIX%%/wlr/config.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_buffer.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_keyboard.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_output.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_pointer.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_switch.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_tablet_pad.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_tablet_tool.h
|
||||
include/wlroots%%SUFFIX%%/wlr/interfaces/wlr_touch.h
|
||||
include/wlroots%%SUFFIX%%/wlr/render/allocator.h
|
||||
include/wlroots%%SUFFIX%%/wlr/render/dmabuf.h
|
||||
include/wlroots%%SUFFIX%%/wlr/render/drm_format_set.h
|
||||
%%OPENGL%%include/wlroots%%SUFFIX%%/wlr/render/egl.h
|
||||
%%OPENGL%%include/wlroots%%SUFFIX%%/wlr/render/gles2.h
|
||||
include/wlroots%%SUFFIX%%/wlr/render/interface.h
|
||||
include/wlroots%%SUFFIX%%/wlr/render/pixman.h
|
||||
%%VULKAN%%include/wlroots%%SUFFIX%%/wlr/render/vulkan.h
|
||||
include/wlroots%%SUFFIX%%/wlr/render/wlr_renderer.h
|
||||
include/wlroots%%SUFFIX%%/wlr/render/wlr_texture.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_buffer.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_compositor.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_cursor.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_damage_ring.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_data_control_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_data_device.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_drm.h
|
||||
%%DRM%%include/wlroots%%SUFFIX%%/wlr/types/wlr_drm_lease_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_export_dmabuf_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_foreign_toplevel_management_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_fullscreen_shell_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_gamma_control_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_idle.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_idle_inhibit_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_idle_notify_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_input_device.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_input_inhibitor.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_input_method_v2.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_keyboard.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_keyboard_group.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_keyboard_shortcuts_inhibit_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_layer_shell_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_linux_dmabuf_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_matrix.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_output.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_output_damage.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_output_layout.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_output_management_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_output_power_management_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_pointer.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_pointer_constraints_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_pointer_gestures_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_presentation_time.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_primary_selection.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_primary_selection_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_region.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_relative_pointer_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_scene.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_screencopy_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_seat.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_server_decoration.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_session_lock_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_single_pixel_buffer_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_subcompositor.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_surface.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_switch.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_tablet_pad.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_tablet_tool.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_tablet_v2.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_text_input_v3.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_touch.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_viewporter.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_virtual_keyboard_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_virtual_pointer_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xcursor_manager.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xdg_activation_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xdg_decoration_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xdg_foreign_registry.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xdg_foreign_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xdg_foreign_v2.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xdg_output_v1.h
|
||||
include/wlroots%%SUFFIX%%/wlr/types/wlr_xdg_shell.h
|
||||
include/wlroots%%SUFFIX%%/wlr/util/addon.h
|
||||
include/wlroots%%SUFFIX%%/wlr/util/box.h
|
||||
include/wlroots%%SUFFIX%%/wlr/util/edges.h
|
||||
include/wlroots%%SUFFIX%%/wlr/util/log.h
|
||||
include/wlroots%%SUFFIX%%/wlr/util/region.h
|
||||
include/wlroots%%SUFFIX%%/wlr/version.h
|
||||
include/wlroots%%SUFFIX%%/wlr/xcursor.h
|
||||
%%X11%%include/wlroots%%SUFFIX%%/wlr/xwayland.h
|
||||
%%X11%%include/wlroots%%SUFFIX%%/wlr/xwayland/server.h
|
||||
%%X11%%include/wlroots%%SUFFIX%%/wlr/xwayland/xwayland.h
|
||||
lib/libwlroots%%SUFFIX%%.so
|
||||
libdata/pkgconfig/wlroots%%SUFFIX%%.pc
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
PORTNAME= cage
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.1.5
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= x11-wm wayland
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
|
@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
|
||||
wayland-protocols>=1.14:graphics/wayland-protocols
|
||||
LIB_DEPENDS= libwayland-server.so:graphics/wayland \
|
||||
libwlroots.so:x11-toolkits/wlroots \
|
||||
libwlroots-0.16.so:x11-toolkits/wlroots016 \
|
||||
libxkbcommon.so:x11/libxkbcommon
|
||||
|
||||
USES= compiler:c11 meson pkgconfig
|
||||
|
@ -42,5 +42,4 @@ post-patch:
|
|||
-e '/project_version/s/@0@/${DISTVERSIONFULL}/' \
|
||||
${WRKSRC}/meson.build
|
||||
|
||||
.include "${.CURDIR:H:H}/x11-toolkits/wlroots016/override.mk"
|
||||
.include <bsd.port.mk>
|
||||
|
|
13
x11-wm/cage/files/patch-meson.build
Normal file
13
x11-wm/cage/files/patch-meson.build
Normal file
|
@ -0,0 +1,13 @@
|
|||
Run-time dependency wlroots found: NO (tried pkgconfig and cmake)
|
||||
|
||||
--- meson.build.nogit 2023-07-28 14:46:37 UTC
|
||||
+++ meson.build
|
||||
@@ -35,7 +35,7 @@ endif
|
||||
)
|
||||
endif
|
||||
|
||||
-wlroots = dependency('wlroots', version: '>= 0.16.0', fallback: ['wlroots', 'wlroots'])
|
||||
+wlroots = dependency('wlroots-0.16', fallback: ['wlroots', 'wlroots'])
|
||||
wayland_protos = dependency('wayland-protocols', version: '>=1.14')
|
||||
wayland_server = dependency('wayland-server')
|
||||
xkbcommon = dependency('xkbcommon')
|
Loading…
Add table
Reference in a new issue