mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
databases/sqlitebrowser: Update to 3.13.1
- https://github.com/sqlitebrowser/sqlitebrowser/releases/tag/v3.13.1 - Change maintainership PR: 281067
This commit is contained in:
parent
cd386b9f5b
commit
2bd6dfe88c
5 changed files with 15 additions and 34 deletions
|
@ -1,31 +1,24 @@
|
||||||
PORTNAME= sqlitebrowser
|
PORTNAME= sqlitebrowser
|
||||||
PORTVERSION= 3.12.2
|
|
||||||
PORTREVISION= 1
|
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
|
DISTVERSION= 3.13.1
|
||||||
CATEGORIES= databases
|
CATEGORIES= databases
|
||||||
|
|
||||||
MAINTAINER= lbartoletti@FreeBSD.org
|
MAINTAINER= mew14930xvi@inbox.lv
|
||||||
COMMENT= Visual tool to manage SQLite databases
|
COMMENT= Visual tool to manage SQLite databases
|
||||||
WWW= https://sqlitebrowser.org/
|
WWW= https://sqlitebrowser.org/
|
||||||
|
|
||||||
LICENSE= MPL20 GPLv3
|
LICENSE= MPL20 GPLv3+
|
||||||
LICENSE_COMB= dual
|
LICENSE_COMB= dual
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
LICENSE_FILE_GPLv3= ${WRKSRC}/LICENSE-GPL-3.0
|
||||||
|
LICENSE_FILE_MPL20= ${WRKSRC}/LICENSE-MPL-2.0
|
||||||
|
|
||||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libantlr.a:devel/antlr
|
USES= cmake compiler:c++14-lang desktop-file-utils gnome qt:5 sqlite
|
||||||
LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2@qt5
|
|
||||||
|
|
||||||
USES= cmake desktop-file-utils gnome qt:5 sqlite
|
|
||||||
USE_QT= core concurrent gui network printsupport testlib widgets \
|
USE_QT= core concurrent gui network printsupport testlib widgets \
|
||||||
buildtools:build linguisttools:build qmake:build xml
|
buildtools:build linguisttools:build qmake:build xml
|
||||||
USE_GITHUB= yes
|
USE_GITHUB= yes
|
||||||
|
|
||||||
PORTSCOUT= ignore:1
|
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
|
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
|
||||||
${WRKSRC}/src/PreferencesDialog.cpp ${WRKSRC}/src/Application.cpp
|
${WRKSRC}/src/PreferencesDialog.cpp ${WRKSRC}/src/Application.cpp
|
||||||
@${REINPLACE_CMD} -e 's|metainfo|appdata|' \
|
|
||||||
${WRKSRC}/src/src.pro ${WRKSRC}/CMakeLists.txt
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1717318544
|
TIMESTAMP = 1729074091
|
||||||
SHA256 (sqlitebrowser-sqlitebrowser-v3.12.2_GH0.tar.gz) = 645f98d38e5d128a449e93cebf03c8070f9eacd2d16b10e433a781d54a9d478a
|
SHA256 (sqlitebrowser-sqlitebrowser-v3.13.1_GH0.tar.gz) = 1044ba67d649cabc459eb887c016f70d6a404ad651390ab33bf7859dc7f1b67b
|
||||||
SIZE (sqlitebrowser-sqlitebrowser-v3.12.2_GH0.tar.gz) = 3990817
|
SIZE (sqlitebrowser-sqlitebrowser-v3.13.1_GH0.tar.gz) = 4923092
|
||||||
|
|
|
@ -1,16 +1,16 @@
|
||||||
--- src/Application.cpp.orig 2016-09-25 11:30:50 UTC
|
--- src/Application.cpp.orig 2024-08-25 17:07:43 UTC
|
||||||
+++ src/Application.cpp
|
+++ src/Application.cpp
|
||||||
@@ -30,8 +30,16 @@ Application::Application(int& argc, char
|
@@ -117,8 +117,16 @@ Application::Application(int& argc, char** argv) :
|
||||||
|
|
||||||
// First of all try to load the application translation file.
|
// First of all try to load the application translation file.
|
||||||
m_translatorApp = new QTranslator(this);
|
m_translatorApp = new QTranslator(this);
|
||||||
+
|
+
|
||||||
+#ifdef Q_OS_FREEBSD
|
+#ifdef Q_OS_FREEBSD
|
||||||
+ QString trans_dir = "%%DATADIR%%/translations";
|
+ QString trans_dir = "%%DATADIR%%/translations";
|
||||||
+ ok = m_translatorApp->load("sqlb_" + name,
|
ok = m_translatorApp->load("sqlb_" + name,
|
||||||
+ trans_dir);
|
+ trans_dir);
|
||||||
+#else
|
+#else
|
||||||
ok = m_translatorApp->load("sqlb_" + name,
|
+ ok = m_translatorApp->load("sqlb_" + name,
|
||||||
QCoreApplication::applicationDirPath() + "/translations");
|
QCoreApplication::applicationDirPath() + "/translations");
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
--- src/version.h.orig 2021-05-02 14:08:53 UTC
|
|
||||||
+++ src/version.h
|
|
||||||
@@ -4,9 +4,7 @@
|
|
||||||
#define MINOR_VERSION 12
|
|
||||||
#define PATCH_VERSION 2
|
|
||||||
|
|
||||||
-#define str(s) #s
|
|
||||||
-#define xstr(s) str(s)
|
|
||||||
-#define APP_VERSION xstr(MAJOR_VERSION) "." xstr(MINOR_VERSION) "." xstr(PATCH_VERSION)
|
|
||||||
+#define APP_VERSION "3.12.2"
|
|
||||||
|
|
||||||
// If it is defined by the compiler, then it is a nightly build, and in the YYYYMMDD format.
|
|
||||||
#ifndef BUILD_VERSION
|
|
|
@ -1,4 +1,5 @@
|
||||||
bin/sqlitebrowser
|
bin/sqlitebrowser
|
||||||
share/appdata/sqlitebrowser.desktop.appdata.xml
|
|
||||||
share/applications/sqlitebrowser.desktop
|
share/applications/sqlitebrowser.desktop
|
||||||
share/icons/hicolor/256x256/apps/sqlitebrowser.png
|
share/icons/hicolor/256x256/apps/sqlitebrowser.png
|
||||||
|
share/icons/hicolor/scalable/apps/sqlitebrowser.svg
|
||||||
|
share/metainfo/sqlitebrowser.desktop.appdata.xml
|
||||||
|
|
Loading…
Add table
Reference in a new issue