graphics/cairo: Update to 1.18.2

Upstream has removed OpenGL support and switched from autoconf to meson.

Some ports needed to be fixed:

audio/fogpad-lv2, audio/ssr-lv2, audio/stone-phaser-lv2,
audio/string-machine-lv2: Add dependency on libGL now that cairo
no longer pulls it in.

devel/doxygen: Add upstream patches to support compressed PDF files
generated by more recent versions of cairo.

www/webkit2-gtk3, www/webkit2-gtk4: Remove requirement for cairo-egl.

x11/hyprpaper: Remove inclusion of unused GLES3 headers so a dependency
on libGLES is not needed.

x11/rofi-file-browser-extended: Fix patch to make sure
GLIB2_INCLUDE_DIRS is defined.

PR:		283531
Reviewed by:	diizzy
Exp-run by:	antoine
This commit is contained in:
Tijl Coosemans 2024-06-21 16:45:30 +02:00
parent 75621bf979
commit 299bcfac71
16 changed files with 93 additions and 159 deletions

View file

@ -1,7 +1,7 @@
PORTNAME= fogpad
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.0-3
PORTREVISION= 2
PORTREVISION= 3
DISTVERSIONSUFFIX= -gc52326b
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@ -17,12 +17,13 @@ BUILD_DEPENDS= lv2>0:audio/lv2 \
bash:shells/bash
LIB_DEPENDS= liblo.so:audio/liblo
USES= compiler:c++11-lib gmake gnome pkgconfig shebangfix xorg
USES= compiler:c++11-lib gl gmake gnome pkgconfig shebangfix xorg
SHEBANG_FILES= dpf/utils/generate-ttl.sh
USE_GITHUB= yes
GH_ACCOUNT= linuxmao-org
GH_PROJECT= fogpad-port # a more recently updated fork of https://github.com/igorski/fogpad
GH_TUPLE= DISTRHO:DPF:4e180a77ec6e93abb021b28495bd84b43498bf31:DISTRHO_DPF/dpf
USE_GL= gl
USE_GNOME= cairo
USE_XORG= x11

View file

@ -1,6 +1,6 @@
PORTNAME= ssr
DISTVERSION= g20210922
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@ -17,7 +17,8 @@ BUILD_DEPENDS= lv2>0:audio/lv2 \
bash:shells/bash
LIB_DEPENDS= libjack.so:audio/jack
USES= compiler:c++11-lang gmake gnome pkgconfig shebangfix xorg
USES= compiler:c++11-lang gl gmake gnome pkgconfig shebangfix xorg
USE_GL= gl
USE_GNOME= cairo
USE_XORG= x11

View file

@ -2,6 +2,7 @@ PORTNAME= stone-phaser
DISTVERSIONPREFIX= v
DISTVERSION= 0.1.2-17
DISTVERSIONSUFFIX= -gda92961
PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@ -15,11 +16,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= lv2>0:audio/lv2 \
bash:shells/bash
USES= compiler:c++0x gmake gnome pkgconfig shebangfix xorg
USES= compiler:c++0x gl gmake gnome pkgconfig shebangfix xorg
SHEBANG_GLOB= *.sh
USE_GITHUB= yes
GH_ACCOUNT= jpcima
GH_TUPLE= DISTRHO:DPF:e69074e:dpf/dpf
USE_GL= gl
USE_GNOME= cairo
USE_XORG= x11

View file

@ -1,7 +1,7 @@
PORTNAME= string-machine
DISTVERSIONPREFIX= v
DISTVERSION= 0.1.0
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@ -15,10 +15,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= lv2>0:audio/lv2 \
${LOCALBASE}/include/boost/intrusive/list.hpp:devel/boost-libs
USES= compiler:c++0x gmake gnome localbase pkgconfig xorg
USES= compiler:c++0x gl gmake gnome localbase pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= jpcima
GH_TUPLE= DISTRHO:DPF:7a056bb:d/dpf
USE_GL= gl
USE_GNOME= cairo
USE_XORG= x11

View file

@ -1,12 +1,18 @@
PORTNAME= doxygen
PORTVERSION= 1.9.6
PORTREVISION= 1
PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/rel-${PORTVERSION} \
http://doxygen.nl/files/
EXTRACT_SUFX= .src.tar.gz
PATCH_SITES= https://github.com/doxygen/doxygen/commit/
PATCHFILES= 966d69c603b5a6ae22e3132b6ecc6a39b86e52ab.patch:-p1 \
7b2a6027775b0158304635a98de0f9b5672f163a.patch:-p1 \
f3514d578633cad3e39d6787f81085e46bafbaf4.patch:-p1 \
8129939c312e4b5060042fdb93bd071b7b133381.patch:-p1
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Documentation system for C, C++, and other languages
WWW= https://www.doxygen.org/

View file

@ -1,3 +1,11 @@
TIMESTAMP = 1673081300
TIMESTAMP = 1735765140
SHA256 (doxygen-1.9.6.src.tar.gz) = 297f8ba484265ed3ebd3ff3fe7734eb349a77e4f95c8be52ed9977f51dea49df
SIZE (doxygen-1.9.6.src.tar.gz) = 5293513
SHA256 (966d69c603b5a6ae22e3132b6ecc6a39b86e52ab.patch) = 76206ebe34b934c8a1fdab853079ea05d05c2c632af744c890f893be32d09aac
SIZE (966d69c603b5a6ae22e3132b6ecc6a39b86e52ab.patch) = 86972
SHA256 (7b2a6027775b0158304635a98de0f9b5672f163a.patch) = 6912468ebeb3e5028d929ee359bf9772cdd1f7f4d59bb2e70e1bdfb7825d5311
SIZE (7b2a6027775b0158304635a98de0f9b5672f163a.patch) = 8545
SHA256 (f3514d578633cad3e39d6787f81085e46bafbaf4.patch) = 3d72d7b311fc748448136c0c512a1f8a3b96f9374f2b02f0d5b050ba2ffccb56
SIZE (f3514d578633cad3e39d6787f81085e46bafbaf4.patch) = 3012
SHA256 (8129939c312e4b5060042fdb93bd071b7b133381.patch) = 68e8b209045d1ff97b88211454800e1ab43a088cbafdf2caea71052466abf875
SIZE (8129939c312e4b5060042fdb93bd071b7b133381.patch) = 2493

View file

@ -1,13 +1,11 @@
PORTNAME= cairo
DISTVERSION= 1.17.4
PORTREVISION= 2
DISTVERSION= 1.18.2
PORTEPOCH= 3
CATEGORIES= graphics
MASTER_SITES= https://cairographics.org/releases/ \
https://cairographics.org/snapshots/
MASTER_SITES= https://cairographics.org/releases/
PATCH_SITES= https://gitlab.freedesktop.org/${PORTNAME}/${PORTNAME}/commit/
PATCHFILES= ebbaebdec12878836fc84d31c59ee324e67abc05.patch:-p1 # cairo-script-interpreter.pc
PATCHFILES= f19e2fe080ddcfce93c8234a919fd882f3d63362.patch:-p1
MAINTAINER= desktop@FreeBSD.org
COMMENT= Vector graphics library with cross-device output support
@ -18,69 +16,44 @@ LICENSE_COMB= dual
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING-LGPL-2.1
LICENSE_FILE_MPL11= ${WRKSRC}/COPYING-MPL-1.1
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png \
libfontconfig.so:x11-fonts/fontconfig
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
liblzo2.so:archivers/lzo2 \
libpng.so:graphics/png
USES= cpe gnome localbase:ldflags meson pkgconfig python:build \
shebangfix tar:xz xorg
CPE_VENDOR= cairographics
USE_LDCONFIG= yes
USE_XORG= pixman
SHEBANG_FILES= version.py
# spectre only used by tests; symbol-lookup because libbfd is difficult
# to use (https://sourceware.org/bugzilla/show_bug.cgi?id=14243);
# tests has circular dependencies
MESON_ARGS= -Dspectre=disabled \
-Dsymbol-lookup=disabled \
-Dtests=disabled
DOCSDIR= ${PREFIX}/share/gtk-doc/html
PORTSCOUT= skipv:5c-1.1,5c-1.2,5c-1.5
USES= autoreconf cpe gnome libtool pkgconfig tar:xz xorg
CPE_VENDOR= cairographics
USE_XORG= pixman
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PLIST_SUB= LIBVER=2.11802.2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-directfb \
--disable-gallium \
--disable-wgl \
--enable-tee
OPTIONS_RADIO= GL
OPTIONS_RADIO_GL= OPENGL GLESV2
OPTIONS_DEFINE= XCB GLIB X11 DOCS
OPTIONS_DEFAULT=OPENGL XCB GLIB X11
OPTIONS_SLAVE= ${ARCH:tu}
OPTIONS_DEFINE= DOCS GLIB X11
OPTIONS_DEFAULT=DOCS GLIB X11
OPTIONS_SUB= yes
DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
DOCS_CONFIGURE_ON= --with-html-dir=${DOCSDIR}
DOCSDIR= ${PREFIX}/share/gtk-doc/html
X11_USES= xorg
X11_USE= xorg=x11,xext,xorgproto,xrender
X11_CONFIGURE_ENABLE=xlib
X11_CONFIGURE_OFF=--disable-glx
OPENGL_USES= gl
OPENGL_USE= gl=egl
OPENGL_CONFIGURE_ENABLE=gl egl
GLESV2_USES= gl
GLESV2_USE= gl=glesv2
GLESV2_DESC= Enable GLESv2 rendering
GLESV2_CONFIGURE_ENABLE=glesv2
GLIB_DESC= Enable GObject Functions Feature
GLIB_USES= gettext-runtime
GLIB_USE= gnome=glib20
GLIB_CONFIGURE_ENABLE= gobject
XCB_DESC= Enable XCB (X C-language Binding) Support
XCB_USES= xorg
XCB_USE= xorg=xcb
XCB_CONFIGURE_ENABLE= xcb
DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
DOCS_MESON_TRUE= gtk_doc
# this has another option --enable-xlib-xcb=auto but it is buggy.
MIPS_BUILD_DEPENDS= ${LOCALBASE}/include/atomic_ops.h:devel/libatomic_ops
MIPS_USES= localbase
MIPS_CONFIGURE_ENV= cairo_cv_atomic_primitives="libatomic-ops"
GLIB_USE= GNOME=glib20
GLIB_MESON_ENABLED= glib
PLIST_SUB+= LIBVER=2.11704.0
post-patch-DOCS-off:
@${REINPLACE_CMD} '/^SUBDIRS/s/doc//' ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e '/^GTK_DOC_CHECK/d' -e '/doc\/.*Makefile/d' \
${WRKSRC}/configure.ac
X11_USE= XORG=x11,xcb,xext,xorgproto,xrender
X11_MESON_ENABLED= xcb xlib
.include <bsd.port.mk>

View file

@ -1,5 +1,5 @@
TIMESTAMP = 1618524411
SHA256 (cairo-1.17.4.tar.xz) = 74b24c1ed436bbe87499179a3b27c43f4143b8676d8ad237a6fa787401959705
SIZE (cairo-1.17.4.tar.xz) = 41834076
SHA256 (ebbaebdec12878836fc84d31c59ee324e67abc05.patch) = 8b8f19ed74def2d663942fe596206ae21e4186fddf5c51097cb31ab6941cc6c8
SIZE (ebbaebdec12878836fc84d31c59ee324e67abc05.patch) = 4272
TIMESTAMP = 1735598607
SHA256 (cairo-1.18.2.tar.xz) = a62b9bb42425e844cc3d6ddde043ff39dbabedd1542eba57a2eb79f85889d45a
SIZE (cairo-1.18.2.tar.xz) = 32574256
SHA256 (f19e2fe080ddcfce93c8234a919fd882f3d63362.patch) = 02761fc52de43709850f287b52e39993fda3abe1f1d6de969fdfd05dac1d4e86
SIZE (f19e2fe080ddcfce93c8234a919fd882f3d63362.patch) = 1126

View file

@ -1,10 +0,0 @@
--- Makefile.am.orig 2020-11-26 23:20:59 UTC
+++ Makefile.am
@@ -20,7 +20,6 @@ if CAIRO_HAS_PNG_FUNCTIONS
SUBDIRS = src doc util
# libpng is required for our test programs
if CAIRO_HAS_PNG_FUNCTIONS
-SUBDIRS += boilerplate test perf
endif
doc:

View file

@ -1,17 +0,0 @@
--- build/configure.ac.system.orig 2020-11-26 23:20:59 UTC
+++ build/configure.ac.system
@@ -53,11 +53,11 @@ LIBS="$LIBS $LIBM"
AC_CHECK_LIBM
LIBS="$LIBS $LIBM"
-AC_CHECK_LIB(rt, sched_yield)
+AC_CHECK_LIB(c, sched_yield)
has_shm_open=
-AC_CHECK_LIB(rt, shm_open, [
- SHM_LIBS=-lrt
+AC_CHECK_LIB(c, shm_open, [
+ SHM_LIBS=
has_shm_open=yes
], [SHM_LIBS=])
AM_CONDITIONAL(HAVE_SHM, test "x$has_shm_open" = "xyes")

View file

@ -1,11 +0,0 @@
--- configure.ac.orig 2020-11-26 23:20:59 UTC
+++ configure.ac
@@ -842,7 +842,7 @@ save_LIBS="$LIBS"
AM_CONDITIONAL(BUILD_SPHINX, test "x$have_glib" = "xyes" -a "x$have_windows" = "xno" -a "x$have_png" = "xyes")
save_LIBS="$LIBS"
-AC_CHECK_LIB(rt, shm_open, shm_LIBS="-lrt")
+AC_CHECK_LIB(c, shm_open, shm_LIBS="")
AC_SUBST(shm_LIBS)
LIBS="$save_LIBS"

View file

@ -2,7 +2,6 @@ bin/cairo-trace
include/cairo/cairo-deprecated.h
include/cairo/cairo-features.h
include/cairo/cairo-ft.h
%%OPENGL%%include/cairo/cairo-gl.h
%%GLIB%%include/cairo/cairo-gobject.h
include/cairo/cairo-pdf.h
include/cairo/cairo-ps.h
@ -11,32 +10,23 @@ include/cairo/cairo-script.h
include/cairo/cairo-svg.h
include/cairo/cairo-tee.h
include/cairo/cairo-version.h
%%XCB%%include/cairo/cairo-xcb.h
%%X11%%include/cairo/cairo-xcb.h
%%X11%%include/cairo/cairo-xlib-xrender.h
%%X11%%include/cairo/cairo-xlib.h
include/cairo/cairo.h
lib/cairo/cairo-fdr.a
lib/cairo/cairo-fdr.so
lib/cairo/libcairo-trace.a
lib/cairo/libcairo-fdr.so
lib/cairo/libcairo-trace.so
%%GLIB%%lib/libcairo-gobject.a
%%GLIB%%lib/libcairo-gobject.so
%%GLIB%%lib/libcairo-gobject.so.2
%%GLIB%%lib/libcairo-gobject.so.%%LIBVER%%
lib/libcairo-script-interpreter.a
lib/libcairo-script-interpreter.so
lib/libcairo-script-interpreter.so.2
lib/libcairo-script-interpreter.so.%%LIBVER%%
lib/libcairo.a
lib/libcairo.so
lib/libcairo.so.2
lib/libcairo.so.%%LIBVER%%
%%OPENGL%%libdata/pkgconfig/cairo-egl.pc
libdata/pkgconfig/cairo-fc.pc
libdata/pkgconfig/cairo-ft.pc
%%OPENGL%%libdata/pkgconfig/cairo-gl.pc
%%GLESV2%%libdata/pkgconfig/cairo-glesv2.pc
%%OPENGL%%%%X11%%libdata/pkgconfig/cairo-glx.pc
%%GLIB%%libdata/pkgconfig/cairo-gobject.pc
libdata/pkgconfig/cairo-pdf.pc
libdata/pkgconfig/cairo-png.pc
@ -45,11 +35,22 @@ libdata/pkgconfig/cairo-script.pc
libdata/pkgconfig/cairo-script-interpreter.pc
libdata/pkgconfig/cairo-svg.pc
libdata/pkgconfig/cairo-tee.pc
%%XCB%%libdata/pkgconfig/cairo-xcb-shm.pc
%%XCB%%libdata/pkgconfig/cairo-xcb.pc
%%X11%%libdata/pkgconfig/cairo-xcb-shm.pc
%%X11%%libdata/pkgconfig/cairo-xcb.pc
%%X11%%libdata/pkgconfig/cairo-xlib-xrender.pc
%%X11%%libdata/pkgconfig/cairo-xlib.pc
libdata/pkgconfig/cairo.pc
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-0.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-10.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-12.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-14.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-16.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-18.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-2.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-4.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-6.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-1-8.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/api-index-all.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/bindings-errors.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/bindings-fonts.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/bindings-memory.html
@ -59,6 +60,7 @@ libdata/pkgconfig/cairo.pc
%%PORTDOCS%%%%DOCSDIR%%/cairo/bindings-return-values.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/bindings-streams.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/bindings-surfaces.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-DWrite-Fonts.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Error-handling.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-FreeType-Fonts.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Image-Surfaces.html
@ -73,12 +75,14 @@ libdata/pkgconfig/cairo.pc
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Regions.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-SVG-Surfaces.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Script-Surfaces.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Surface-Observer.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Tags-and-Links.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Tee-surface.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Transformations.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Types.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-User-Fonts.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Version-Information.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Win32-Fonts.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Win32-GDI-Fonts.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-Win32-Surfaces.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-XCB-Surfaces.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-XLib-Surfaces.html
@ -98,15 +102,6 @@ libdata/pkgconfig/cairo.pc
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo-text.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/cairo.devhelp2
%%PORTDOCS%%%%DOCSDIR%%/cairo/home.png
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.10.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.12.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.14.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.16.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.2.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.4.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.6.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-1.8.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index-all.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/index.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/language-bindings.html
%%PORTDOCS%%%%DOCSDIR%%/cairo/left-insensitive.png

View file

@ -96,13 +96,6 @@ WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
libwpe-1.0.so:www/libwpe \
libWPEBackend-fdo-1.0.so:www/wpebackend-fdo
pre-configure:
# .if !exists() evaluates too early before cairo has a chance to be installed
@if ! pkg-config --exists cairo-egl; then \
${ECHO_MSG} "${PKGNAME}: Needs cairo with OPENGL support enabled."; \
${FALSE}; \
fi
post-install:
@${RLN} ${STAGEDIR}${PREFIX}/libexec/webkit2gtk-4.0/jsc \
${STAGEDIR}${PREFIX}/bin/jsc-4

View file

@ -101,13 +101,6 @@ WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
CXXFLAGS+= -Wno-error=enum-constexpr-conversion
.endif
pre-configure:
# .if !exists() evaluates too early before cairo has a chance to be installed
@if ! pkg-config --exists cairo-egl; then \
${ECHO_MSG} "${PKGNAME}: Needs cairo with OPENGL support enabled."; \
${FALSE}; \
fi
post-install:
@${RLN} ${STAGEDIR}${PREFIX}/libexec/webkit2gtk-5.0/jsc \
${STAGEDIR}${PREFIX}/bin/jsc-5

View file

@ -42,6 +42,7 @@ post-patch:
-e '/ rt)/d' \
-e '/install.*systemd/d' \
${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} '/GLES3/d' ${WRKSRC}/src/includes.hpp
# Respect consolekit2 as XDG_RUNTIME_DIR fallback
@${REINPLACE_CMD} 's,/run/user,/var&,' \
${WRKSRC}/src/ipc/Socket.cpp

View file

@ -1,11 +1,7 @@
--- CMakeLists.txt.orig 2022-02-01 17:36:09 UTC
+++ CMakeLists.txt
@@ -8,11 +8,9 @@ project(rofi-file-browser-extended)
# Plugin
find_package(PkgConfig)
-pkg_search_module(GLIB2 REQUIRED glib-2.0)
+pkg_search_module(GLIB REQUIRED glib-2.0)
@@ -11,8 +11,6 @@ pkg_search_module(CAIRO REQUIRED cairo)
pkg_search_module(GLIB2 REQUIRED glib-2.0)
pkg_search_module(CAIRO REQUIRED cairo)
-pkg_get_variable(ROFI_PLUGINS_DIR rofi pluginsdir)
@ -13,16 +9,18 @@
include_directories(
include
${GLIB2_INCLUDE_DIRS}
@@ -37,7 +35,7 @@ add_library(filebrowser SHARED ${SRC})
@@ -37,8 +35,8 @@ target_link_libraries(filebrowser
set_target_properties(filebrowser PROPERTIES PREFIX "")
target_link_libraries(filebrowser
- ${GLIB2_LIBRARIES}
+ ${GLIB_LDFLAGS}
${CAIRO_LIBRARIES}
- ${CAIRO_LIBRARIES}
+ ${GLIB2_LDFLAGS}
+ ${CAIRO_LDFLAGS}
)
@@ -53,4 +51,4 @@ add_custom_command(OUTPUT "${CMAKE_CURRENT_SOURCE_DIR}
install(TARGETS filebrowser DESTINATION ${ROFI_PLUGINS_DIR})
@@ -53,4 +51,4 @@ add_custom_target(manpage ALL DEPENDS "${CMAKE_CURRENT
add_custom_target(manpage ALL DEPENDS "${CMAKE_CURRENT_SOURCE_DIR}/doc/rofi-file-browser-extended.1.gz")