mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
sysutils/vtm: New port: Text-based desktop environment
Text based desktop environment inside the terminal. Allows for tiling terminal buffers, detaching sessions and remote collaborative work. WWW: https://github.com/directvt/vtm PR: 263864 Reported by: Daniel Pérez <y7v81xhon@mozmail.com>
This commit is contained in:
parent
cd3812a835
commit
294265d4bd
5 changed files with 65 additions and 0 deletions
|
@ -1518,6 +1518,7 @@
|
|||
SUBDIR += vobcopy
|
||||
SUBDIR += volman
|
||||
SUBDIR += vpnc-scripts
|
||||
SUBDIR += vtm
|
||||
SUBDIR += vttest
|
||||
SUBDIR += wait_on
|
||||
SUBDIR += walk
|
||||
|
|
27
sysutils/vtm/Makefile
Normal file
27
sysutils/vtm/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
PORTNAME= vtm
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.9.99.70
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= nxjoseph@protonmail.com
|
||||
COMMENT= Text-based desktop environment
|
||||
WWW= https://github.com/directvt/vtm
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= cmake compiler:c++20-lang lua pkgconfig
|
||||
USE_CXXSTD= c++20
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= directvt
|
||||
|
||||
CFLAGS+= -I${LUA_INCDIR}
|
||||
LDFLAGS+= -L${LUA_LIBDIR}
|
||||
|
||||
PLIST_FILES= bin/vtm
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} 's/lua-5.4/lua-${LUA_VER}/g' \
|
||||
${WRKSRC}/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
3
sysutils/vtm/distinfo
Normal file
3
sysutils/vtm/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1741550105
|
||||
SHA256 (directvt-vtm-v0.9.99.70_GH0.tar.gz) = 9068151b389723a1f6059296359c49dde77f18c2f08af050b33a34f3d06ad1c2
|
||||
SIZE (directvt-vtm-v0.9.99.70_GH0.tar.gz) = 1900004
|
31
sysutils/vtm/files/patch-CMakeLists.txt
Normal file
31
sysutils/vtm/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- CMakeLists.txt.orig 2025-03-07 15:17:49 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -29,24 +29,15 @@ endif()
|
||||
#set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -static -pthread -s")
|
||||
endif()
|
||||
|
||||
-# Lua
|
||||
-include(FetchContent)
|
||||
-FetchContent_Declare(lua
|
||||
- URL https://www.lua.org/ftp/lua-5.4.7.tar.gz
|
||||
- URL_HASH SHA256=9fbf5e28ef86c69858f6d3d34eccc32e911c1a28b4120ff3e84aaa70cfbf1e30
|
||||
- DOWNLOAD_EXTRACT_TIMESTAMP true)
|
||||
-FetchContent_MakeAvailable(lua)
|
||||
-file(GLOB lua_src CONFIGURE_DEPENDS ${lua_SOURCE_DIR}/src/*.c)
|
||||
-list(REMOVE_ITEM lua_src ${lua_SOURCE_DIR}/src/lua.c ${lua_SOURCE_DIR}/src/luac.c)
|
||||
-add_library(lua ${lua_src})
|
||||
-target_include_directories(lua PUBLIC ${lua_SOURCE_DIR}/src)
|
||||
-target_sources(lua PRIVATE ${lua_src})
|
||||
+find_package(PkgConfig)
|
||||
|
||||
+pkg_check_modules(LUA REQUIRED lua-5.4 IMPORTED_TARGET GLOBAL)
|
||||
+
|
||||
add_executable(vtm "src/vtm.cpp" ${WIN32_RESOURCES})
|
||||
# add_executable(term "src/netxs/apps/term.cpp")
|
||||
# add_executable(calc "src/netxs/apps/calc.cpp")
|
||||
|
||||
-target_link_libraries(vtm lua)
|
||||
+target_link_libraries(vtm ${LUA_LIBRARIES})
|
||||
# target_link_libraries(term lua)
|
||||
# target_link_libraries(calc lua)
|
||||
|
3
sysutils/vtm/pkg-descr
Normal file
3
sysutils/vtm/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
Text based desktop environment inside the terminal.
|
||||
Allows for tiling terminal buffers, detaching sessions
|
||||
and remote collaborative work.
|
Loading…
Add table
Reference in a new issue