graphics/py-pygeos: Update to 0.14

- Convert to USE_PYTHON=pep517

Changes:	https://github.com/pygeos/pygeos/releases
		https://github.com/pygeos/pygeos/blob/master/CHANGELOG.rst
This commit is contained in:
Po-Chuan Hsieh 2023-05-08 00:04:02 +08:00
parent 50a57c5184
commit 265d8a94e1
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
3 changed files with 19 additions and 8 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= pygeos
PORTVERSION= 0.12.0
PORTREVISION= 1
PORTVERSION= 0.14
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -12,13 +11,14 @@ WWW= https://github.com/pygeos/pygeos
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= geos>=3.5:graphics/geos \
${PYTHON_PKGNAMEPREFIX}numpy>=1.13,1:math/py-numpy@${PY_FLAVOR}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.13,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools>=61.0.0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libgeos.so:graphics/geos
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.13,1:math/py-numpy@${PY_FLAVOR}
USES= python:3.8+
USE_PYTHON= autoplist concurrent cython distutils
USE_PYTHON= autoplist concurrent cython pep517
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1655208286
SHA256 (pygeos-0.12.0.tar.gz) = 3c41542ef67c66015f443ae3e6e683503a8a221f9c24fb2380f6ae42aed1600a
SIZE (pygeos-0.12.0.tar.gz) = 141393
TIMESTAMP = 1683227639
SHA256 (pygeos-0.14.tar.gz) = 30fbc17f64844200b85133b885fcfb65541b8779531f6ef4f8fe467d3fba7623
SIZE (pygeos-0.14.tar.gz) = 141330

View file

@ -0,0 +1,11 @@
--- pyproject.toml.orig 2022-12-12 08:21:17 UTC
+++ pyproject.toml
@@ -2,7 +2,7 @@
# numpy and Cython are required to execute setup.py to build Cython extensions
requires = [
"Cython~=0.29",
- "oldest-supported-numpy",
+ "numpy",
"setuptools>=61.0.0",
]
build-backend = "setuptools.build_meta"