* Updated version to 0.2.1.1

* Added MetaLab(sunsite) mirror to MASTER_SITES
* Fixed some files to respect CFLAGS properly

PR:		14903
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
Steve Price 1999-11-26 17:50:47 +00:00
parent 3685d4b9a9
commit 23cdd5ebb9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=23357
6 changed files with 106 additions and 12 deletions

View file

@ -1,5 +1,5 @@
# New ports collection makefile for: cpm-emulator
# Version required: 0.2.1
# Version required: 0.2.1.1
# Date created: 28 June 1995
# Whom: janek@gaja.ipan.lublin.pl
#
@ -7,19 +7,17 @@
#
DISTNAME= cpm-0.2.1
PKGNAME= cpmemu-0.2.1
PKGNAME= cpmemu-0.2.1.1
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.cdrom.com/pub/linux/slackware-4.0/source/extra-stuff/CPM-80-emulator/
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
ftp://ftp.cdrom.com/pub/linux/slackware-4.0/source/extra-stuff/CPM-80-emulator/
MASTER_SITE_SUBDIR= system/emulators
PATCH_SITES= ${MASTER_SITE_SUNSITE}
PATCH_SITE_SUBDIR= system/emulators
PATCHFILES= cpm-0.2.1-glibc-rjm.patch.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cpm ${PREFIX}/bin/cpmemu
${INSTALL_PROGRAM} ${WRKSRC}/format ${PREFIX}/bin/cpmformat
${MKDIR} ${PREFIX}/share/cpm
${INSTALL_DATA} ${WRKSRC}/z80-binaries/cpm.sys ${PREFIX}/share/cpm
${INSTALL_DATA} ${WRKSRC}/z80-binaries/cd.com ${PREFIX}/share/cpm
${INSTALL_DATA} ${WRKSRC}/z80-binaries/link.com ${PREFIX}/share/cpm
${INSTALL_DATA} ${WRKSRC}/z80-binaries/xccp.com ${PREFIX}/share/cpm
.include <bsd.port.mk>

View file

@ -1 +1,2 @@
MD5 (cpm-0.2.1.tar.gz) = b6aa29c7164e10c2a0ad2f4ac72c3a83
MD5 (cpm-0.2.1-glibc-rjm.patch.gz) = 029b902a7a59239182ea264e02e33345

View file

@ -0,0 +1,52 @@
--- Makefile.orig Mon Nov 15 06:49:52 1999
+++ Makefile Mon Nov 15 06:54:21 1999
@@ -2,26 +2,26 @@
# basic prefix for installation
-PREFIX = /usr/local
+PREFIX ?= /usr/local
# where to install `cpm' executable.
BINDIR = $(PREFIX)/bin
# where `cpm' looks for its files (cpm.sys and .com files).
-CPMLIBDIR = $(PREFIX)/lib/cpm
+CPMLIBDIR = $(PREFIX)/share/cpm
# You shouldn't need to edit below this line.
-CC = gcc
+CC ?= gcc
-CFLAGS = -O2 -pipe -ansi -Wall \
+CFLAGS += -ansi -Wall \
-Wshadow -Wpointer-arith -Wcast-qual -Wcast-align \
-Waggregate-return -Wstrict-prototypes -Wmissing-prototypes \
-Wnested-externs -Wwrite-strings \
-DCPMLIBDIR=\"$(CPMLIBDIR)\"
-LDFLAGS = -s
+LDFLAGS += -s
OBJS = single.o z80emu.o em.o io.o bios.o \
commands.o running.o main.o disneu.o disz80.o low.o
@@ -42,11 +42,14 @@
cpm: $(OBJS)
$(CC) $(LDFLAGS) -o cpm $(OBJS)
+format: format.o
+ $(CC) $(LDFLAGS) -o format format.o
+
clean:
rm -f *~ loads.s makeloads *.o $(TARGETS)
install: all
- install -m 511 cpm $(BINDIR)
+ ${BSD_INSTALL_PROGRAM} cpm $(BINDIR)/cpmemu
+ ${BSD_INSTALL_PROGRAM} format $(BINDIR)/cpmformat
-mkdir $(CPMLIBDIR)
- chmod 755 $(CPMLIBDIR)
- install -m 444 z80-binaries/* $(CPMLIBDIR)
+ ${BSD_INSTALL_DATA} z80-binaries/* $(CPMLIBDIR)

View file

@ -0,0 +1,11 @@
--- bios.c.orig Mon Nov 15 06:33:54 1999
+++ bios.c Mon Nov 15 06:39:55 1999
@@ -227,7 +227,7 @@
case BIOS: /* System Reset (coldboot) */
case DIRBUF-20:
if (!silent_exit)
- printf("\nCp/M BIOS COLDBOOT takes you back to Linux\n");
+ printf("\nCp/M BIOS COLDBOOT takes you back to FreeBSD\n");
exit(0);
case BIOS+3: /* System Reset (warmboot) */
case DIRBUF-19:

View file

@ -0,0 +1,11 @@
--- io.c.orig Wed Jun 22 03:25:46 1994
+++ io.c Mon Nov 15 06:31:36 1999
@@ -13,7 +13,7 @@
/*****************************************************************************/
#include "cpmemu.h"
-#define HAVE_RAW_IO
+#undef HAVE_RAW_IO
/* magic for character I/O */
#include <unistd.h>

View file

@ -0,0 +1,21 @@
--- low.c.orig Mon Nov 15 06:33:54 1999
+++ low.c Mon Nov 15 06:41:26 1999
@@ -21,7 +21,6 @@
#include "cpmemu.h"
#include <ctype.h>
#include <unistd.h>
-#include <sys/perm.h> /* needed for ioperm() -rjm */
#include <sys/types.h>
#include <sys/time.h>
#include <signal.h>
@@ -88,10 +87,8 @@
/* get access to sound port */
cptr = NULL;
- if (ioperm(0x61, 1, 1)) {
hardware_access = 0; /* no access to speaker port */
return;
- }
/* install signal handler */
sa.sa_handler = tickerint;