misc/py-openvdb: update 11.0.0 → 12.0.1

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2025-04-04 01:54:04 -07:00
parent 6e66bb5b58
commit 231c7e45b9
4 changed files with 20 additions and 12 deletions

View file

@ -1,18 +1,18 @@
PORTNAME= openvdb
DISTVERSIONPREFIX= v
DISTVERSION= 11.0.0
PORTREVISION= 6
DISTVERSION= 12.0.1
CATEGORIES= misc
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Tools for storage and manipulation of sparse volumetric data
WWW= https://www.openvdb.org/
WWW= https://www.openvdb.org \
https://github.com/AcademySoftwareFoundation/openvdb
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/../../../LICENSE
BUILD_DEPENDS= pybind11>0:devel/pybind11 \
BUILD_DEPENDS= nanobind>0:devel/nanobind \
${PYNUMPY}
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
libopenvdb.so:misc/openvdb \
@ -28,13 +28,14 @@ GH_ACCOUNT= AcademySoftwareFoundation
CMAKE_ON= USE_NUMPY OPENVDB_PYTHON_WRAP_ALL_GRID_TYPES
CMAKE_OFF= OPENVDB_BUILD_PYTHON_UNITTESTS
CMAKE_ARGS= -DPython_EXECUTABLE=${PYTHON_CMD}
CMAKE_ARGS= -DPython_EXECUTABLE=${PYTHON_CMD} \
-DFREEBSD_PYTHON_VER=${PYTHON_VER}
WRKSRC_SUBDIR= openvdb/openvdb/python
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
PLIST_FILES= ${PYTHON_SITELIBDIR}/pyopenvdb${PYTHON_EXT_SUFFIX}.so
PLIST_FILES= ${PYTHON_SITELIBDIR}/openvdb${PYTHON_EXT_SUFFIX}.so
do-test: # run an example, since the supplied test appears to be only for Windows
@cd ${WRKSRC} && \

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1712017184
SHA256 (AcademySoftwareFoundation-openvdb-v11.0.0_GH0.tar.gz) = 6314ff1db057ea90050763e7b7d7ed86d8224fcd42a82cdbb9c515e001b96c74
SIZE (AcademySoftwareFoundation-openvdb-v11.0.0_GH0.tar.gz) = 4620858
TIMESTAMP = 1743748486
SHA256 (AcademySoftwareFoundation-openvdb-v12.0.1_GH0.tar.gz) = a3c8724ecadabaf558b6e1bd6f1d695e93b82a7cfdf144b8551e5253340ddce0
SIZE (AcademySoftwareFoundation-openvdb-v12.0.1_GH0.tar.gz) = 4708771

View file

@ -1,6 +1,6 @@
# example from https://www.openvdb.org/documentation/doxygen/python.html
import pyopenvdb as vdb
import openvdb as vdb
# A grid comprises a sparse tree representation of voxel data,
# user-supplied metadata and a voxel space to world space transform,

View file

@ -1,11 +1,18 @@
--- CMakeLists.txt.orig 2022-10-27 23:35:20 UTC
--- CMakeLists.txt.orig 2025-04-03 05:22:14 UTC
+++ CMakeLists.txt
@@ -12,6 +12,9 @@ project(OpenVDBPython LANGUAGES CXX)
@@ -12,6 +12,16 @@ include(GNUInstallDirs)
include(GNUInstallDirs)
+set(CMAKE_MODULE_PATH "${CMAKE_INSTALL_PREFIX}/lib/cmake/OpenVDB" ${CMAKE_MODULE_PATH})
+find_package(OpenVDB REQUIRED)
+find_package(Python ${FREEBSD_PYTHON_VER} EXACT REQUIRED COMPONENTS Development Interpreter)
+find_package(nanobind REQUIRED)
+set(Python_PACKAGES_DIR "site-packages")
+set(VDB_PYTHON_INSTALL_DIRECTORY
+ ${CMAKE_INSTALL_LIBDIR}/python${Python_VERSION_MAJOR}.${Python_VERSION_MINOR}/${Python_PACKAGES_DIR}
+ CACHE STRING "The directory to install the openvdb and nanovdb Python modules."
+)
+
###### OpenVDB Python Options