mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
chinese/ibus-table-chinese: Update to 1.8.12
- De-DEPRECATED - Change to new upstream
This commit is contained in:
parent
7b78350041
commit
22522d8fcb
4 changed files with 52 additions and 10 deletions
|
@ -1,18 +1,14 @@
|
|||
PORTNAME= ibus-table-chinese
|
||||
PORTVERSION= 1.8.3
|
||||
PORTVERSION= 1.8.12
|
||||
CATEGORIES= chinese
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Chinese input tables for IBus
|
||||
WWW= https://github.com/definite/ibus-table-chinese
|
||||
WWW= https://github.com/mike-fabian/ibus-table-chinese
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN= does not build: TypeError: cannot use a string pattern on a bytes-like object
|
||||
DEPRECATED= Broken since 2021
|
||||
EXPIRATION_DATE= 2023-03-21
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/share/cmake/Modules/ManageEnvironment.cmake:devel/cmake-fedora \
|
||||
ibus-daemon:textproc/ibus \
|
||||
${LOCALBASE}/libexec/ibus-engine-table:textproc/ibus-table
|
||||
|
@ -22,7 +18,7 @@ RUN_DEPENDS= ibus-daemon:textproc/ibus \
|
|||
USES= cmake:insource,noninja pkgconfig
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= definite
|
||||
GH_ACCOUNT= mike-fabian
|
||||
|
||||
INSTALL_TARGET= install
|
||||
DATADIR= ${PREFIX}/share/ibus-table
|
||||
|
@ -31,4 +27,9 @@ CMAKE_ARGS+= -DDATA_DIR:PATH="${PREFIX}/share" \
|
|||
-DCMAKE_FEDORA_TMP_DIR:PATH="${WRKSRC}"
|
||||
MAKE_ENV+= PYTHONDONTWRITEBYTECODE=1
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
|
||||
-e 's,%%DOCSDIR%%,${DOCSDIR},' \
|
||||
${WRKSRC}/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1608203500
|
||||
SHA256 (definite-ibus-table-chinese-1.8.3_GH0.tar.gz) = aa22c223ef26bacbc25ae756702af06dcaaff58c1d62e2375a58c5b78aa656b8
|
||||
SIZE (definite-ibus-table-chinese-1.8.3_GH0.tar.gz) = 10824912
|
||||
TIMESTAMP = 1676914416
|
||||
SHA256 (mike-fabian-ibus-table-chinese-1.8.12_GH0.tar.gz) = 41d9923bf207e2be6fb50813ad994eda6460af78c66c576591aac3da4c8c53a9
|
||||
SIZE (mike-fabian-ibus-table-chinese-1.8.12_GH0.tar.gz) = 10856736
|
||||
|
|
34
chinese/ibus-table-chinese/files/patch-CMakeLists.txt
Normal file
34
chinese/ibus-table-chinese/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- CMakeLists.txt.orig 2023-02-20 21:21:01 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -1,7 +1,7 @@
|
||||
cmake_minimum_required(VERSION 3.0.0)
|
||||
|
||||
# Default CMAKE_INSTALL_PREFIX should be set before PROJECT()
|
||||
-SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "Install dir prefix")
|
||||
+SET(CMAKE_INSTALL_PREFIX "%%PREFIX%%" CACHE PATH "Install dir prefix")
|
||||
|
||||
####################################################################
|
||||
# Project specific information
|
||||
@@ -21,12 +21,12 @@ Input tables themselves are in subpackages."
|
||||
)
|
||||
|
||||
IF(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||
- SET(LIB_DIR "${CMAKE_INSTALL_PREFIX}/lib64" CACHE PATH "Library dir")
|
||||
+ SET(LIB_DIR "${CMAKE_INSTALL_PREFIX}/lib" CACHE PATH "Library dir")
|
||||
ELSE(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||
SET(LIB_DIR "${CMAKE_INSTALL_PREFIX}/lib" CACHE PATH "Library dir")
|
||||
ENDIF(CMAKE_SYSTEM_PROCESSOR MATCHES "64")
|
||||
SET(LIBEXEC_DIR "${LIB_DIR}" CACHE PATH "LIBEXEC dir")
|
||||
-SET(DATA_DIR "/usr/share")
|
||||
+SET(DATA_DIR "%%PREFIX%%/share")
|
||||
|
||||
####################################################################
|
||||
# Building
|
||||
@@ -36,6 +36,6 @@ ADD_SUBDIRECTORY(tables)
|
||||
####################################################################
|
||||
# Installing
|
||||
#
|
||||
-SET(PRJ_DOC_DIR "${DATA_DIR}/doc/ibus-table-chinese")
|
||||
+SET(PRJ_DOC_DIR "%%DOCSDIR%%")
|
||||
INSTALL(FILES AUTHORS README ChangeLog COPYING DESTINATION ${PRJ_DOC_DIR})
|
||||
|
|
@ -5,24 +5,31 @@
|
|||
%%DATADIR%%/icons/array30-big.png
|
||||
%%DATADIR%%/icons/array30.png
|
||||
%%DATADIR%%/icons/cangjie-big.png
|
||||
%%DATADIR%%/icons/cangjie-big.svg
|
||||
%%DATADIR%%/icons/cangjie3.svg
|
||||
%%DATADIR%%/icons/cangjie5.svg
|
||||
%%DATADIR%%/icons/cantonese.png
|
||||
%%DATADIR%%/icons/cantonese.svg
|
||||
%%DATADIR%%/icons/cantonhk.png
|
||||
%%DATADIR%%/icons/cantonyale.png
|
||||
%%DATADIR%%/icons/cantonyale.svg
|
||||
%%DATADIR%%/icons/easy-big.png
|
||||
%%DATADIR%%/icons/erbi-qs.svg
|
||||
%%DATADIR%%/icons/erbi.png
|
||||
%%DATADIR%%/icons/jyutping.png
|
||||
%%DATADIR%%/icons/quick-classic.png
|
||||
%%DATADIR%%/icons/quick-classic.svg
|
||||
%%DATADIR%%/icons/quick3.png
|
||||
%%DATADIR%%/icons/quick5.png
|
||||
%%DATADIR%%/icons/scj6.svg
|
||||
%%DATADIR%%/icons/stroke5.png
|
||||
%%DATADIR%%/icons/stroke5.svg
|
||||
%%DATADIR%%/icons/wu.png
|
||||
%%DATADIR%%/icons/wu.svg
|
||||
%%DATADIR%%/icons/wubi-haifeng86.svg
|
||||
%%DATADIR%%/icons/wubi-jidian86.svg
|
||||
%%DATADIR%%/icons/yong.png
|
||||
%%DATADIR%%/icons/yong.svg
|
||||
%%DATADIR%%/tables/array30-big.db
|
||||
%%DATADIR%%/tables/array30.db
|
||||
%%DATADIR%%/tables/cangjie-big.db
|
||||
|
|
Loading…
Add table
Reference in a new issue