mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 10:36:38 -04:00
databases/py-pyarrow: Update to 17.0.0
- Convert to USES=cmake:indirect Changes: https://arrow.apache.org/release/
This commit is contained in:
parent
bb05c04b38
commit
1aa952c22c
4 changed files with 19 additions and 31 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= pyarrow
|
PORTNAME= pyarrow
|
||||||
PORTVERSION= 15.0.2
|
PORTVERSION= 17.0.0
|
||||||
CATEGORIES= databases python
|
CATEGORIES= databases python
|
||||||
MASTER_SITES= PYPI
|
MASTER_SITES= PYPI
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
@ -12,17 +12,18 @@ WWW= https://arrow.apache.org/ \
|
||||||
LICENSE= APACHE20
|
LICENSE= APACHE20
|
||||||
|
|
||||||
BUILD_DEPENDS= arrow>=${PORTVERSION}<${PORTVERSION}_99:databases/arrow \
|
BUILD_DEPENDS= arrow>=${PORTVERSION}<${PORTVERSION}_99:databases/arrow \
|
||||||
cmake:devel/cmake-core \
|
${PYTHON_PKGNAMEPREFIX}numpy>=1.25,1:math/py-numpy@${PY_FLAVOR} \
|
||||||
${PYTHON_PKGNAMEPREFIX}numpy>=0.14,1:math/py-numpy@${PY_FLAVOR} \
|
${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
|
||||||
${PYTHON_PKGNAMEPREFIX}setuptools>=40.1.0:devel/py-setuptools@${PY_FLAVOR} \
|
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=8:devel/py-setuptools-scm@${PY_FLAVOR} \
|
||||||
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR} \
|
|
||||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||||
LIB_DEPENDS= libarrow.so:databases/arrow
|
LIB_DEPENDS= libarrow.so:databases/arrow
|
||||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.16.6,1<2,1:math/py-numpy@${PY_FLAVOR}
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.16.6,1<2,1:math/py-numpy@${PY_FLAVOR}
|
||||||
|
|
||||||
USES= python
|
USES= cmake:indirect python shebangfix
|
||||||
USE_PYTHON= autoplist concurrent cython pep517
|
USE_PYTHON= autoplist concurrent cython pep517
|
||||||
|
|
||||||
|
SHEBANG_FILES= cmake_modules/aws_sdk_cpp_generate_variables.sh
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||||
|
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1711222294
|
TIMESTAMP = 1721710236
|
||||||
SHA256 (pyarrow-15.0.2.tar.gz) = 9c9bc803cb3b7bfacc1e96ffbfd923601065d9d3f911179d81e72d99fd74a3d9
|
SHA256 (pyarrow-17.0.0.tar.gz) = 4beca9521ed2c0921c1023e68d097d0299b62c362639ea315572a58f3f50fd28
|
||||||
SIZE (pyarrow-15.0.2.tar.gz) = 1064226
|
SIZE (pyarrow-17.0.0.tar.gz) = 1112479
|
||||||
|
|
|
@ -1,13 +1,11 @@
|
||||||
--- pyproject.toml.orig 2024-03-13 13:39:08 UTC
|
--- pyproject.toml.orig 2024-07-11 08:59:52 UTC
|
||||||
+++ pyproject.toml
|
+++ pyproject.toml
|
||||||
@@ -18,8 +18,8 @@ requires = [
|
@@ -27,7 +27,7 @@ requires = [
|
||||||
[build-system]
|
# configuring setuptools_scm in pyproject.toml requires
|
||||||
requires = [
|
# versions released after 2022
|
||||||
"cython >= 0.29.31",
|
"setuptools_scm[toml]>=8",
|
||||||
- "oldest-supported-numpy>=0.14",
|
- "setuptools>=64",
|
||||||
- "setuptools_scm < 8.0.0",
|
+ "setuptools>=61",
|
||||||
+ "numpy>=0.14",
|
|
||||||
+ "setuptools_scm",
|
|
||||||
"setuptools >= 40.1.0",
|
|
||||||
"wheel"
|
|
||||||
]
|
]
|
||||||
|
build-backend = "setuptools.build_meta"
|
||||||
|
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- setup.py.orig 2024-03-24 09:40:30 UTC
|
|
||||||
+++ setup.py
|
|
||||||
@@ -492,7 +492,7 @@ setup(
|
|
||||||
'pyarrow/_generated_version.py'),
|
|
||||||
'version_scheme': guess_next_dev_version
|
|
||||||
},
|
|
||||||
- setup_requires=['setuptools_scm < 8.0.0', 'cython >= 0.29.31'] + setup_requires,
|
|
||||||
+ setup_requires=['setuptools_scm', 'cython >= 0.29.31'] + setup_requires,
|
|
||||||
install_requires=install_requires,
|
|
||||||
tests_require=['pytest', 'pandas', 'hypothesis'],
|
|
||||||
python_requires='>=3.8',
|
|
Loading…
Add table
Reference in a new issue