- Update science/netcdf4 to 4.0.1

- Bump PORTREVISION for dependent ports

PR:		ports/136377
Submitted by:	Sunpoet Po-Chuan Hsieh <sunpoet at sunpoet.net> (maintainer)
Feature safe:	yes
This commit is contained in:
Rong-En Fan 2009-09-26 15:11:38 +00:00
parent 9afeaca11b
commit 18581ecd56
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=242144
8 changed files with 35 additions and 14 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= NetCDF PORTNAME= NetCDF
PORTVERSION= 1.2.3 PORTVERSION= 1.2.3
PORTREVISION= 1
CATEGORIES= math perl5 CATEGORIES= math perl5
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf-perl/ MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf-perl/
PKGNAMEPREFIX= p5- PKGNAMEPREFIX= p5-
@ -19,7 +20,7 @@ COMMENT= Perl5 module to read and write netCDF files
NETCDF_VER?= 4 NETCDF_VER?= 4
.if (${NETCDF_VER} == 4) .if (${NETCDF_VER} == 4)
LIB_DEPENDS= netcdf.5:${PORTSDIR}/science/netcdf4 LIB_DEPENDS= netcdf.6:${PORTSDIR}/science/netcdf4
.else .else
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
.endif .endif

View file

@ -0,0 +1,13 @@
--- perl/NetCDF.xs.orig 2003-01-10 00:09:14.000000000 +0800
+++ perl/NetCDF.xs 2009-09-26 06:10:36.000000000 +0800
@@ -23,6 +23,10 @@
#include <assert.h>
#include "netcdf.h"
+#if !defined(MAX_NC_OPEN)
+#define MAX_NC_OPEN sysconf(_SC_OPEN_MAX)
+#endif
+
/*
* Macro for setting a scalar value either directly or through a reference:
*/

View file

@ -8,6 +8,7 @@
PORTNAME= cdo PORTNAME= cdo
PORTVERSION= 1.3.1 PORTVERSION= 1.3.1
PORTREVISION= 1
CATEGORIES= science CATEGORIES= science
MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \ MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
http://sunpoet.net/distfiles/ http://sunpoet.net/distfiles/
@ -47,7 +48,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-Makefile.in
.if (${NETCDF_VER} == 4) .if (${NETCDF_VER} == 4)
HDF5_VER= 18 HDF5_VER= 18
WITH_HDF5= yes WITH_HDF5= yes
LIB_DEPENDS+= netcdf.5:${PORTSDIR}/science/netcdf4 LIB_DEPENDS+= netcdf.6:${PORTSDIR}/science/netcdf4
.else .else
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
.endif .endif

View file

@ -6,7 +6,7 @@
# #
PORTNAME= netcdf PORTNAME= netcdf
PORTVERSION= 4.0 PORTVERSION= 4.0.1
CATEGORIES= science CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \ MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \ ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@ -19,8 +19,8 @@ CONFLICTS= hdf-4.* netcdf-3.*
LATEST_LINK= netcdf4 LATEST_LINK= netcdf4
CONFIGURE_ARGS= --disable-f77 --disable-f90 \ CONFIGURE_ARGS= --disable-f77 --disable-f90 \
--enable-cxx --enable-cxx-4 --enable-netcdf-4 --enable-shared \ --enable-cxx --enable-cxx-4 --enable-ncgen4 --enable-netcdf-4 \
--with-hdf5=${LOCALBASE} --with-zlib=/usr --enable-shared --with-hdf5=${LOCALBASE} --with-zlib=/usr
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran" CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
MAKE_ENV+= MAKEINFOFLAGS="--no-split" INFODIR="${PREFIX}/${INFO_PATH}" MAKE_ENV+= MAKEINFOFLAGS="--no-split" INFODIR="${PREFIX}/${INFO_PATH}"
@ -32,7 +32,7 @@ LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
INFO= netcdf netcdf-c netcdf-cxx netcdf-cxx4 netcdf-f77 \ INFO= netcdf netcdf-c netcdf-cxx netcdf-cxx4 netcdf-f77 \
netcdf-f90 netcdf-install netcdf-tutorial netcdf-f90 netcdf-install netcdf-tutorial
MAN1= ncdump.1 ncgen.1 MAN1= ncdump.1 ncgen.1 ncgen4.1
MAN3= netcdf.3 MAN3= netcdf.3
OPTIONS= HDF5_CONVERT "Do data conversion through HDF5" off OPTIONS= HDF5_CONVERT "Do data conversion through HDF5" off
@ -49,14 +49,14 @@ CONFIGURE_ARGS+=--enable-hdf5-convert
post-patch: post-patch:
.if defined(NOPORTDOCS) .if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e '814 s/install-docDATA //' \ @${REINPLACE_CMD} -e '829 s/install-docDATA //' \
${WRKSRC}/man4/Makefile.in ${WRKSRC}/man4/Makefile.in
.endif .endif
@${REINPLACE_CMD} -e \ @${REINPLACE_CMD} -e \
's/\(@INSTALL_DOCS_TRUE@MAN.*\)/# \1/' \ 's/\(@INSTALL_DOCS_TRUE@MAN.*\)/# \1/' \
${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \ @${REINPLACE_CMD} -e \
'274 s/\(info_docs\).*/html_docs\)/' \ '288 s/\(info_docs\).*/html_docs\)/' \
${WRKSRC}/man4/Makefile.in ${WRKSRC}/man4/Makefile.in
post-configure: post-configure:

View file

@ -1,3 +1,3 @@
MD5 (netcdf-4.0.tar.gz) = afc057b07b6e6843556dcfbc4ced402c MD5 (netcdf-4.0.1.tar.gz) = a251453c5477599f050fa4e593295186
SHA256 (netcdf-4.0.tar.gz) = 4f6934fd862b2e0f5a6ddcd8ef5f86a03d8aebfd106bc09c97afc80fe2ad5c96 SHA256 (netcdf-4.0.1.tar.gz) = 290e377aa2e9419bb50a2fa1038d6e77d36f239a8a9c3be9e3a9319f1e484d19
SIZE (netcdf-4.0.tar.gz) = 11584002 SIZE (netcdf-4.0.1.tar.gz) = 8018998

View file

@ -6,4 +6,4 @@ library, and format support the creation, access, and sharing of
scientific data. The netCDF software was developed at the Unidata scientific data. The netCDF software was developed at the Unidata
Program Center in Boulder, Colorado. Program Center in Boulder, Colorado.
WWW: http://www.unidata.ucar.edu/packages/netcdf/ WWW: http://www.unidata.ucar.edu/software/netcdf/

View file

@ -1,5 +1,7 @@
bin/nc-config
bin/ncdump bin/ncdump
bin/ncgen bin/ncgen
bin/ncgen4
include/ncvalues.h include/ncvalues.h
include/netcdf.h include/netcdf.h
include/netcdf.hh include/netcdf.hh
@ -8,7 +10,7 @@ include/netcdfcpp4.h
lib/libnetcdf.a lib/libnetcdf.a
lib/libnetcdf.la lib/libnetcdf.la
lib/libnetcdf.so lib/libnetcdf.so
lib/libnetcdf.so.5 lib/libnetcdf.so.6
lib/libnetcdf_c++.a lib/libnetcdf_c++.a
lib/libnetcdf_c++.la lib/libnetcdf_c++.la
lib/libnetcdf_c++.so lib/libnetcdf_c++.so
@ -17,8 +19,10 @@ lib/libnetcdf_c++4.a
lib/libnetcdf_c++4.la lib/libnetcdf_c++4.la
lib/libnetcdf_c++4.so lib/libnetcdf_c++4.so
lib/libnetcdf_c++4.so.1 lib/libnetcdf_c++4.so.1
lib/pkgconfig/netcdf.pc
%%PORTDOCS%%%%DOCSDIR%%/ncdump-man-1.html %%PORTDOCS%%%%DOCSDIR%%/ncdump-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen-man-1.html %%PORTDOCS%%%%DOCSDIR%%/ncgen-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen4-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.html %%PORTDOCS%%%%DOCSDIR%%/netcdf-c.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.pdf %%PORTDOCS%%%%DOCSDIR%%/netcdf-c.pdf
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.ps %%PORTDOCS%%%%DOCSDIR%%/netcdf-c.ps
@ -55,3 +59,4 @@ lib/libnetcdf_c++4.so.1
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f77-man.html %%PORTDOCS%%%%DOCSDIR%%/netcdf_f77-man.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f90-man.html %%PORTDOCS%%%%DOCSDIR%%/netcdf_f90-man.html
%%PORTDOCS%%@dirrm %%DOCSDIR%% %%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry lib/pkgconfig

View file

@ -7,6 +7,7 @@
PORTNAME= netCDF4 PORTNAME= netCDF4
PORTVERSION= 0.8.1 PORTVERSION= 0.8.1
PORTREVISION= 1
CATEGORIES= science python CATEGORIES= science python
MASTER_SITES= http://netcdf4-python.googlecode.com/files/ \ MASTER_SITES= http://netcdf4-python.googlecode.com/files/ \
CHEESESHOP CHEESESHOP
@ -18,7 +19,7 @@ COMMENT= Python Interface to the NetCDF Library(versions 3 and 4)
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${BUILD_DEPENDS} RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18 \ LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18 \
netcdf.5:${PORTSDIR}/science/netcdf4 netcdf.6:${PORTSDIR}/science/netcdf4
USE_PYTHON= 2.5+ USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes USE_PYDISTUTILS= yes