filesystems/py-dfvfs: update to 20240505

This commit is contained in:
Antoine Brodin 2025-02-18 10:08:36 +00:00
parent cd6b0f51bf
commit 183dec0f36
3 changed files with 20 additions and 9 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= dfvfs PORTNAME= dfvfs
PORTVERSION= 20231208 PORTVERSION= 20240505
PORTREVISION= 1
CATEGORIES= filesystems security devel python CATEGORIES= filesystems security devel python
MASTER_SITES= https://github.com/log2timeline/dfvfs/releases/download/${PORTVERSION}/ \ MASTER_SITES= https://github.com/log2timeline/dfvfs/releases/download/${PORTVERSION}/ \
LOCAL/antoine LOCAL/antoine
@ -13,8 +12,12 @@ WWW= https://github.com/log2timeline/dfvfs
LICENSE= APACHE20 LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= libbde>=a:filesystems/libbde \ RUN_DEPENDS= libbde>=a:filesystems/libbde \
libcaes>=a:security/libcaes \
libewf>=0:devel/libewf \ libewf>=0:devel/libewf \
libfcrypto>=a:security/libfcrypto \
libfsapfs>=e:filesystems/libfsapfs \ libfsapfs>=e:filesystems/libfsapfs \
libfsext>=e:filesystems/libfsext \ libfsext>=e:filesystems/libfsext \
libfsfat>=e:filesystems/libfsfat \ libfsfat>=e:filesystems/libfsfat \
@ -45,7 +48,7 @@ RUN_DEPENDS= libbde>=a:filesystems/libbde \
USES= python USES= python
USE_LOCALE= en_US.UTF-8 USE_LOCALE= en_US.UTF-8
USE_PYTHON= autoplist concurrent cryptography distutils USE_PYTHON= autoplist cryptography pep517
DO_MAKE_TEST= ${SETENV} ${TEST_ENV} ${PYTHON_CMD} DO_MAKE_TEST= ${SETENV} ${TEST_ENV} ${PYTHON_CMD}
TEST_TARGET= run_tests.py TEST_TARGET= run_tests.py
@ -54,7 +57,4 @@ NO_ARCH= yes
# Upstream archive contains files with UTF-8 names # Upstream archive contains files with UTF-8 names
EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
post-patch:
${REINPLACE_CMD} "/cffi/d" ${WRKSRC}/requirements.txt
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1707754540 TIMESTAMP = 1739783519
SHA256 (dfvfs-20231208.tar.gz) = 522e5225738c14b9134001a7147cf5688538efe4ca42c6536837bb650a204664 SHA256 (dfvfs-20240505.tar.gz) = 5b60f302d57f5d771859c5718f2c7cba5bdaadba93b815a999c8e0a72f596d2e
SIZE (dfvfs-20231208.tar.gz) = 98086866 SIZE (dfvfs-20240505.tar.gz) = 98086812

View file

@ -0,0 +1,11 @@
--- dfvfs/lib/sqlite_database.py.orig 2023-12-03 10:56:43 UTC
+++ dfvfs/lib/sqlite_database.py
@@ -14,7 +14,7 @@ class SQLiteDatabaseFile(object):
_HAS_COLUMN_QUERY = 'PRAGMA table_info("{0:s}")'
_HAS_TABLE_QUERY = (
- 'SELECT name FROM sqlite_master WHERE type = "table"')
+ 'SELECT name FROM sqlite_master WHERE type = \'table\'')
_HEADER_SIGNATURE = b'SQLite format 3'