mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
graphics/graphviz: update to 12.2.1
This commit is contained in:
parent
58c3753ac7
commit
1453a4f0f2
6 changed files with 17 additions and 11 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= graphviz
|
||||
PORTVERSION= 12.2.0
|
||||
PORTVERSION= 12.2.1
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= graphics tk
|
||||
MASTER_SITES= https://gitlab.com/api/v4/projects/4207231/packages/generic/graphviz-releases/${PORTVERSION}/
|
||||
|
@ -40,6 +40,7 @@ CONFLICTS_INSTALL= ghmm
|
|||
|
||||
INSTALL_TARGET= install-strip
|
||||
PLIST_SUB= PORTVERSION="${PORTVERSION}"
|
||||
SHEBANG_FILES= cmd/dot/dot_sandbox
|
||||
|
||||
FIX_INCLUDE= lib/cdt/dthdr.h lib/pathplan/tri.h \
|
||||
lib/pathplan/pathutil.h lib/pathplan/solvers.h \
|
||||
|
@ -162,6 +163,7 @@ TCL_CONFIGURE_ENABLE= tcl
|
|||
TCL_CPPFLAGS= -I${TCL_INCLUDEDIR}
|
||||
TCL_CONFIGURE_ENV= TCLCONFIG="${TCL_LIBDIR}/tclConfig.sh"
|
||||
TCL_VARS= SHEBANG_FILES+=tclpkg/gv/demo/modgraph.tcl \
|
||||
SHEBANG_FILES+=tclpkg/gv/demo/modgraph.py \
|
||||
PLIST_SUB+=TCL_VER="${TCL_VER}"
|
||||
TK_CPPFLAGS= -I${TK_INCLUDEDIR}
|
||||
TK_CONFIGURE_ON= --with-wish=${WISH}
|
||||
|
@ -193,6 +195,8 @@ CONFIGURE_ARGS+= --program-transform-name="s/x/x/" \
|
|||
|
||||
.if ${PORT_OPTIONS:MPYTHON} || ${PORT_OPTIONS:MTCL}
|
||||
BINARY_ALIAS+= python3=${PYTHON_CMD}
|
||||
.else
|
||||
USES+= python:env
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MRUBY}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1730789047
|
||||
SHA256 (graphviz-12.2.0.tar.gz) = bd56a15908567ae56f77fcad167f30416b12f4147f91467cbf27265ce11140ad
|
||||
SIZE (graphviz-12.2.0.tar.gz) = 26813735
|
||||
TIMESTAMP = 1734282718
|
||||
SHA256 (graphviz-12.2.1.tar.gz) = 242bc18942eebda6db4039f108f387ec97856fc91ba47f21e89341c34b554df8
|
||||
SIZE (graphviz-12.2.1.tar.gz) = 26813453
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.ac.orig 2024-11-03 19:33:36 UTC
|
||||
--- configure.ac.orig 2024-12-06 23:55:56 UTC
|
||||
+++ configure.ac
|
||||
@@ -731,13 +731,13 @@ else
|
||||
@@ -730,13 +730,13 @@ else
|
||||
for l in "$lua_suffix" "" "54" "5.4" "53" "5.3" "52" "5.2" "51" "5.1" ; do
|
||||
pkgconfig_lua_found=`$PKG_CONFIG --exists lua$l 2>/dev/null`
|
||||
if test "$?" = "0" ; then
|
||||
|
@ -16,7 +16,7 @@
|
|||
LUA_LIBS="$LUA_LFLAGS "`$PKG_CONFIG --libs lualib$l`
|
||||
fi
|
||||
break
|
||||
@@ -1029,6 +1029,7 @@ else
|
||||
@@ -1028,6 +1028,7 @@ else
|
||||
RUBY_CFLAGS="$RUBY_CFLAGS -I`$RUBY $srcdir/config/config_ruby.rb vendorhdrdir`"
|
||||
RUBY_CFLAGS="$RUBY_CFLAGS -I`$RUBY $srcdir/config/config_ruby.rb sitehdrdir`"
|
||||
RUBY_CFLAGS="$RUBY_CFLAGS -I`$RUBY $srcdir/config/config_ruby.rb rubyhdrdir`"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- lib/expr/exgram.h.orig 2024-09-28 08:34:49 UTC
|
||||
--- lib/expr/exgram.h.orig 2024-12-06 23:55:56 UTC
|
||||
+++ lib/expr/exgram.h
|
||||
@@ -19,7 +19,7 @@ extern "C" {
|
||||
* with both yacc and bison
|
||||
|
@ -8,4 +8,4 @@
|
|||
+#if !defined(_EXGRAM_H)
|
||||
#define _EXGRAM_H
|
||||
|
||||
#include <cgraph/agxbuf.h>
|
||||
#include <cgraph/gv_ctype.h>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- plugin/xlib/vimdot.sh.orig 2023-01-21 19:59:25 UTC
|
||||
--- plugin/xlib/vimdot.sh.orig 2024-12-06 23:55:56 UTC
|
||||
+++ plugin/xlib/vimdot.sh
|
||||
@@ -9,7 +9,7 @@ fi
|
||||
@@ -9,7 +9,7 @@ error() { echo "$0: $*" >&2; exit 1; }
|
||||
error() { echo "$0: $*" >&2; exit 1; }
|
||||
|
||||
# Try $EDITOR first, else try vim or vi
|
||||
|
|
|
@ -8,6 +8,7 @@ bin/dijkstra
|
|||
bin/dot
|
||||
bin/dot2gxl
|
||||
bin/dot_builtins
|
||||
bin/dot_sandbox
|
||||
bin/edgepaint
|
||||
bin/fdp
|
||||
bin/gc
|
||||
|
@ -463,6 +464,7 @@ share/man/man1/diffimg.1.gz
|
|||
share/man/man1/dijkstra.1.gz
|
||||
share/man/man1/dot.1.gz
|
||||
share/man/man1/dot2gxl.1.gz
|
||||
share/man/man1/dot_sandbox.1.gz
|
||||
share/man/man1/edgepaint.1.gz
|
||||
share/man/man1/fdp.1.gz
|
||||
share/man/man1/gc.1.gz
|
||||
|
|
Loading…
Add table
Reference in a new issue