mirror of
https://git.freebsd.org/ports.git
synced 2025-05-04 23:47:37 -04:00
www/nghttp2: Attempt to fix build on 13.2 and 14.0
Attempt to fix build failure introduced in 1.62.0 PR: 278965 Approved by: portmgr (blanket, build fix)
This commit is contained in:
parent
b9a2ee3c9d
commit
143fa66a1a
2 changed files with 22 additions and 0 deletions
|
@ -43,6 +43,17 @@ HPACK_BUILD_DEPENDS= jansson>=2.5:devel/jansson
|
||||||
HPACK_CMAKE_BOOL= ENABLE_HPACK_TOOLS
|
HPACK_CMAKE_BOOL= ENABLE_HPACK_TOOLS
|
||||||
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
|
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
|
||||||
|
|
||||||
|
.include <bsd.port.options.mk>
|
||||||
|
|
||||||
|
.if ${OPSYS}_${OSREL:C/\\./-/} == FreeBSD_13-2
|
||||||
|
USES+= llvm
|
||||||
|
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-compatibility-fix
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.if ${OPSYS}_${OSREL:C/\\./-/} == FreeBSD_14-0
|
||||||
|
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-compatibility-fix
|
||||||
|
.endif
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${MKDIR} ${STAGEDIR}${PREFIX}/etc/nghttpx/
|
${MKDIR} ${STAGEDIR}${PREFIX}/etc/nghttpx/
|
||||||
${INSTALL_DATA} ${FILESDIR}/nghttpx.conf.sample ${STAGEDIR}${PREFIX}/etc/nghttpx/nghttpx.conf.sample
|
${INSTALL_DATA} ${FILESDIR}/nghttpx.conf.sample ${STAGEDIR}${PREFIX}/etc/nghttpx/nghttpx.conf.sample
|
||||||
|
|
11
www/nghttp2/files/extra-patch-compatibility-fix
Normal file
11
www/nghttp2/files/extra-patch-compatibility-fix
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- src/template.h.orig 2024-06-08 10:06:50 UTC
|
||||||
|
+++ src/template.h
|
||||||
|
@@ -444,7 +444,7 @@ inline constexpr bool operator==(const StringRef &lhs,
|
||||||
|
std::equal(std::begin(lhs), std::end(lhs), std::begin(rhs));
|
||||||
|
}
|
||||||
|
|
||||||
|
-#ifndef __APPLE__
|
||||||
|
+#ifndef __FreeBSD__
|
||||||
|
inline constexpr std::strong_ordering
|
||||||
|
operator<=>(const StringRef &lhs, const StringRef &rhs) noexcept {
|
||||||
|
return std::lexicographical_compare_three_way(std::begin(lhs), std::end(lhs),
|
Loading…
Add table
Reference in a new issue