mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
audio/soundtouch: Update to 2.3.3
Changelog: https://codeberg.org/soundtouch/soundtouch/compare/2.3.1...2.3.3 PR: 278568 Reported by: kunda <luzpaz@pm.me>, Andrey Korobkov <alster@vinterdalen.se> Reviewed by: crees (maintainer)
This commit is contained in:
parent
d912af90ef
commit
13602717d0
4 changed files with 16 additions and 51 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= soundtouch
|
||||
DISTVERSION= 2.3.1
|
||||
DISTVERSION= 2.3.3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= https://www.surina.net/${PORTNAME}/
|
||||
|
||||
|
@ -10,11 +10,11 @@ WWW= https://www.surina.net/soundtouch/
|
|||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.TXT
|
||||
|
||||
USES= cmake cpe
|
||||
USES= cmake compiler:c++17-lang cpe pathfix
|
||||
CPE_VENDOR= surina
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CPE_VENDOR= surina
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
CFLAGS_i386= -DSOUNDTOUCH_DISABLE_X86_OPTIMIZATIONS
|
||||
|
||||
CMAKE_ON= BUILD_SHARED_LIBS
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1634244025
|
||||
SHA256 (soundtouch-2.3.1.tar.gz) = 6900996607258496ce126924a19fe9d598af9d892cf3f33d1e4daaa9b42ae0b1
|
||||
SIZE (soundtouch-2.3.1.tar.gz) = 524664
|
||||
TIMESTAMP = 1712001624
|
||||
SHA256 (soundtouch-2.3.3.tar.gz) = 43b23dfac2f64a3aff55d64be096ffc7b73842c3f5665caff44975633a975a99
|
||||
SIZE (soundtouch-2.3.3.tar.gz) = 606780
|
||||
|
|
|
@ -1,46 +1,11 @@
|
|||
--- CMakeLists.txt.orig 2021-09-07 15:26:53 UTC
|
||||
--- CMakeLists.txt.orig 2024-04-01 20:14:00 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -6,8 +6,6 @@ include(GNUInstallDirs)
|
||||
if(MSVC)
|
||||
set(COMPILE_DEFINITIONS /O2 /fp:fast)
|
||||
set(COMPILE_OPTIONS )
|
||||
-else()
|
||||
- set(COMPILE_OPTIONS -Ofast)
|
||||
@@ -13,7 +13,7 @@ else()
|
||||
if(EMSCRIPTEN)
|
||||
list(APPEND COMPILE_OPTIONS -O3)
|
||||
else()
|
||||
- list(APPEND COMPILE_OPTIONS -Ofast)
|
||||
+# list(APPEND COMPILE_OPTIONS -Ofast)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
#####################
|
||||
@@ -59,7 +57,7 @@ else()
|
||||
target_compile_definitions(SoundTouch PRIVATE SOUNDTOUCH_FLOAT_SAMPLES)
|
||||
endif()
|
||||
|
||||
-if(CMAKE_SYSTEM_PROCESSOR MATCHES "^(armv7.*|armv8.*)$")
|
||||
+if(CMAKE_SYSTEM_PROCESSOR MATCHES "^(armv7.*|armv8.*|aarch64.*)$")
|
||||
set(NEON_CPU ON)
|
||||
else()
|
||||
set(NEON_CPU OFF)
|
||||
@@ -68,9 +66,14 @@ endif()
|
||||
option(NEON "Use ARM Neon SIMD instructions if in ARM CPU" ON)
|
||||
if(${NEON} AND ${NEON_CPU})
|
||||
target_compile_definitions(SoundTouch PRIVATE SOUNDTOUCH_USE_NEON)
|
||||
- target_compile_options(SoundTouch PRIVATE -mfpu=neon)
|
||||
endif()
|
||||
|
||||
+find_package(OpenMP)
|
||||
+option(OPENMP "Use parallel multicore calculation through OpenMP" ON)
|
||||
+if(OPENMP AND OPENMP_FOUND)
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
|
||||
+endif()
|
||||
+
|
||||
install(
|
||||
FILES
|
||||
include/BPMDetect.h
|
||||
@@ -105,6 +108,9 @@ if(SOUNDSTRETCH)
|
||||
target_compile_definitions(soundstretch PRIVATE ${COMPILE_DEFINITIONS})
|
||||
target_compile_options(soundstretch PRIVATE ${COMPILE_OPTIONS})
|
||||
target_link_libraries(soundstretch PRIVATE SoundTouch)
|
||||
+ if(INTEGER_SAMPLES)
|
||||
+ target_compile_definitions(soundstretch PRIVATE SOUNDTOUCH_INTEGER_SAMPLES)
|
||||
+ endif()
|
||||
|
||||
install(TARGETS soundstretch
|
||||
DESTINATION bin
|
||||
|
|
|
@ -11,5 +11,5 @@ lib/cmake/SoundTouch/SoundTouchTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
|||
lib/cmake/SoundTouch/SoundTouchTargets.cmake
|
||||
lib/libSoundTouch.so
|
||||
lib/libSoundTouch.so.2
|
||||
lib/libSoundTouch.so.2.3.1
|
||||
lib/libSoundTouch.so.2.3.3
|
||||
libdata/pkgconfig/soundtouch.pc
|
||||
|
|
Loading…
Add table
Reference in a new issue