mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
lang/python37: remove expired port
Manual commit as the previous commit broke some Makefile logic.
This commit is contained in:
parent
53475f525a
commit
12f5a11b04
18 changed files with 1 additions and 7651 deletions
1
MOVED
1
MOVED
|
@ -7657,3 +7657,4 @@ security/p5-OpenCA-PKCS7||2023-06-23|Has expired: Depends on expired security/p5
|
|||
security/p5-OpenCA-OpenSSL||2023-06-23|Has expired: Broken since 2021
|
||||
security/krb5-118|security/krb5|2023-06-25|Has expired: EOL one year after the release of krb5 1.19
|
||||
x11-wm/pager|x11-wm/sawfish-pager|2023-06-27|Renamed to match upstream naming
|
||||
lang/python37|lang/python38|2023-06-27|Has expired: Upgrade to a newer Python version. 3.7 is in maintenance status and gets security fixes only. End-of-Life: 2023-06-27. See https://devguide.python.org/versions/
|
||||
|
|
|
@ -298,7 +298,6 @@
|
|||
SUBDIR += python3
|
||||
SUBDIR += python310
|
||||
SUBDIR += python311
|
||||
SUBDIR += python37
|
||||
SUBDIR += python38
|
||||
SUBDIR += python39
|
||||
SUBDIR += qmasm
|
||||
|
|
|
@ -1,151 +0,0 @@
|
|||
PORTNAME= python
|
||||
DISTVERSION= ${PYTHON_DISTVERSION}
|
||||
CATEGORIES= lang python
|
||||
MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
|
||||
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
|
||||
DISTNAME= Python-${DISTVERSION}
|
||||
DIST_SUBDIR= python
|
||||
|
||||
MAINTAINER= python@FreeBSD.org
|
||||
COMMENT= Interpreted object-oriented programming language
|
||||
WWW= https://www.python.org/
|
||||
|
||||
LICENSE= PSFL
|
||||
|
||||
DEPRECATED= Upgrade to a newer Python version. 3.7 is in maintenance status and gets security fixes only. End-of-Life: 2023-06-27. See https://devguide.python.org/versions/
|
||||
EXPIRATION_DATE= 2023-06-27
|
||||
|
||||
LIB_DEPENDS= libffi.so:devel/libffi \
|
||||
libmpdec.so:math/mpdecimal
|
||||
|
||||
USES= cpe ncurses pathfix pkgconfig python:${PYTHON_DISTVERSION:R},env readline \
|
||||
shebangfix ssl tar:xz
|
||||
PATHFIX_MAKEFILEIN= Makefile.pre.in
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
python_CMD= ${PREFIX}/bin/python${PYTHON_DISTVERSION:R}
|
||||
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
|
||||
|
||||
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
|
||||
CONFIGURE_ARGS+= --enable-shared --with-system-ffi --with-system-libmpdec --without-ensurepip
|
||||
CONFIGURE_ENV+= OPT="" # Null out OPT to respect user CFLAGS and remove optimizations
|
||||
|
||||
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
|
||||
|
||||
TEST_TARGET= buildbottest
|
||||
TEST_ARGS= TESTOPTS=-j${MAKE_JOBS_NUMBER}
|
||||
|
||||
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
|
||||
|
||||
PLIST_SUB= ABI=${ABIFLAGS} \
|
||||
XY=${PYTHON_SUFFIX} \
|
||||
XYDOT=${PYTHON_VER} \
|
||||
XYZDOT=${DISTVERSION} \
|
||||
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
|
||||
|
||||
OPTIONS_DEFINE= DEBUG IPV6 LTO NLS PYMALLOC
|
||||
OPTIONS_DEFAULT= PYMALLOC
|
||||
OPTIONS_EXCLUDE_riscv64= LTO
|
||||
OPTIONS_RADIO= HASH
|
||||
OPTIONS_RADIO_HASH= FNV SIPHASH
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
NLS_DESC= Enable gettext support for the locale module
|
||||
PYMALLOC_DESC= Enable specialized mallocs
|
||||
|
||||
HASH_DESC= Hash Algorithm (PEP-456)
|
||||
FNV_DESC= Modified Fowler-Noll-Vo Algorithm
|
||||
SIPHASH_DESC= SipHash24 Algorithm
|
||||
|
||||
FNV_CONFIGURE_ON= --with-hash-algorithm=fnv
|
||||
SIPHASH_CONFIGURE_ON= --with-hash-algorithm=siphash24
|
||||
|
||||
DEBUG_CONFIGURE_WITH= pydebug
|
||||
IPV6_CONFIGURE_ENABLE= ipv6
|
||||
|
||||
LTO_CONFIGURE_ON= --with-lto
|
||||
|
||||
# Use CPPFLAGS over CFLAGS due to -I ordering, causing elementtree and pyexpat
|
||||
# to break in Python 2.7, or preprocessor complaints in Python >= 3.3
|
||||
# Upstream Issue: https://bugs.python.org/issue6299
|
||||
NLS_USES= gettext
|
||||
NLS_CPPFLAGS= -I${LOCALBASE}/include
|
||||
NLS_LIBS= -L${LOCALBASE}/lib -lintl
|
||||
NLS_CONFIGURE_ENV_OFF= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
|
||||
|
||||
PYMALLOC_CONFIGURE_WITH= pymalloc
|
||||
|
||||
.include "${.CURDIR}/Makefile.version"
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MPYMALLOC}
|
||||
ABIFLAGS:= m${ABIFLAGS}
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDEBUG}
|
||||
ABIFLAGS:= d${ABIFLAGS}
|
||||
.endif
|
||||
|
||||
.if !empty(ABIFLAGS)
|
||||
PLIST_FILES+= bin/python${PYTHON_VER}${ABIFLAGS} \
|
||||
bin/python${PYTHON_VER}${ABIFLAGS}-config \
|
||||
libdata/pkgconfig/python-${PYTHON_VER}${ABIFLAGS}.pc
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == sparc64
|
||||
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
|
||||
.endif
|
||||
|
||||
# See https://bugs.freebsd.org/115940 and https://bugs.freebsd.org/193650
|
||||
.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
|
||||
PLIST_SUB+= NO_NIS="@comment "
|
||||
DISABLED_EXTENSIONS+= nis
|
||||
.else
|
||||
PLIST_SUB+= NO_NIS=""
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
# disable the detection of includes and library from e2fsprogs-libuuid,
|
||||
# which introduces hidden dependency and breaks build
|
||||
@${REINPLACE_CMD} -e 's|uuid/uuid.h|ignore_&|' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e '/find_library_file/ s|uuid|ignore_&|' ${WRKSRC}/setup.py
|
||||
# disable detection of multiarch as it breaks with clang >= 13, which adds a
|
||||
# major.minor version number in -print-multiarch output, confusing Python
|
||||
@${REINPLACE_CMD} -e 's|^\( *MULTIARCH=\).*--print-multiarch.*|\1|' ${WRKSRC}/configure
|
||||
# Apply DISABLED_EXTENSIONS
|
||||
@${ECHO_CMD} '*disabled*' > ${WRKSRC}/Modules/Setup.local
|
||||
. for _module in ${DISABLED_EXTENSIONS}
|
||||
@${ECHO_CMD} ${_module} >> ${WRKSRC}/Modules/Setup.local
|
||||
. endfor
|
||||
|
||||
post-install:
|
||||
.if ! ${PORT_OPTIONS:MDEBUG}
|
||||
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: https://bugs.python.org/issue17975
|
||||
.endif
|
||||
${LN} -sf libpython${PYTHON_VER}${ABIFLAGS}.so.1.0 ${STAGEDIR}${PREFIX}/lib/libpython${PYTHON_VER}${ABIFLAGS}.so.1
|
||||
# This code block exists for the qemu-user enabled cross build environment.
|
||||
# When using this environment in poudriere, CC is not set to the default
|
||||
# of /usr/bin/cc and a cross-compile toolchain is used. We need to hand
|
||||
# edit this so that the run time configuration for python matches what the
|
||||
# FreeBSD base system provides. sbruno 02Aug2017
|
||||
.if ${CC} == /nxb-bin/usr/bin/cc
|
||||
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
|
||||
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
|
||||
@cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
|
||||
./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
|
||||
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
|
||||
@cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
|
||||
./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
|
||||
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
|
||||
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
|
||||
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}${ABIFLAGS}/Makefile
|
||||
.endif
|
||||
for i in ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/lib-dynload/*.so; do \
|
||||
${STRIP_CMD} $$i; done # Strip shared extensions
|
||||
${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
|
||||
${STAGEDIR}${PREFIX}/lib/libpython${PYTHON_VER}${ABIFLAGS}.so.1.0-gdb.py
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,7 +0,0 @@
|
|||
# Mk/Uses/python.mk includes this file, don't remove it!
|
||||
|
||||
# Do not forget to
|
||||
# 1. Update python documentation (lang/python-doc-*)
|
||||
# Run "make -C lang/python-doc-html makesum"
|
||||
# 2. Remove PORTREVISION in Makefile
|
||||
PYTHON_DISTVERSION= 3.7.17
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1686177820
|
||||
SHA256 (python/Python-3.7.17.tar.xz) = 7911051ed0422fd54b8f59ffc030f7cf2ae30e0f61bda191800bb040dce4f9d2
|
||||
SIZE (python/Python-3.7.17.tar.xz) = 18066196
|
|
@ -1,41 +0,0 @@
|
|||
From 9934ce31b8447667f71c211e559a8de71e8263db Mon Sep 17 00:00:00 2001
|
||||
From: Brendan Molloy <brendan@bbqsrc.net>
|
||||
Date: Mon, 4 Jan 2016 23:14:06 +1100
|
||||
Subject: [PATCH] Check bytecode file actually exists and tests
|
||||
|
||||
Should solve issue 20397, where using the --record argument results
|
||||
in files that failed to generate bytecode files are added to the
|
||||
record file nonetheless.
|
||||
---
|
||||
Lib/distutils/command/install_lib.py | 17 +++++++++++++----
|
||||
Lib/distutils/tests/test_install_lib.py | 8 ++++++--
|
||||
2 files changed, 19 insertions(+), 6 deletions(-)
|
||||
|
||||
--- Lib/distutils/command/install_lib.py.orig 2015-12-07 01:39:07 UTC
|
||||
+++ Lib/distutils/command/install_lib.py
|
||||
@@ -164,12 +164,21 @@ class install_lib(Command):
|
||||
ext = os.path.splitext(os.path.normcase(py_file))[1]
|
||||
if ext != PYTHON_SOURCE_EXTENSION:
|
||||
continue
|
||||
+
|
||||
if self.compile:
|
||||
- bytecode_files.append(importlib.util.cache_from_source(
|
||||
- py_file, optimization=''))
|
||||
+ candidate = importlib.util.cache_from_source(
|
||||
+ py_file, optimization='')
|
||||
+
|
||||
+ if os.path.isfile(candidate):
|
||||
+ bytecode_files.append(candidate)
|
||||
+
|
||||
if self.optimize > 0:
|
||||
- bytecode_files.append(importlib.util.cache_from_source(
|
||||
- py_file, optimization=self.optimize))
|
||||
+ candidate = importlib.util.cache_from_source(
|
||||
+ py_file, optimization=self.optimize)
|
||||
+
|
||||
+ if os.path.isfile(candidate):
|
||||
+ bytecode_files.append(candidate)
|
||||
+
|
||||
|
||||
return bytecode_files
|
||||
|
|
@ -1,33 +0,0 @@
|
|||
From 9934ce31b8447667f71c211e559a8de71e8263db Mon Sep 17 00:00:00 2001
|
||||
From: Brendan Molloy <brendan@bbqsrc.net>
|
||||
Date: Mon, 4 Jan 2016 23:14:06 +1100
|
||||
Subject: [PATCH] Check bytecode file actually exists and tests
|
||||
|
||||
Should solve issue 20397, where using the --record argument results
|
||||
in files that failed to generate bytecode files are added to the
|
||||
record file nonetheless.
|
||||
---
|
||||
Lib/distutils/command/install_lib.py | 17 +++++++++++++----
|
||||
Lib/distutils/tests/test_install_lib.py | 8 ++++++--
|
||||
2 files changed, 19 insertions(+), 6 deletions(-)
|
||||
|
||||
--- Lib/distutils/tests/test_install_lib.py.orig 2015-12-07 01:39:07 UTC
|
||||
+++ Lib/distutils/tests/test_install_lib.py
|
||||
@@ -64,11 +64,15 @@ class InstallLibTestCase(support.Tempdir
|
||||
cmd.distribution.ext_modules = [Extension('foo', ['xxx'])]
|
||||
cmd.distribution.packages = ['spam']
|
||||
cmd.distribution.script_name = 'setup.py'
|
||||
+
|
||||
+ # Create rubbish, uncompilable file
|
||||
+ f = os.path.join(project_dir, 'spam', 'rubbish.py')
|
||||
+ self.write_file(f, 'rubbish()')
|
||||
|
||||
# get_outputs should return 4 elements: spam/__init__.py and .pyc,
|
||||
- # foo.import-tag-abiflags.so / foo.pyd
|
||||
+ # foo.import-tag-abiflags.so / foo.pyd and rubbish.py (no .pyc)
|
||||
outputs = cmd.get_outputs()
|
||||
- self.assertEqual(len(outputs), 4, outputs)
|
||||
+ self.assertEqual(len(outputs), 5, outputs)
|
||||
|
||||
def test_get_inputs(self):
|
||||
project_dir, dist = self.create_dist()
|
|
@ -1,65 +0,0 @@
|
|||
# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
|
||||
# Submitted by: koobs (r326729)
|
||||
# TODO: Upstream
|
||||
|
||||
# Description: Create symlinks for non-ABI-suffixed python*-config and ABI-suffixed python-*.pc
|
||||
# Submitted by: antoine@ (r358029)
|
||||
# TODO: Upstream
|
||||
--- Makefile.pre.in.orig 2018-12-25 13:00:52 UTC
|
||||
+++ Makefile.pre.in
|
||||
@@ -80,7 +80,6 @@ MAKESETUP= $(srcdir)/Modules/makesetup
|
||||
OPT= @OPT@
|
||||
BASECFLAGS= @BASECFLAGS@
|
||||
BASECPPFLAGS= @BASECPPFLAGS@
|
||||
-CONFIGURE_CFLAGS= @CFLAGS@
|
||||
# CFLAGS_NODIST is used for building the interpreter and stdlib C extensions.
|
||||
# Use it when a compiler flag should _not_ be part of the distutils CFLAGS
|
||||
# once Python is installed (Issue #21121).
|
||||
@@ -89,18 +88,16 @@ CONFIGURE_CFLAGS_NODIST=@CFLAGS_NODIST@
|
||||
# Use it when a linker flag should _not_ be part of the distutils LDFLAGS
|
||||
# once Python is installed (bpo-35257)
|
||||
CONFIGURE_LDFLAGS_NODIST=@LDFLAGS_NODIST@
|
||||
-CONFIGURE_CPPFLAGS= @CPPFLAGS@
|
||||
-CONFIGURE_LDFLAGS= @LDFLAGS@
|
||||
# Avoid assigning CFLAGS, LDFLAGS, etc. so users can use them on the
|
||||
# command line to append to these values without stomping the pre-set
|
||||
# values.
|
||||
-PY_CFLAGS= $(BASECFLAGS) $(OPT) $(CONFIGURE_CFLAGS) $(CFLAGS) $(EXTRA_CFLAGS)
|
||||
+PY_CFLAGS= $(BASECFLAGS) $(OPT) $(CFLAGS) $(EXTRA_CFLAGS)
|
||||
PY_CFLAGS_NODIST=$(CONFIGURE_CFLAGS_NODIST) $(CFLAGS_NODIST)
|
||||
# Both CPPFLAGS and LDFLAGS need to contain the shell's value for setup.py to
|
||||
# be able to build extension modules using the directories specified in the
|
||||
# environment variables
|
||||
-PY_CPPFLAGS= $(BASECPPFLAGS) -I. -I$(srcdir)/Include $(CONFIGURE_CPPFLAGS) $(CPPFLAGS)
|
||||
-PY_LDFLAGS= $(CONFIGURE_LDFLAGS) $(LDFLAGS)
|
||||
+PY_CPPFLAGS= $(BASECPPFLAGS) -I. -I$(srcdir)/Include $(CPPFLAGS)
|
||||
+PY_LDFLAGS= $(LDFLAGS)
|
||||
PY_LDFLAGS_NODIST=$(CONFIGURE_LDFLAGS_NODIST) $(LDFLAGS_NODIST)
|
||||
NO_AS_NEEDED= @NO_AS_NEEDED@
|
||||
LDLAST= @LDLAST@
|
||||
@@ -1213,12 +1210,6 @@ bininstall: altbininstall
|
||||
else true; \
|
||||
fi
|
||||
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python3$(EXE))
|
||||
- -if test "$(VERSION)" != "$(LDVERSION)"; then \
|
||||
- rm -f $(DESTDIR)$(BINDIR)/python$(VERSION)-config; \
|
||||
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(LDVERSION)-config python$(VERSION)-config); \
|
||||
- rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION).pc; \
|
||||
- (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python-$(LDVERSION).pc); \
|
||||
- fi
|
||||
-rm -f $(DESTDIR)$(BINDIR)/python3-config
|
||||
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python3-config)
|
||||
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
|
||||
@@ -1505,6 +1496,12 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
|
||||
$(INSTALL_SCRIPT) python-config.py $(DESTDIR)$(LIBPL)/python-config.py
|
||||
$(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(LDVERSION)-config
|
||||
+ -if test "$(VERSION)" != "$(LDVERSION)"; then \
|
||||
+ rm -f $(DESTDIR)$(BINDIR)/python$(VERSION)-config; \
|
||||
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(LDVERSION)-config python$(VERSION)-config); \
|
||||
+ rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION).pc; \
|
||||
+ (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python-$(LDVERSION).pc); \
|
||||
+ fi
|
||||
@if [ -s Modules/python.exp -a \
|
||||
"`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
|
||||
echo; echo "Installing support files for building shared extension modules on AIX:"; \
|
|
@ -1,11 +0,0 @@
|
|||
--- Misc/python-config.sh.in.orig 2018-07-13 21:07:16 UTC
|
||||
+++ Misc/python-config.sh.in
|
||||
@@ -15,7 +15,7 @@ fi
|
||||
# Returns the actual prefix where this script was installed to.
|
||||
installed_prefix ()
|
||||
{
|
||||
- RESULT=$(dirname $(cd $(dirname "$1") && pwd -P))
|
||||
+ RESULT=$(dirname $(cd $(dirname $(realpath "$1")) && pwd -P))
|
||||
if which readlink >/dev/null 2>&1 ; then
|
||||
if readlink -f "$RESULT" >/dev/null 2>&1; then
|
||||
RESULT=$(readlink -f "$RESULT")
|
|
@ -1,32 +0,0 @@
|
|||
--- Modules/_decimal/_decimal.c.orig 2021-02-17 21:21:24 UTC
|
||||
+++ Modules/_decimal/_decimal.c
|
||||
@@ -58,6 +58,11 @@
|
||||
|
||||
#define BOUNDS_CHECK(x, MIN, MAX) x = (x < MIN || MAX < x) ? MAX : x
|
||||
|
||||
+#if defined(__GNUC__) && !defined(__INTEL_COMPILER)
|
||||
+ #define UNUSED __attribute__((unused))
|
||||
+#else
|
||||
+ #define UNUSED
|
||||
+#endif
|
||||
|
||||
/* _Py_DEC_MINALLOC >= MPD_MINALLOC */
|
||||
#define _Py_DEC_MINALLOC 4
|
||||
@@ -3277,7 +3282,7 @@ dec_format(PyObject *dec, PyObject *args)
|
||||
}
|
||||
else {
|
||||
size_t n = strlen(spec.dot);
|
||||
- if (n > 1 || (n == 1 && !isascii((uchar)spec.dot[0]))) {
|
||||
+ if (n > 1 || (n == 1 && !isascii((unsigned char)spec.dot[0]))) {
|
||||
/* fix locale dependent non-ascii characters */
|
||||
dot = dotsep_as_utf8(spec.dot);
|
||||
if (dot == NULL) {
|
||||
@@ -3286,7 +3291,7 @@ dec_format(PyObject *dec, PyObject *args)
|
||||
spec.dot = PyBytes_AS_STRING(dot);
|
||||
}
|
||||
n = strlen(spec.sep);
|
||||
- if (n > 1 || (n == 1 && !isascii((uchar)spec.sep[0]))) {
|
||||
+ if (n > 1 || (n == 1 && !isascii((unsigned char)spec.sep[0]))) {
|
||||
/* fix locale dependent non-ascii characters */
|
||||
sep = dotsep_as_utf8(spec.sep);
|
||||
if (sep == NULL) {
|
|
@ -1,29 +0,0 @@
|
|||
--- Modules/socketmodule.c
|
||||
+++ Modules/socketmodule.c
|
||||
@@ -1850,6 +1850,11 @@ getsockaddrarg(PySocketSockObject *s, PyObject *args,
|
||||
/* RDS sockets use sockaddr_in: fall-through */
|
||||
#endif /* AF_RDS */
|
||||
|
||||
+#ifdef AF_DIVERT
|
||||
+ case AF_DIVERT:
|
||||
+ /* FreeBSD divert(4) sockets use sockaddr_in: fall-through */
|
||||
+#endif /* AF_DIVERT */
|
||||
+
|
||||
case AF_INET:
|
||||
{
|
||||
struct maybe_idna host = {NULL, NULL};
|
||||
@@ -7628,6 +7633,14 @@ PyInit__socket(void)
|
||||
PyModule_AddIntMacro(m, AF_SYSTEM);
|
||||
#endif
|
||||
|
||||
+/* FreeBSD divert(4) */
|
||||
+#ifdef PF_DIVERT
|
||||
+ PyModule_AddIntMacro(m, PF_DIVERT);
|
||||
+#endif
|
||||
+#ifdef AF_DIVERT
|
||||
+ PyModule_AddIntMacro(m, AF_DIVERT);
|
||||
+#endif
|
||||
+
|
||||
#ifdef AF_PACKET
|
||||
PyModule_AddIntMacro(m, AF_PACKET);
|
||||
#endif
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.orig 2022-02-23 19:52:00 UTC
|
||||
+++ configure
|
||||
@@ -6625,7 +6625,7 @@ fi
|
||||
|
||||
if test "$Py_LTO" = 'true' ; then
|
||||
case $CC in
|
||||
- *clang*)
|
||||
+ *clang*|cc)
|
||||
|
||||
if test -n "$ac_tool_prefix"; then
|
||||
# Extract the first word of "${ac_tool_prefix}llvm-ar", so it can be a program name with args.
|
|
@ -1,207 +0,0 @@
|
|||
diff --git a/Modules/_posixsubprocess.c b/Modules/_posixsubprocess.c
|
||||
index 3cf0683ad9..fb070e4cc4 100644
|
||||
--- Modules/_posixsubprocess.c
|
||||
+++ Modules/_posixsubprocess.c
|
||||
@@ -21,6 +21,8 @@
|
||||
#include <dirent.h>
|
||||
#endif
|
||||
|
||||
+#include "posixmodule.h"
|
||||
+
|
||||
#ifdef _Py_MEMORY_SANITIZER
|
||||
# include <sanitizer/msan_interface.h>
|
||||
#endif
|
||||
@@ -222,7 +222,6 @@ _close_fds_by_brute_force(long start_fd, PyObject *py_fds_to_keep)
|
||||
long end_fd = safe_get_max_fd();
|
||||
Py_ssize_t num_fds_to_keep = PyTuple_GET_SIZE(py_fds_to_keep);
|
||||
Py_ssize_t keep_seq_idx;
|
||||
- int fd_num;
|
||||
/* As py_fds_to_keep is sorted we can loop through the list closing
|
||||
* fds in between any in the keep list falling within our range. */
|
||||
for (keep_seq_idx = 0; keep_seq_idx < num_fds_to_keep; ++keep_seq_idx) {
|
||||
@@ -230,15 +229,11 @@ _close_fds_by_brute_force(long start_fd, PyObject *py_fds_to_keep)
|
||||
int keep_fd = PyLong_AsLong(py_keep_fd);
|
||||
if (keep_fd < start_fd)
|
||||
continue;
|
||||
- for (fd_num = start_fd; fd_num < keep_fd; ++fd_num) {
|
||||
- close(fd_num);
|
||||
- }
|
||||
+ _Py_closerange(start_fd, keep_fd - 1);
|
||||
start_fd = keep_fd + 1;
|
||||
}
|
||||
if (start_fd <= end_fd) {
|
||||
- for (fd_num = start_fd; fd_num < end_fd; ++fd_num) {
|
||||
- close(fd_num);
|
||||
- }
|
||||
+ _Py_closerange(start_fd, end_fd);
|
||||
}
|
||||
}
|
||||
|
||||
diff --git a/Modules/posixmodule.c b/Modules/posixmodule.c
|
||||
index 43d4302b92..7878517353 100644
|
||||
--- Modules/posixmodule.c
|
||||
+++ Modules/posixmodule.c
|
||||
@@ -7820,6 +7820,78 @@ os_close_impl(PyObject *module, int fd)
|
||||
Py_RETURN_NONE;
|
||||
}
|
||||
|
||||
+/* Our selection logic for which function to use is as follows:
|
||||
+ * 1. If close_range(2) is available, always prefer that; it's better for
|
||||
+ * contiguous ranges like this than fdwalk(3) which entails iterating over
|
||||
+ * the entire fd space and simply doing nothing for those outside the range.
|
||||
+ * 2. If closefrom(2) is available, we'll attempt to use that next if we're
|
||||
+ * closing up to sysconf(_SC_OPEN_MAX).
|
||||
+ * 2a. Fallback to fdwalk(3) if we're not closing up to sysconf(_SC_OPEN_MAX),
|
||||
+ * as that will be more performant if the range happens to have any chunk of
|
||||
+ * non-opened fd in the middle.
|
||||
+ * 2b. If fdwalk(3) isn't available, just do a plain close(2) loop.
|
||||
+ */
|
||||
+#ifdef __FreeBSD__
|
||||
+#define USE_CLOSEFROM
|
||||
+#endif /* __FreeBSD__ */
|
||||
+
|
||||
+#ifdef HAVE_FDWALK
|
||||
+#define USE_FDWALK
|
||||
+#endif /* HAVE_FDWALK */
|
||||
+
|
||||
+#ifdef USE_FDWALK
|
||||
+static int
|
||||
+_fdwalk_close_func(void *lohi, int fd)
|
||||
+{
|
||||
+ int lo = ((int *)lohi)[0];
|
||||
+ int hi = ((int *)lohi)[1];
|
||||
+
|
||||
+ if (fd >= hi)
|
||||
+ return 1;
|
||||
+ else if (fd >= lo)
|
||||
+ close(fd);
|
||||
+ return 0;
|
||||
+}
|
||||
+#endif /* USE_FDWALK */
|
||||
+
|
||||
+/* Closes all file descriptors in [first, last], ignoring errors. */
|
||||
+void
|
||||
+_Py_closerange(int first, int last)
|
||||
+{
|
||||
+ first = Py_MAX(first, 0);
|
||||
+ _Py_BEGIN_SUPPRESS_IPH
|
||||
+#ifdef HAVE_CLOSE_RANGE
|
||||
+ if (close_range(first, last, 0) == 0 || errno != ENOSYS) {
|
||||
+ /* Any errors encountered while closing file descriptors are ignored;
|
||||
+ * ENOSYS means no kernel support, though,
|
||||
+ * so we'll fallback to the other methods. */
|
||||
+ }
|
||||
+ else
|
||||
+#endif /* HAVE_CLOSE_RANGE */
|
||||
+#ifdef USE_CLOSEFROM
|
||||
+ if (last >= sysconf(_SC_OPEN_MAX)) {
|
||||
+ /* Any errors encountered while closing file descriptors are ignored */
|
||||
+ closefrom(first);
|
||||
+ }
|
||||
+ else
|
||||
+#endif /* USE_CLOSEFROM */
|
||||
+#ifdef USE_FDWALK
|
||||
+ {
|
||||
+ int lohi[2];
|
||||
+ lohi[0] = first;
|
||||
+ lohi[1] = last + 1;
|
||||
+ fdwalk(_fdwalk_close_func, lohi);
|
||||
+ }
|
||||
+#else
|
||||
+ {
|
||||
+ for (int i = first; i <= last; i++) {
|
||||
+ /* Ignore errors */
|
||||
+ (void)close(i);
|
||||
+ }
|
||||
+ }
|
||||
+#endif /* USE_FDWALK */
|
||||
+ _Py_END_SUPPRESS_IPH
|
||||
+}
|
||||
|
||||
/*[clinic input]
|
||||
os.closerange
|
||||
@@ -7835,12 +7907,8 @@ static PyObject *
|
||||
os_closerange_impl(PyObject *module, int fd_low, int fd_high)
|
||||
/*[clinic end generated code: output=0ce5c20fcda681c2 input=5855a3d053ebd4ec]*/
|
||||
{
|
||||
- int i;
|
||||
Py_BEGIN_ALLOW_THREADS
|
||||
- _Py_BEGIN_SUPPRESS_IPH
|
||||
- for (i = Py_MAX(fd_low, 0); i < fd_high; i++)
|
||||
- close(i);
|
||||
- _Py_END_SUPPRESS_IPH
|
||||
+ _Py_closerange(fd_low, fd_high - 1);
|
||||
Py_END_ALLOW_THREADS
|
||||
Py_RETURN_NONE;
|
||||
}
|
||||
diff --git a/Modules/posixmodule.h b/Modules/posixmodule.h
|
||||
index 1ec1833825..be2308ea86 100644
|
||||
--- Modules/posixmodule.h
|
||||
+++ Modules/posixmodule.h
|
||||
@@ -19,6 +19,8 @@ PyAPI_FUNC(int) _Py_Gid_Converter(PyObject *, void *);
|
||||
#endif /* MS_WINDOWS */
|
||||
#endif
|
||||
|
||||
+PyAPI_FUNC(void) _Py_closerange(int first, int last);
|
||||
+
|
||||
#ifdef __cplusplus
|
||||
}
|
||||
#endif
|
||||
diff --git a/configure b/configure
|
||||
index 829dd69bb8..2eeadec5f0 100755
|
||||
--- configure
|
||||
+++ configure
|
||||
@@ -11490,9 +11490,9 @@ fi
|
||||
|
||||
# checks for library functions
|
||||
for ac_func in alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
|
||||
- clock confstr ctermid dup3 execv faccessat fchmod fchmodat fchown fchownat \
|
||||
- fexecve fdopendir fork fpathconf fstatat ftime ftruncate futimesat \
|
||||
- futimens futimes gai_strerror getentropy \
|
||||
+ clock close_range confstr ctermid dup3 execv faccessat fchmod fchmodat fchown \
|
||||
+ fchownat fdwalk fexecve fdopendir fork fpathconf fstatat ftime ftruncate \
|
||||
+ futimesat futimens futimes gai_strerror getentropy \
|
||||
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
|
||||
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
|
||||
if_nameindex \
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f1cc8e9bcb..80952290b7 100644
|
||||
--- configure.ac
|
||||
+++ configure.ac
|
||||
@@ -3574,9 +3574,9 @@ fi
|
||||
|
||||
# checks for library functions
|
||||
AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
|
||||
- clock confstr ctermid dup3 execv faccessat fchmod fchmodat fchown fchownat \
|
||||
- fexecve fdopendir fork fpathconf fstatat ftime ftruncate futimesat \
|
||||
- futimens futimes gai_strerror getentropy \
|
||||
+ clock close_range confstr ctermid dup3 execv faccessat fchmod fchmodat fchown \
|
||||
+ fchownat fdwalk fexecve fdopendir fork fpathconf fstatat ftime ftruncate \
|
||||
+ futimesat futimens futimes gai_strerror getentropy \
|
||||
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
|
||||
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
|
||||
if_nameindex \
|
||||
diff --git a/pyconfig.h.in b/pyconfig.h.in
|
||||
index ebab5ff518..e1d659059c 100644
|
||||
--- pyconfig.h.in
|
||||
+++ pyconfig.h.in
|
||||
@@ -128,6 +128,9 @@
|
||||
/* Define to 1 if you have the `clock_settime' function. */
|
||||
#undef HAVE_CLOCK_SETTIME
|
||||
|
||||
+/* Define to 1 if you have the `close_range' function. */
|
||||
+#undef HAVE_CLOSE_RANGE
|
||||
+
|
||||
/* Define if the C compiler supports computed gotos. */
|
||||
#undef HAVE_COMPUTED_GOTOS
|
||||
|
||||
@@ -324,6 +327,9 @@
|
||||
/* Define to 1 if you have the `fdopendir' function. */
|
||||
#undef HAVE_FDOPENDIR
|
||||
|
||||
+/* Define to 1 if you have the `fdwalk' function. */
|
||||
+#undef HAVE_FDWALK
|
||||
+
|
||||
/* Define to 1 if you have the `fexecve' function. */
|
||||
#undef HAVE_FEXECVE
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
Fix build with LibreSSL 3.5.*
|
||||
|
||||
--- Modules/_hashopenssl.c.orig 2022-03-16 13:27:21 UTC
|
||||
+++ Modules/_hashopenssl.c
|
||||
@@ -42,7 +42,7 @@ module _hashlib
|
||||
#define HASH_OBJ_CONSTRUCTOR 0
|
||||
#endif
|
||||
|
||||
-#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
|
||||
+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL)
|
||||
/* OpenSSL < 1.1.0 */
|
||||
#define EVP_MD_CTX_new EVP_MD_CTX_create
|
||||
#define EVP_MD_CTX_free EVP_MD_CTX_destroy
|
|
@ -1,11 +0,0 @@
|
|||
--- setup.py.orig 2021-02-17 21:21:03 UTC
|
||||
+++ setup.py
|
||||
@@ -2057,7 +2057,7 @@ class PyBuildExt(build_ext):
|
||||
undef_macros = []
|
||||
if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
|
||||
include_dirs = []
|
||||
- libraries = [':libmpdec.so.2']
|
||||
+ libraries = ['mpdec']
|
||||
sources = ['_decimal/_decimal.c']
|
||||
depends = ['_decimal/docstrings.h']
|
||||
else:
|
|
@ -1,12 +0,0 @@
|
|||
[
|
||||
{ type: install
|
||||
message: <<EOM
|
||||
Note that some standard Python modules are provided as separate ports
|
||||
as they require additional dependencies. They are available as:
|
||||
|
||||
py%%PYTHON_SUFFIX%%-gdbm databases/py-gdbm@py%%PYTHON_SUFFIX%%
|
||||
py%%PYTHON_SUFFIX%%-sqlite3 databases/py-sqlite3@py%%PYTHON_SUFFIX%%
|
||||
py%%PYTHON_SUFFIX%%-tkinter x11-toolkits/py-tkinter@py%%PYTHON_SUFFIX%%
|
||||
EOM
|
||||
}
|
||||
]
|
|
@ -1,2 +0,0 @@
|
|||
Python is an interpreted object-oriented programming language, and is
|
||||
often compared to Tcl, Perl or Scheme.
|
File diff suppressed because it is too large
Load diff
Loading…
Add table
Reference in a new issue