mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
Update to 0.9.1, unbreak.
Submitted by: Volker Stolz <vs@foldr.org> Revamped by yours truly. Closes PR: 53239 Approved by: (maintainer timeout)
This commit is contained in:
parent
a5e671d466
commit
12f3389dd0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=87401
4 changed files with 19 additions and 38 deletions
|
@ -6,19 +6,16 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= xmms-speex
|
PORTNAME= xmms-speex
|
||||||
PORTVERSION= 0.6.0
|
PORTVERSION= 0.9.1
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= audio
|
CATEGORIES= audio
|
||||||
MASTER_SITES= http://jzb.rapanden.dk/speex/
|
MASTER_SITES= http://jzb.rapanden.dk/pub/
|
||||||
DISTNAME= speex-xmms-${PORTVERSION}
|
DISTNAME= speex-xmms-${PORTVERSION}
|
||||||
|
|
||||||
MAINTAINER= dyeske@yahoo.com
|
MAINTAINER= dyeske@yahoo.com
|
||||||
COMMENT= XMMS input plugin to play speex files
|
COMMENT= XMMS input plugin to play speex files
|
||||||
|
|
||||||
BROKEN= Broken dependency
|
|
||||||
|
|
||||||
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
|
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
|
||||||
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
|
LIB_DEPENDS= speex.2:${PORTSDIR}/audio/speex
|
||||||
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
|
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/speex-xmms
|
WRKSRC= ${WRKDIR}/speex-xmms
|
||||||
|
@ -26,17 +23,7 @@ WRKSRC= ${WRKDIR}/speex-xmms
|
||||||
USE_X_PREFIX= yes
|
USE_X_PREFIX= yes
|
||||||
USE_GNOME= gtk12
|
USE_GNOME= gtk12
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
USE_REINPLACE= yes
|
|
||||||
|
|
||||||
pre-build:
|
MAKE_FLAGS= CC="${CC}" CFLAGS="${CFLAGS}"
|
||||||
@${REINPLACE_CMD} -e 's|^main|all|; \
|
|
||||||
s|-lgtk|${CFLAGS} `${GTK_CONFIG} --cflags` `${GTK_CONFIG} --libs` |; \
|
|
||||||
s|-I/usr/include/xmms||; \
|
|
||||||
s|^install: libspeex.o|install:|; \
|
|
||||||
s|-I/usr/lib/glib/include||; \
|
|
||||||
s|-I/usr/include/glib-1.2||; \
|
|
||||||
s|-I/usr/include/gtk-1.2||; \
|
|
||||||
s|/usr/lib/xmms/Input|${X11BASE}/lib/xmms/Input|' \
|
|
||||||
${WRKSRC}/Makefile
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1 +1 @@
|
||||||
MD5 (speex-xmms-0.6.0.tar.gz) = b4014356ef929706444ff98639550460
|
MD5 (speex-xmms-0.9.1.tar.gz) = 223a8c8fc7f073c7a7bd4fe6736ed0ee
|
||||||
|
|
14
audio/xmms-speex/files/patch-Makefile
Normal file
14
audio/xmms-speex/files/patch-Makefile
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- Makefile.orig Sun Aug 3 18:18:42 2003
|
||||||
|
+++ Makefile Thu Aug 14 18:08:45 2003
|
||||||
|
@@ -14,7 +14,7 @@
|
||||||
|
$(MAKE) -C $(@D) all
|
||||||
|
|
||||||
|
libspeex.so: libspeex.c libspeex.h $(OBJS) $(GUIOBJS)
|
||||||
|
- $(CC) -shared -logg -lspeex -lgtk -lpthread -lxmms $(INCDIRS) $(CFLAGS) -DVERSION=$(VERSION) -DPACKAGE=\"libspeex\" -o libspeex.so libspeex.c $(OBJS) $(GUIOBJS)
|
||||||
|
+ $(CC) -shared $(INCDIRS) $(CFLAGS) -DVERSION=$(VERSION) -DPACKAGE=\"libspeex\" -o libspeex.so libspeex.c $(OBJS) $(GUIOBJS) `xmms-config --libs` -logg -lspeex
|
||||||
|
|
||||||
|
#utf8.o: utf8.c utf8.h
|
||||||
|
# $(CC) -c $(INCDIRS) $(CFLAGS) -DHAVE_ICONV -DICONV_CONST= -o utf8.o utf8.c
|
|
@ -1,20 +0,0 @@
|
||||||
--- libspeex.c.orig Sat Sep 21 13:18:53 2002
|
|
||||||
+++ libspeex.c Sat Sep 21 13:23:14 2002
|
|
||||||
@@ -385,7 +385,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
speex_bits_rewind(&sbits);
|
|
||||||
- speex_decode(spx_decoder, &sbits, outbuff, 1);
|
|
||||||
+ speex_decode(spx_decoder, &sbits, outbuff);
|
|
||||||
|
|
||||||
// Converting and clipping check
|
|
||||||
for (i = 0; i < speex_fs->framesize; i++) {
|
|
||||||
@@ -455,7 +455,7 @@
|
|
||||||
// For multiple frames within packets
|
|
||||||
for (j=0; j < speex_fs->nframes; j++)
|
|
||||||
{
|
|
||||||
- speex_decode(spx_decoder, &sbits, outbuff, 0);
|
|
||||||
+ speex_decode(spx_decoder, &sbits, outbuff);
|
|
||||||
|
|
||||||
// Converting and clipping check
|
|
||||||
for (i = 0; i < speex_fs->framesize; i++) {
|
|
Loading…
Add table
Reference in a new issue