biology/fasttree: Update to 2.1.11

Add -trans option for amino acid alignments
Changes: https://microbesonline.org/fasttree/ChangeLog

PR:             283035
Reported by:    alster@vinterdalen.se
This commit is contained in:
Jason W. Bacon 2024-12-03 08:52:16 -06:00
parent aef82c04c9
commit 12b5c3c8f1
3 changed files with 12 additions and 12 deletions

View file

@ -1,23 +1,23 @@
PORTNAME= FastTree
DISTVERSION= 2.1.10
PORTREVISION= 5
DISTVERSION= 2.1.11
CATEGORIES= biology
MASTER_SITES= http://www.microbesonline.org/fasttree/
MASTER_SITES= https://www.microbesonline.org/fasttree/
EXTRACT_SUFX= .c
MAINTAINER= jwb@FreeBSD.org
COMMENT= Approximately-maximum-likelihood phylogenetic trees from alignments
WWW= http://www.microbesonline.org/fasttree/
WWW= https://www.microbesonline.org/fasttree/
LICENSE= GPLv2+
NO_WRKSUBDIR= yes
PLIST_FILES= bin/FastTree
.if !exists(/usr/include/omp.h)
USES= compiler:gcc-c++11-lib
.endif
NO_WRKSUBDIR= yes
PLIST_FILES= bin/FastTree
do-extract:
@${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
@${CP} ${FILESDIR}/Makefile ${WRKSRC}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1512317739
SHA256 (FastTree-2.1.10.c) = 54cb89fc1728a974a59eae7a7ee6309cdd3cddda9a4c55b700a71219fc6e926d
SIZE (FastTree-2.1.10.c) = 390916
TIMESTAMP = 1732861256
SHA256 (FastTree-2.1.11.c) = 9026ae550307374be92913d3098f8d44187d30bea07902b9dcbfb123eaa2050f
SIZE (FastTree-2.1.11.c) = 395543

View file

@ -1,5 +1,5 @@
--- FastTree-2.1.10.c.orig 2017-12-04 15:09:11 UTC
+++ FastTree-2.1.10.c
--- FastTree-2.1.11.c.orig 2017-12-04 15:09:11 UTC
+++ FastTree-2.1.11.c
@@ -8759,7 +8759,7 @@ double pnorm(double x)
void *mymalloc(size_t sz) {