math/lcalc: upgrade to 2.1.0

Release notes at https://gitlab.com/sagemath/lcalc/-/releases/2.1.0
This commit is contained in:
Thierry Thomas 2025-04-11 16:20:40 +02:00
parent 9c5f8020f9
commit 114f9ea81c
7 changed files with 8 additions and 1257 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= lcalc
PORTVERSION= 2.0.5
PORTREVISION= 4
PORTVERSION= 2.1.0
CATEGORIES= math
MASTER_SITES= ftp://ftp.fu-berlin.de/unix/misc/sage/spkg/upstream/lcalc/
@ -15,10 +14,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libpari.so:math/pari
#USE_GITHUB= yes
#GH_ACCOUNT= agrawroh
#GH_PROJECT= l-calc
#GH_TAGNAME= 4c57471
#USE_GITLAB= yes
#GL_ACCOUNT= sagemath
USES= autoreconf compiler:c++11-lang gmake libtool localbase \
pkgconfig tar:xz

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1651073020
SHA256 (lcalc-2.0.5.tar.xz) = d780c385579cc6ee45fa27ccd2d3a3c4157fbb5ef8cd1b8951d1028bbc64c035
SIZE (lcalc-2.0.5.tar.xz) = 830360
TIMESTAMP = 1744379557
SHA256 (lcalc-2.1.0.tar.xz) = eca4f7de5f1129a9cec2cd2f012a8362c8489e746f07adae3229dd8eb2541f79
SIZE (lcalc-2.1.0.tar.xz) = 831000

File diff suppressed because it is too large Load diff

View file

@ -1,24 +0,0 @@
--- src/libLfunction/Lglobals.h.orig 2021-12-19 17:09:15 UTC
+++ src/libLfunction/Lglobals.h
@@ -52,8 +52,20 @@ using namespace std;
//---------------------------------------------------------------------------
-#include "Lcomplex.h" //for complex numbers
+#include <complex>
typedef complex<Double> Complex;
+inline Complex operator* (const Complex &l, int r) { return l * Double(r); }
+inline Complex operator/ (const Complex &l, int r) { return l / Double(r); }
+inline Complex operator+ (const Complex &l, int r) { return l + Double(r); }
+inline Complex operator- (const Complex &l, int r) { return l - Double(r); }
+inline bool operator==(const Complex &l, int r) { return l == Double(r); }
+inline bool operator!=(const Complex &l, int r) { return l != Double(r); }
+
+inline Complex operator*(int l, const Complex &r) { return r * l; }
+inline Complex operator+(int l, const Complex &r) { return r + l; }
+
+inline Complex operator/(int l, const Complex &r) { return Double(l) / r; }
+inline Complex operator-(int l, const Complex &r) { return Double(l) - r; }
#include "Lcommon.h"

View file

@ -1,10 +0,0 @@
--- src/libLfunction/Makefile.am.orig 2021-12-19 17:10:47 UTC
+++ src/libLfunction/Makefile.am
@@ -5,7 +5,6 @@ pkginclude_HEADERS = \
nodist_pkginclude_HEADERS = ../config.h
pkginclude_HEADERS = \
L.h \
- Lcomplex.h \
Ldokchitser.h \
Lexplicit_formula.h \
Lgamma.h \

View file

@ -1,11 +0,0 @@
--- src/libLfunction/mpreal.h.orig 2021-12-19 17:09:15 UTC
+++ src/libLfunction/mpreal.h
@@ -56,7 +56,7 @@
#include <cmath>
#include <cstring>
#include <limits>
-#include "Lcomplex.h"
+#include <complex>
#include <algorithm>
#include <stdint.h>

View file

@ -18,8 +18,8 @@ include/lcalc/Lriemannsiegel_blfi.h
include/lcalc/Lvalue.h
include/lcalc/config.h
lib/libLfunction.so
lib/libLfunction.so.1
lib/libLfunction.so.1.0.1
lib/libLfunction.so.2
lib/libLfunction.so.2.0.0
libdata/pkgconfig/lcalc.pc
%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog