mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
textproc/belr: Update version 5.2.94=>5.4.2
Changelog: https://gitlab.linphone.org/BC/public/belr/-/tags/5.4.2 Sponsored by: Cybermancer Infosec
This commit is contained in:
parent
7845849b9d
commit
0e215e9684
4 changed files with 27 additions and 13 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= belr
|
PORTNAME= belr
|
||||||
DISTVERSION= 5.2.94
|
DISTVERSION= 5.4.2
|
||||||
CATEGORIES= textproc
|
CATEGORIES= textproc
|
||||||
|
|
||||||
MAINTAINER= bofh@FreeBSD.org
|
MAINTAINER= bofh@FreeBSD.org
|
||||||
|
@ -9,17 +9,21 @@ WWW= https://www.linphone.org/
|
||||||
LICENSE= GPLv3
|
LICENSE= GPLv3
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||||
|
|
||||||
LIB_DEPENDS= libbctoolbox.so:net/bctoolbox
|
BUILD_DEPENDS= ${LOCALBASE}/lib/libbctoolbox.a:net/bctoolbox \
|
||||||
|
${LOCALBASE}/lib/libbcunit.a:devel/bcunit
|
||||||
|
|
||||||
USES= cmake compiler:c++17-lang
|
USES= cmake compiler:c++17-lang dos2unix
|
||||||
USE_GITLAB= yes
|
USE_GITLAB= yes
|
||||||
GL_SITE= https://gitlab.linphone.org/BC
|
GL_SITE= https://gitlab.linphone.org/BC
|
||||||
GL_ACCOUNT= public
|
GL_ACCOUNT= public
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
|
DOS2UNIX_FILES= ${WRKSRC}/CMakeLists.txt
|
||||||
|
|
||||||
CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
|
CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
|
||||||
-DCMAKE_SKIP_INSTALL_RPATH=ON \
|
-DCMAKE_SKIP_INSTALL_RPATH=ON \
|
||||||
-DENABLE_STATIC=NO \
|
|
||||||
-DENABLE_STRICT=NO
|
-DENABLE_STRICT=NO
|
||||||
|
|
||||||
|
LDFLAGS+= -lpthread
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1690557501
|
TIMESTAMP = 1743019505
|
||||||
SHA256 (belr-5.2.94.tar.bz2) = 0ae9d689eee980365c09ce8d95dacc94423275f20a762f242669c15574f2cc7f
|
SHA256 (belr-5.4.2.tar.bz2) = 5401f54acfc16ea8b4ef82fff791fd71f9256bb63c788f0dab684df78a8389b3
|
||||||
SIZE (belr-5.2.94.tar.bz2) = 56512
|
SIZE (belr-5.4.2.tar.bz2) = 56503
|
||||||
|
|
10
textproc/belr/files/patch-CMakeLists.txt
Normal file
10
textproc/belr/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- CMakeLists.txt.orig 2025-03-26 20:06:19 UTC
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -51,6 +51,7 @@ endif()
|
||||||
|
|
||||||
|
# find_package should be invoked here to check for libraries - however do NOT
|
||||||
|
# call include_directories here (see below)
|
||||||
|
+find_package(OpenSSL REQUIRED)
|
||||||
|
find_package(BCToolbox 5.3.0 REQUIRED OPTIONAL_COMPONENTS tester)
|
||||||
|
#Mandatory to init default compilation flags
|
||||||
|
bc_init_compilation_flags(STRICT_OPTIONS_CPP STRICT_OPTIONS_C STRICT_OPTIONS_CXX ENABLE_STRICT)
|
|
@ -1,18 +1,18 @@
|
||||||
bin/belr-compiler
|
bin/belr-compiler
|
||||||
bin/belr-parse
|
bin/belr-parse
|
||||||
bin/belr_tester
|
bin/belr-tester
|
||||||
include/belr/abnf.h
|
include/belr/abnf.h
|
||||||
include/belr/belr.h
|
include/belr/belr.h
|
||||||
include/belr/grammarbuilder.h
|
include/belr/grammarbuilder.h
|
||||||
include/belr/parser.h
|
include/belr/parser.h
|
||||||
lib/cmake/belr/belrConfig.cmake
|
lib/cmake/Belr/BelrConfig.cmake
|
||||||
lib/cmake/belr/belrTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
lib/cmake/Belr/BelrConfigVersion.cmake
|
||||||
lib/cmake/belr/belrTargets.cmake
|
lib/cmake/Belr/BelrTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||||
|
lib/cmake/Belr/BelrTargets.cmake
|
||||||
|
lib/libbelr.a
|
||||||
%%DATADIR%%-tester/res/basicgrammar.txt
|
%%DATADIR%%-tester/res/basicgrammar.txt
|
||||||
%%DATADIR%%-tester/res/register.txt
|
%%DATADIR%%-tester/res/register.txt
|
||||||
%%DATADIR%%-tester/res/response.txt
|
%%DATADIR%%-tester/res/response.txt
|
||||||
%%DATADIR%%-tester/res/sipgrammar.txt
|
%%DATADIR%%-tester/res/sipgrammar.txt
|
||||||
%%DATADIR%%-tester/res/vcardgrammar.txt
|
%%DATADIR%%-tester/res/vcardgrammar.txt
|
||||||
%%DATADIR%%/grammars/belr-grammar-example.blr
|
%%DATADIR%%/grammars/belr-grammar-example.blr
|
||||||
lib/libbelr.so
|
|
||||||
lib/libbelr.so.1
|
|
||||||
|
|
Loading…
Add table
Reference in a new issue