devel/py-thinc8: Update to 8.3.6

Changes:	https://github.com/explosion/thinc/releases
This commit is contained in:
Po-Chuan Hsieh 2025-04-18 13:16:22 +08:00
parent 9020daf19a
commit 0d8b87e10b
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
4 changed files with 32 additions and 15 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= thinc
PORTVERSION= 8.3.4
PORTVERSION= 8.3.6
CATEGORIES= devel python
MASTER_SITES= PYPI \
https://github.com/explosion/thinc/releases/download/release-v${PORTVERSION}/
@ -14,14 +14,14 @@ WWW= https://thinc.ai/ \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.2.0<1.3.0:math/py-blis@${PY_FLAVOR} \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.3.0<1.4.0:math/py-blis@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}murmurhash>=0.28.0<1.1.0:devel/py-murmurhash@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.19.0,1<3.0.0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}preshed3>=3.0.2<3.1.0:devel/py-preshed3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.2.0<1.3.0:math/py-blis@${PY_FLAVOR} \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.3.0<1.4.0:math/py-blis@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}catalogue>=2.0.4<2.1.0:devel/py-catalogue@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}confection>=0.0.1<1.0.0:devel/py-confection@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
@ -29,12 +29,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.2.0<1.3.0:math/py-blis@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}numpy>=1.19.0,1<3.0.0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=20.0:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}preshed3>=3.0.2<3.1.0:devel/py-preshed3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic2>=1.7.4<3.0.0:devel/py-pydantic2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic2>=2.0.0<3.0.0:devel/py-pydantic2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}srsly>=2.4.0<3.0.0:devel/py-srsly@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wasabi>=0.8.1<1.2.0:textproc/py-wasabi@${PY_FLAVOR}
USES= python:3.9+
USES= python
USE_PYTHON= autoplist concurrent cython pep517
PORTSCOUT= limit:^8\.

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1738089074
SHA256 (thinc-8.3.4.tar.gz) = b5925482498bbb6dca0771e375b35c915818f735891e93d93a662dab15f6ffd8
SIZE (thinc-8.3.4.tar.gz) = 193903
TIMESTAMP = 1744288988
SHA256 (thinc-8.3.6.tar.gz) = 49983f9b7ddc4343a9532694a9118dd216d7a600520a21849a43b6c268ec6cad
SIZE (thinc-8.3.6.tar.gz) = 194218

View file

@ -1,9 +1,15 @@
--- pyproject.toml.orig 2025-01-13 12:16:06 UTC
--- pyproject.toml.orig 2025-04-04 11:10:41 UTC
+++ pyproject.toml
@@ -6,7 +6,7 @@ requires = [
@@ -1,12 +1,12 @@ requires = [
[build-system]
requires = [
"setuptools",
- "cython>=3.0,<4.0",
+ "cython>=0,<4.0",
"murmurhash>=1.0.2,<1.1.0",
"cymem>=2.0.2,<2.1.0",
"preshed>=3.0.2,<3.1.0",
"blis>=1.2.0,<1.3.0",
"blis>=1.3.0,<1.4.0",
- "numpy>=2.0.0,<3.0.0",
+ "numpy>=1.19.0,<3.0.0",
]

View file

@ -1,11 +1,22 @@
--- setup.cfg.orig 2024-12-16 12:19:05 UTC
--- setup.cfg.orig 2025-04-04 11:10:50 UTC
+++ setup.cfg
@@ -33,7 +33,7 @@ setup_requires =
python_requires = >=3.9,<3.13
@@ -32,8 +32,8 @@ setup_requires =
include_package_data = true
python_requires = >=3.9,<3.14
setup_requires =
cython>=0.29.0,<3.0
- cython>=3.0,<4.0
- numpy>=2.0.0,<3.0.0
+ cython>=0,<4.0
+ numpy>=1.19.0,<3.0.0
cymem>=2.0.2,<2.1.0
preshed>=3.0.2,<3.1.0
murmurhash>=1.0.2,<1.1.0
@@ -48,7 +48,7 @@ install_requires =
catalogue>=2.0.4,<2.1.0
confection>=0.0.1,<1.0.0
setuptools
- numpy>=2.0.0,<3.0.0
+ numpy>=1.19.0,<3.0.0
pydantic>=2.0.0,<3.0.0
packaging>=20.0
dataclasses>=0.6,<1.0; python_version < "3.7"