devel/muon: fix building in env without git

This commit is contained in:
Baptiste Daroussin 2024-11-26 09:59:23 +01:00
parent ef8ea5091b
commit 0acecea6cf
2 changed files with 17 additions and 5 deletions

View file

@ -25,14 +25,14 @@ USE_CSTD= c99
CFLAGS+= -D__XSI_VISIBLE=1
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
post-patch:
# this confuses some of the FreeBSD configure targets
@${RM} -r ${WRKSRC}/tests/project/common
do-configure:
@(cd ${WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${SH} bootstrap.sh . && \
./muon setup -Dlibcurl=disabled -Dlibarchive=disabled ${BUILD_WRKSRC})
${SETENV} ${CONFIGURE_ENV} ./muon setup \
-Dlibcurl=disabled \
-Dlibarchive=disabled \
-Dtracy=disabled \
${BUILD_WRKSRC})
do-install:
@(${SETENV} ${MAKE_ENV} ${BUILD_WRKSRC}/muon -C ${BUILD_WRKSRC} install)

View file

@ -0,0 +1,12 @@
--- tests/project/meson.build.orig 2024-10-07 15:19:19 UTC
+++ tests/project/meson.build
@@ -401,8 +401,8 @@ endif
endif
endif
+meson_tests_dir = meson.current_source_dir() / 'meson-tests'
if git.found()
- meson_tests_dir = meson.current_source_dir() / 'meson-tests'
meson_tests_sha = '1e565931348f15f3f9b654f46ab4bf5fa009ca4f'
if not fs.is_dir(meson_tests_dir)