irc/irssi: Revert build with ssl from ports

This fix was only needed for breakage caused by pkgconf, which has
meanwhile been fixed.

This reverts commit 71f0f861ce.
This commit is contained in:
Felix Palmen 2024-03-16 08:26:20 +01:00
parent 4c0ac6f6d1
commit 0a8e5e996f
2 changed files with 0 additions and 15 deletions

View file

@ -42,9 +42,6 @@ UTF8PROC_MESON_NO= disable-utf8proc
PERL_USE_OFF= perl5=build PERL_USE_OFF= perl5=build
post-patch:
@${REINPLACE_CMD} 's|%%OPENSSLLIB%%|${OPENSSLLIB}|' ${WRKSRC}/meson.build
post-install-PERL-off: post-install-PERL-off:
@${RM} -r ${STAGEDIR}${DATADIR}/scripts @${RM} -r ${STAGEDIR}${DATADIR}/scripts

View file

@ -1,12 +0,0 @@
--- meson.build.orig 2023-03-28 12:13:26 UTC
+++ meson.build
@@ -284,7 +284,8 @@ if glib_internal and want_static_dependency and want_f
else
openssl_dep = dependency('openssl', static : want_static_dependency, include_type : 'system')
endif
-dep += openssl_dep
+dep += cc.find_library('crypto', dirs: '%%OPENSSLLIB%%')
+dep += cc.find_library('ssl', dirs: '%%OPENSSLLIB%%')
############
# utf8proc #