mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
net-p2p/vuze: Remove expired port
2025-03-31 net-p2p/vuze: Abandoned upstream
This commit is contained in:
parent
e8edf37bb7
commit
09c7af2a8f
9 changed files with 1 additions and 179 deletions
1
MOVED
1
MOVED
|
@ -4227,3 +4227,4 @@ science/py-moltemplate||2025-03-31|Has expired: Depends on expired devel/py-pyte
|
|||
math/py-numdifftools||2025-03-31|Has expired: Depends on expired devel/py-pytest-runner
|
||||
graphics/py-pygal||2025-03-31|Has expired: Depends on expired devel/py-pytest-runner
|
||||
www/choqok||2025-03-31|Has expired: Project discontinued upstream
|
||||
net-p2p/vuze||2025-03-31|Has expired: Abandoned upstream
|
||||
|
|
|
@ -106,7 +106,6 @@
|
|||
SUBDIR += twitch-tui
|
||||
SUBDIR += udpt
|
||||
SUBDIR += uhub
|
||||
SUBDIR += vuze
|
||||
SUBDIR += walletd
|
||||
SUBDIR += warpinator
|
||||
SUBDIR += xbt
|
||||
|
|
|
@ -1,72 +0,0 @@
|
|||
PORTNAME= vuze
|
||||
PORTVERSION= 5.7.4.0
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net-p2p java
|
||||
MASTER_SITES= SF/azureus/vuze/Vuze_${PORTVERSION:S/.//g}
|
||||
DISTNAME= Vuze_${PORTVERSION:S/.//g}_source
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= BitTorrent client written in Java
|
||||
WWW= https://www.vuze.com/
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/GPL.txt
|
||||
|
||||
DEPRECATED= Abandoned upstream
|
||||
EXPIRATION_DATE=2025-03-31
|
||||
|
||||
BUILD_DEPENDS= ${JAVALIBDIR}/log4j.jar:devel/log4j \
|
||||
${JAVALIBDIR}/commons-cli.jar:java/apache-commons-cli \
|
||||
${JAVALIBDIR}/junit.jar:java/junit \
|
||||
${JAVALIBDIR}/swt.jar:x11-toolkits/swt
|
||||
RUN_DEPENDS= ${JAVALIBDIR}/swt.jar:x11-toolkits/swt
|
||||
|
||||
USES= cpe gnome java:ant zip
|
||||
JAVA_OS= native
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
NO_ARCH= yes
|
||||
|
||||
JARFILE= ${PORTNAME}.jar
|
||||
|
||||
# build classpath from BUILD_DEPENDS
|
||||
CLASSPATH_JARS= ${BUILD_DEPENDS:C/:.+$//:M*.jar:T}
|
||||
|
||||
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE} \
|
||||
bin/${PORTNAME} \
|
||||
share/icons/hicolor/16x16/apps/${PORTNAME}.png \
|
||||
share/icons/hicolor/32x32/apps/${PORTNAME}.png \
|
||||
share/icons/hicolor/64x64/apps/${PORTNAME}.png
|
||||
|
||||
SUB_FILES= ${PORTNAME}
|
||||
SUB_LIST= LIBDIR="${LOCALBASE}/lib" JARFILE="${JARFILE}" \
|
||||
SWTJAR="${JAVALIBDIR}/swt.jar" JAVA="${LOCALBASE}/bin/java"
|
||||
|
||||
DESKTOP_ENTRIES= "Vuze" \
|
||||
"BitTorrent client" \
|
||||
"${PORTNAME}" \
|
||||
"${PORTNAME}" \
|
||||
"Network;P2P;Java;" \
|
||||
true
|
||||
|
||||
CLASSPATH=.
|
||||
.for jar in ${CLASSPATH_JARS}
|
||||
CLASSPATH:=${CLASSPATH}:${JAVALIBDIR}/${jar}
|
||||
.endfor
|
||||
|
||||
post-patch:
|
||||
${RM} -r ${WRKSRC}/org/eclipse
|
||||
@${SED} -E -e 's|%%CLASSPATH%%|${CLASSPATH}|' \
|
||||
${FILESDIR}/build.xml > ${WRKSRC}/build.xml
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/dist/lib/${JARFILE} ${STAGEDIR}${JAVAJARDIR}
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
|
||||
.for s in 16 32 64
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}x${s}/apps
|
||||
${INSTALL_DATA} ${WRKSRC}/org/gudy/azureus2/ui/icons/a${s}.png \
|
||||
${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}x${s}/apps/${PORTNAME}.png
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1485891204
|
||||
SHA256 (Vuze_5740_source.zip) = 2a5b2084f1f6bdc3aaea0cf16fee3dc40050111c365a5383a34679443be80bdf
|
||||
SIZE (Vuze_5740_source.zip) = 10809580
|
|
@ -1,51 +0,0 @@
|
|||
<!-- Under a BSDL license. Copyright by Mario S F Ferreira <lioux@FreeBSD.org> 2005- -->
|
||||
<!-- Under a BSDL license. Copyright by jrandom 2005- -->
|
||||
<project basedir="." default="dist" name="azureus">
|
||||
<description>
|
||||
Builds Azureus
|
||||
</description>
|
||||
<!-- set global properties for this build -->
|
||||
<property name="src" location="src"/>
|
||||
<property name="build" location="build"/>
|
||||
<property name="dist" location="dist"/>
|
||||
|
||||
<target name="init">
|
||||
<!-- Create the time stamp -->
|
||||
<tstamp/>
|
||||
<!-- Create the build directory structure used by compile -->
|
||||
<mkdir dir="${build}"/>
|
||||
</target>
|
||||
|
||||
<target name="compile" depends="init" description="compile the source " >
|
||||
<!-- Compile the java code from ${src} into ${build} -->
|
||||
<javac srcdir="." destdir="${build}" fork="yes" source="1.5" target="1.5"
|
||||
memoryMaximumSize="512m">
|
||||
<include name="**/*.java"/>
|
||||
<exclude name="**/Win32*.java"/>
|
||||
<exclude name="**/swt/osx/**"/>
|
||||
<exclude name="**/macosx/**"/>
|
||||
<classpath path="%%CLASSPATH%%"/>
|
||||
</javac>
|
||||
</target>
|
||||
|
||||
<target name="dist" depends="compile" description="generate the distribution" >
|
||||
<!-- Create the distribution directory -->
|
||||
<mkdir dir="${dist}/lib"/>
|
||||
|
||||
<copy todir="${build}">
|
||||
<fileset dir="." includes="**/*.gif **/*.jpg, **/*.png" />
|
||||
<fileset dir="." includes="**/*.dat **/*.stf **/*.xsd" />
|
||||
<fileset dir="." includes="**/*.css **/*.html **/*.js **/*.php **/*.tmpl **/*.txt" />
|
||||
<fileset dir="." includes="**/*.ico **/*.wav" />
|
||||
<fileset dir="." includes="**/*.properties" />
|
||||
</copy>
|
||||
<!-- Put everything in ${build} into the azureus.jar file -->
|
||||
<jar jarfile="${dist}/lib/vuze.jar" basedir="${build}"/>
|
||||
</target>
|
||||
|
||||
<target name="clean" description="clean up" >
|
||||
<!-- Delete the ${build} and ${dist} directory trees -->
|
||||
<delete dir="${build}"/>
|
||||
<delete dir="${dist}"/>
|
||||
</target>
|
||||
</project>
|
|
@ -1,12 +0,0 @@
|
|||
--- org/gudy/azureus2/ui/swt/views/table/painted/TableViewPainted.java.orig 2013-09-10 23:18:13.000000000 +0200
|
||||
+++ org/gudy/azureus2/ui/swt/views/table/painted/TableViewPainted.java 2013-09-10 23:18:56.000000000 +0200
|
||||
@@ -2554,9 +2554,6 @@
|
||||
}
|
||||
|
||||
private int getScrollbarsMode() {
|
||||
- if (hasGetScrollBarMode) {
|
||||
- return cTable.getScrollbarsMode();
|
||||
- }
|
||||
return SWT.NONE;
|
||||
}
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
Add koi8-u as an encoding...
|
||||
|
||||
https://jira.vuze.com/browse/SUP-195
|
||||
|
||||
--- org/gudy/azureus2/core3/internat/LocaleUtil.java 2012-07-12 22:34:06.000000000 -0400
|
||||
+++ org/gudy/azureus2/core3/internat/LocaleUtil.java 2012-10-15 01:18:16.000000000 -0400
|
||||
@@ -37,5 +37,5 @@
|
||||
systemEncoding, // must be first entry due to code below that gets the system decoder
|
||||
"Big5","EUC-JP","EUC-KR","GB18030","GB2312","GBK","ISO-2022-JP","ISO-2022-KR",
|
||||
- "Shift_JIS","KOI8-R",
|
||||
+ "Shift_JIS","KOI8-U","KOI8-R",
|
||||
"TIS-620", // added for bug #1008848
|
||||
Constants.DEFAULT_ENCODING,"windows-1251",Constants.BYTE_ENCODING
|
|
@ -1,22 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# java
|
||||
export JAVA_OS="%%JAVA_OS%%"
|
||||
|
||||
ECLIPSE_BASE=%%LOCALBASE%%/eclipse
|
||||
ECLIPSE_SWT_JAR=%%SWTJAR%%
|
||||
LIB_PATH=%%LIBDIR%%
|
||||
|
||||
CLASS_PATH=:%%JAVAJARDIR%%/%%JARFILE%%:${ECLIPSE_SWT_JAR}
|
||||
|
||||
if [ "${DEBUG}" ]
|
||||
then
|
||||
echo "ECLIPSE_BASE = ${ECLIPSE_BASE}"
|
||||
echo "ECLIPSE_WS = ${ECLIPSE_WS}"
|
||||
echo "ECLIPSE_SWT = ${ECLIPSE_SWT}"
|
||||
echo "ECLIPSE_SWT_JAR = ${ECLIPSE_SWT_JAR}"
|
||||
echo "CLASS_PATH = ${CLASS_PATH}"
|
||||
echo "LIB_PATH = ${LIB_PATH}"
|
||||
fi
|
||||
|
||||
exec "%%JAVA%%" -cp "${CLASS_PATH}" "-Djava.library.path=${LIB_PATH}" "-Dos.name=FreeBSD" "-Dazureus.config.path=${HOME}/.Azureus" "-Duser.dir=${HOME}/.Azureus" org.gudy.azureus2.ui.swt.Main "${@}"
|
|
@ -1,5 +0,0 @@
|
|||
Vuze is a java bittorrent client. Vuze (formerly Azureus) offers
|
||||
multiple torrent downloads, queuing/priority systems (on torrents and
|
||||
files), start/stop seeding options and instant access to
|
||||
numerous pieces of information about your torrents. Azureus
|
||||
now features an embedded tracker easily setup and ready to use.
|
Loading…
Add table
Reference in a new issue