- New port: editors/dlangide

Cross platform D language IDE written using DlangUI library.
- Uses DUB (dub.json or dub.sdl) project format
- Shows tree with project source files
- Can open and edit source files from project or file system in multi-tab editor
- Build and run project with DUB
- Build log highlight and navigation to place of error or warning by clicking on
  log line (contributed by Extrawurst)
- DUB dependencies update
- DUB package configuration selection (contributed by NCrashed)
- Dependency projects are shown in workspace tree
- New project wizard
- Toolchain settings for DMD, LDC, GDC
- Project specific settings
- Basic debugger support using GDB (work in progress)
- D language source code, json, dml syntax highlight
- Indent / unindent text with Tab and Shift+Tab or Ctrl+[ and Ctrl+]
- Toggle line or block comments by Ctrl+/ and Ctrl+Shift+/
- D source code autocompletion by Ctrl+Space or Ctrl+Shift+G (using DCD)
- D source code Go To Definition by Ctrl+G or F12 (using DCD)
- D source Doc comments display on mouse hover (using DCD)
- D source code Smart Indents
- Select word by mouse double click

WWW: https://github.com/buggins/dlangui
This commit is contained in:
Jose Alonso Cardenas Marquez 2017-07-23 02:54:33 +00:00
parent 4f83a0eee1
commit 09a1664d85
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=446443
5 changed files with 87 additions and 0 deletions

View file

@ -27,6 +27,7 @@
SUBDIR += dhex
SUBDIR += diakonos
SUBDIR += dkns
SUBDIR += dlangide
SUBDIR += drjava
SUBDIR += e3
SUBDIR += ecce

40
editors/dlangide/Makefile Normal file
View file

@ -0,0 +1,40 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
PORTNAME= dlangide
PORTVERSION= 0.7.30
CATEGORIES= editors
MASTER_SITES= https://github.com/buggins/dlangide/archive/
DISTNAME= ${PORTVERSION:S/^/v/}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
COMMENT= D language IDE based on DlangUI
LICENSE= BSL
BUILD_DEPENDS= ldmd2:lang/ldc \
dub:devel/dub \
${LOCALBASE}/lib/d/libdlangui.a:devel/dlangui \
${LOCALBASE}/lib/d/libdsymbol.a:devel/dsymbol \
${LOCALBASE}/lib/d/libdparse.a:devel/libdparse \
${LOCALBASE}/lib/d/libemsi_containers.a:devel/containers \
${LOCALBASE}/lib/d/libmsgpack-d.a:devel/msgpack-d \
${LOCALBASE}/lib/d/libdlib.a:devel/dlib \
${LOCALBASE}/lib/d/libDerelictUtil.a:devel/derelict-util \
${LOCALBASE}/lib/d/libDerelictGL3.a:graphics/derelict-gl3 \
${LOCALBASE}/lib/d/libDerelictSDL2.a:devel/derelict-sdl \
${LOCALBASE}/lib/d/libDerelictFT.a:print/derelict-ft \
dcd-server:devel/dcd-server
PLIST_FILES= bin/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
do-build:
@cd ${WRKSRC} && ${DUB_CMD}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1500703850
SHA256 (dlangide/v0.7.30.tar.gz) = 5255ac4dfd70bf0d2f2a9306fbb1338f1c03f8ae5015dfe10d5fb8a942ab8225
SIZE (dlangide/v0.7.30.tar.gz) = 2291395

View file

@ -0,0 +1,19 @@
--- dub.json.orig 2017-04-11 13:32:24 UTC
+++ dub.json
@@ -8,14 +8,10 @@
"targetName": "dlangide",
"targetPath": "bin",
"targetType": "executable",
-
+ "libs": ["dlangui","dsymbol","dparse","dlib","dcd","emsi_containers","msgpack-d", "DerelictFT","DerelictUtil","DerelictGL3","DerelictSDL2"],
+ "lflags":["-L/usr/local/lib/d","-L/usr/local/lib"],
"stringImportPaths": ["views", "views/res", "views/res/i18n", "views/res/mdpi", "views/res/hdpi"],
- "dependencies": {
- "dlangui": "==0.9.50",
- "dcd": "~>0.9.0-alpha4"
- },
-
"copyFiles-windows": [
"libs/windows/x86/mago-mi.exe"
],

View file

@ -0,0 +1,24 @@
Cross platform D language IDE written using DlangUI library.
- Uses DUB (dub.json or dub.sdl) project format
- Shows tree with project source files
- Can open and edit source files from project or file system in multi-tab editor
- Build and run project with DUB
- Build log highlight and navigation to place of error or warning by clicking on
log line (contributed by Extrawurst)
- DUB dependencies update
- DUB package configuration selection (contributed by NCrashed)
- Dependency projects are shown in workspace tree
- New project wizard
- Toolchain settings for DMD, LDC, GDC
- Project specific settings
- Basic debugger support using GDB (work in progress)
- D language source code, json, dml syntax highlight
- Indent / unindent text with Tab and Shift+Tab or Ctrl+[ and Ctrl+]
- Toggle line or block comments by Ctrl+/ and Ctrl+Shift+/
- D source code autocompletion by Ctrl+Space or Ctrl+Shift+G (using DCD)
- D source code Go To Definition by Ctrl+G or F12 (using DCD)
- D source Doc comments display on mouse hover (using DCD)
- D source code Smart Indents
- Select word by mouse double click
WWW: https://github.com/buggins/dlangui