mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
security/beid: update to 5.0.28
This commit is contained in:
parent
e0afbdc1ff
commit
09707eb57f
7 changed files with 29 additions and 69 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= beid
|
PORTNAME= beid
|
||||||
PORTVERSION= 5.0.8
|
PORTVERSION= 5.0.28
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
CATEGORIES= security
|
CATEGORIES= security
|
||||||
|
|
||||||
|
@ -44,8 +44,7 @@ post-patch:
|
||||||
@${REINPLACE_CMD} -e 's,/usr/bin/pinentry,${LOCALBASE}/bin/pinentry,' \
|
@${REINPLACE_CMD} -e 's,/usr/bin/pinentry,${LOCALBASE}/bin/pinentry,' \
|
||||||
-e 's,/proc/%d/exe,/proc/%d/file,' \
|
-e 's,/proc/%d/exe,/proc/%d/file,' \
|
||||||
${WRKSRC}/cardcomm/pkcs11/src/dialogs/dialogspinentry/dlgs_pinentry.cpp
|
${WRKSRC}/cardcomm/pkcs11/src/dialogs/dialogspinentry/dlgs_pinentry.cpp
|
||||||
@${REINPLACE_CMD} -e '/^MODUTIL=/s,/usr/bin,${LOCALBASE}/bin,' \
|
@${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' \
|
||||||
-e '/^CERTUTIL=/s,/usr/bin,${LOCALBASE}/bin,' \
|
|
||||||
-e '/^LIBS=/s,=.*,=${PREFIX}/lib,' \
|
-e '/^LIBS=/s,=.*,=${PREFIX}/lib,' \
|
||||||
${WRKSRC}/plugins_tools/chrome_pkcs11/beid-update-nssdb
|
${WRKSRC}/plugins_tools/chrome_pkcs11/beid-update-nssdb
|
||||||
@${REINPLACE_CMD} '/^Exec=/s,/usr/bin,${PREFIX}/bin,' \
|
@${REINPLACE_CMD} '/^Exec=/s,/usr/bin,${PREFIX}/bin,' \
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1598443353
|
TIMESTAMP = 1638704952
|
||||||
SHA256 (Fedict-eid-mw-v5.0.8_GH0.tar.gz) = 843f1535cf6c54391e84ce9dba55a2d6de029ca4cb10e5f71880532d46fa9b83
|
SHA256 (Fedict-eid-mw-v5.0.28_GH0.tar.gz) = 44fa020dd40ae6801a941991780d0efcc4d7ec2b8949e19544f695bc24c22bfb
|
||||||
SIZE (Fedict-eid-mw-v5.0.8_GH0.tar.gz) = 8782476
|
SIZE (Fedict-eid-mw-v5.0.28_GH0.tar.gz) = 13615312
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- plugins_tools/eid-viewer/Makefile.am.orig 2021-08-13 09:34:02 UTC
|
||||||
|
+++ plugins_tools/eid-viewer/Makefile.am
|
||||||
|
@@ -131,7 +131,7 @@ eid_viewer_LDADD += $(top_builddir)/cardcomm/pkcs11/sr
|
||||||
|
endif
|
||||||
|
libeidviewer_la_LIBADD = $(top_builddir)/plugins_tools/util/liblabels.la $(top_builddir)/cardcomm/pkcs11/src/libbeidpkcs11.la @SSL_LIBS@ @XML2_LIBS@
|
||||||
|
libeidviewer_la_LDFLAGS = -version-info 1:0:1
|
||||||
|
-AM_CFLAGS = @GTK_CFLAGS@ -I. -I$(srcdir)/include -Igtk -DDATAROOTDIR='"$(datarootdir)"' -I$(top_srcdir)/doc/sdk/include/v240 -I$(top_srcdir)/cardcomm/pkcs11/src/fuzz -I$(top_srcdir)/plugins_tools/util @SSL_CFLAGS@ @GIO_CFLAGS@ @XML2_CFLAGS@ @CURL_CFLAGS@ @libproxy_CFLAGS@ -fvisibility=hidden @FUZZING@
|
||||||
|
+AM_CPPFLAGS = -I. -I$(srcdir)/include -Igtk -DDATAROOTDIR='"$(datarootdir)"' -I$(top_srcdir)/doc/sdk/include/v240 -I$(top_srcdir)/cardcomm/pkcs11/src/fuzz -I$(top_srcdir)/plugins_tools/util @GTK_CFLAGS@ @SSL_CFLAGS@ @GIO_CFLAGS@ @XML2_CFLAGS@ @CURL_CFLAGS@ @libproxy_CFLAGS@ -fvisibility=hidden @FUZZING@
|
||||||
|
AM_CXXFLAGS = $(AM_CFLAGS) -std=c++98
|
||||||
|
SUBDIRS = . gtk/po test uml
|
||||||
|
|
10
security/beid/files/patch-plugins__tools_eid-viewer_verify.c
Normal file
10
security/beid/files/patch-plugins__tools_eid-viewer_verify.c
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- plugins_tools/eid-viewer/verify.c.orig 2021-08-13 09:34:02 UTC
|
||||||
|
+++ plugins_tools/eid-viewer/verify.c
|
||||||
|
@@ -19,7 +19,6 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef HAVE_LIBBSD
|
||||||
|
-#include <bsd/bsd.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef __APPLE__
|
|
@ -1,40 +0,0 @@
|
||||||
--- plugins_tools/chrome_pkcs11/beid-update-nssdb.orig 2018-07-20 12:53:45 UTC
|
|
||||||
+++ plugins_tools/chrome_pkcs11/beid-update-nssdb
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/bin/bash
|
|
||||||
+#! /bin/sh
|
|
||||||
#
|
|
||||||
# The MIT License (MIT)
|
|
||||||
#
|
|
||||||
@@ -26,15 +26,17 @@
|
|
||||||
# Copyright(c) Wouter Verhelst, 2018
|
|
||||||
|
|
||||||
NSSDB=$HOME/.pki/nssdb
|
|
||||||
-MODUTIL="/usr/bin/modutil -force -dbdir sql:$NSSDB"
|
|
||||||
-CERTUTIL="/usr/bin/certutil -d sql:$NSSDB"
|
|
||||||
+MODUTIL="/usr/bin/modutil"
|
|
||||||
+CERTUTIL="/usr/bin/certutil"
|
|
||||||
LIBS=$(ld --verbose | grep SEARCH | awk '{ gsub(/;/,"\n"); print }' | awk -F '\"' '/SEARCH_DIR\(\"=?/ { gsub(/=/,""); print $2 }')
|
|
||||||
PKCS11=libbeidpkcs11.so.0
|
|
||||||
|
|
||||||
+[ -e $CERTUTIL -a -e $MODUTIL ] || exit
|
|
||||||
+
|
|
||||||
if [ ! -f $NSSDB/cert9.db ]; then
|
|
||||||
echo "Initializing new database"
|
|
||||||
mkdir -p $NSSDB
|
|
||||||
- $CERTUTIL -N --empty-password
|
|
||||||
+ $CERTUTIL -d sql:$NSSDB -N --empty-password
|
|
||||||
fi
|
|
||||||
|
|
||||||
for DIR in $LIBS; do
|
|
||||||
@@ -45,8 +47,8 @@ for DIR in $LIBS; do
|
|
||||||
echo "ID-card support for Google Chrome/Chromium/Opera already enabled"
|
|
||||||
else
|
|
||||||
echo "Enabling ID-card functionality in Google Chrome/Chromium/Opera via $LIB"
|
|
||||||
- $MODUTIL -delete "Belgium eID"
|
|
||||||
- $MODUTIL -add "Belgium eID" -libfile $LIB -mechanisms FRIENDLY
|
|
||||||
+ $MODUTIL -force -dbdir sql:$NSSDB -delete "Belgium eID"
|
|
||||||
+ $MODUTIL -force -dbdir sql:$NSSDB -add "Belgium eID" -libfile $LIB -mechanisms FRIENDLY
|
|
||||||
fi
|
|
||||||
exit
|
|
||||||
fi
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- plugins_tools/eid-viewer/Makefile.am.orig 2020-07-09 08:00:33 UTC
|
|
||||||
+++ plugins_tools/eid-viewer/Makefile.am
|
|
||||||
@@ -120,7 +120,7 @@ dist_eidvinclude_HEADERS = \
|
|
||||||
eid_viewer_LDADD = @GTK_LIBS@ @GIO_LIBS@ @SSL_LIBS@ @XML2_LIBS@ @CURL_LIBS@ @libproxy_LIBS@ $(top_builddir)/plugins_tools/util/liblabels.la libeidviewer.la
|
|
||||||
libeidviewer_la_LIBADD = $(top_builddir)/plugins_tools/util/liblabels.la $(top_builddir)/cardcomm/pkcs11/src/libbeidpkcs11.la @SSL_LIBS@ @XML2_LIBS@
|
|
||||||
libeidviewer_la_LDFLAGS = -version-info 1:0:1
|
|
||||||
-AM_CFLAGS = @GTK_CFLAGS@ -I. -I$(srcdir)/include -Igtk -DDATAROOTDIR='"$(datarootdir)"' -I$(top_srcdir)/doc/sdk/include/rsaref220 -I$(top_srcdir)/plugins_tools/util @SSL_CFLAGS@ @GIO_CFLAGS@ @XML2_CFLAGS@ @CURL_CFLAGS@ @libproxy_CFLAGS@ -fvisibility=hidden @FUZZING@
|
|
||||||
+AM_CPPFLAGS = -I. -I$(srcdir)/include -Igtk -DDATAROOTDIR='"$(datarootdir)"' -I$(top_srcdir)/doc/sdk/include/rsaref220 -I$(top_srcdir)/plugins_tools/util @GTK_CFLAGS@ @SSL_CFLAGS@ @GIO_CFLAGS@ @XML2_CFLAGS@ @CURL_CFLAGS@ @libproxy_CFLAGS@ -fvisibility=hidden @FUZZING@
|
|
||||||
AM_CXXFLAGS = $(AM_CFLAGS) -std=c++98
|
|
||||||
SUBDIRS = . gtk/po test uml
|
|
||||||
|
|
||||||
@@ -199,7 +199,9 @@ dist_trust_DATA = \
|
|
||||||
certs/belgiumrca4.pem
|
|
||||||
|
|
||||||
install-data-hook:
|
|
||||||
- if ( $(SSL_PREFIX)/bin/openssl help 2>&1 | grep -q rehash); then $(SSL_PREFIX)/bin/openssl rehash $(DESTDIR)/$(trustdir); else $(SSL_PREFIX)/bin/c_rehash $(DESTDIR)/$(trustdir); fi
|
|
||||||
+ (cd $(DESTDIR)$(trustdir) && for i in *.pem; do \
|
|
||||||
+ ln -sfh $$i $$($(SSL_PREFIX)/bin/openssl x509 -hash -noout -in $$i).0; \
|
|
||||||
+ done)
|
|
||||||
|
|
||||||
gtk/viewer_glade.h: gtk/viewer.glade
|
|
||||||
$(top_srcdir)/plugins_tools/aboutmw/gtk/gen.sh VIEWER_GLADE_H VIEWER_GLADE_STRING < $^ > $@
|
|
|
@ -18,8 +18,8 @@ lib/libbeidpkcs11.so.0.0.0
|
||||||
lib/libeidviewer.so
|
lib/libeidviewer.so
|
||||||
lib/libeidviewer.so.0
|
lib/libeidviewer.so.0
|
||||||
lib/libeidviewer.so.0.1.0
|
lib/libeidviewer.so.0.1.0
|
||||||
lib/mozilla/pkcs11-modules/beidp11kit.json
|
|
||||||
lib/mozilla/pkcs11-modules/beidpkcs11.json
|
lib/mozilla/pkcs11-modules/beidpkcs11.json
|
||||||
|
lib/mozilla/pkcs11-modules/beidpkcs11_alt.json
|
||||||
lib/pkcs11/beidpkcs11.so
|
lib/pkcs11/beidpkcs11.so
|
||||||
lib/firefox/distribution/extensions/belgiumeid@eid.belgium.be.xpi
|
lib/firefox/distribution/extensions/belgiumeid@eid.belgium.be.xpi
|
||||||
libdata/pkgconfig/libbeidpkcs11.pc
|
libdata/pkgconfig/libbeidpkcs11.pc
|
||||||
|
@ -27,9 +27,11 @@ share/applications/eid-viewer.desktop
|
||||||
share/eid-mw/eidv4.xsd
|
share/eid-mw/eidv4.xsd
|
||||||
share/eid-mw/trustdir/143b8e8e.0
|
share/eid-mw/trustdir/143b8e8e.0
|
||||||
share/eid-mw/trustdir/9ef4b1e1.0
|
share/eid-mw/trustdir/9ef4b1e1.0
|
||||||
|
share/eid-mw/trustdir/a094a3c4.0
|
||||||
share/eid-mw/trustdir/belgiumrca2.pem
|
share/eid-mw/trustdir/belgiumrca2.pem
|
||||||
share/eid-mw/trustdir/belgiumrca3.pem
|
share/eid-mw/trustdir/belgiumrca3.pem
|
||||||
share/eid-mw/trustdir/belgiumrca4.pem
|
share/eid-mw/trustdir/belgiumrca4.pem
|
||||||
|
share/eid-mw/trustdir/belgiumrca6.pem
|
||||||
share/eid-mw/trustdir/c7e71426.0
|
share/eid-mw/trustdir/c7e71426.0
|
||||||
share/icons/hicolor/128x128/apps/eid-viewer.png
|
share/icons/hicolor/128x128/apps/eid-viewer.png
|
||||||
share/icons/hicolor/16x16/apps/eid-viewer.png
|
share/icons/hicolor/16x16/apps/eid-viewer.png
|
||||||
|
|
Loading…
Add table
Reference in a new issue