mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
net/httping: Update to 4.4.0
- Rename FFTW option to FFTW3 Changes: https://github.com/folkertvanheusden/HTTPing/releases
This commit is contained in:
parent
95d1b03827
commit
087f7620f3
3 changed files with 18 additions and 35 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= httping
|
||||
PORTVERSION= 4.2.0
|
||||
PORTVERSION= 4.4.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= net
|
||||
|
||||
|
@ -14,17 +14,19 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
USES= cmake pkgconfig localbase:ldflags ssl
|
||||
|
||||
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${PREFIX}/share/man/man1
|
||||
CMAKE_ON= USE_SSL
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= folkertvanheusden
|
||||
GH_PROJECT= HTTPing
|
||||
|
||||
OPTIONS_DEFINE= DOCS FFTW NCURSES NLS
|
||||
OPTIONS_DEFINE= DOCS FFTW3 NCURSES NLS
|
||||
OPTIONS_DEFAULT=NCURSES
|
||||
OPTIONS_SUB= yes
|
||||
FFTW3_IMPLIES= TUI
|
||||
|
||||
FFTW_CMAKE_BOOL= USE_FFTW
|
||||
FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3
|
||||
FFTW3_CMAKE_BOOL= USE_FFTW3
|
||||
FFTW3_LIB_DEPENDS= libfftw3.so:math/fftw3
|
||||
NCURSES_CMAKE_BOOL= USE_TUI
|
||||
NCURSES_LDFLAGS= ${NCURSESLIBS}
|
||||
NCURSES_USES= ncurses
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1739116680
|
||||
SHA256 (folkertvanheusden-HTTPing-v4.2.0_GH0.tar.gz) = d6eb16a1f7d8724b883f07ffe71f75ae13f0535dbab077ff19ab8f36ab90d96a
|
||||
SIZE (folkertvanheusden-HTTPing-v4.2.0_GH0.tar.gz) = 81921
|
||||
TIMESTAMP = 1739930140
|
||||
SHA256 (folkertvanheusden-HTTPing-v4.4.0_GH0.tar.gz) = 87fa2da5ac83c4a0edf4086161815a632df38e1cc230e1e8a24a8114c09da8fd
|
||||
SIZE (folkertvanheusden-HTTPing-v4.4.0_GH0.tar.gz) = 82454
|
||||
|
|
|
@ -1,30 +1,11 @@
|
|||
--- CMakeLists.txt.orig 2024-05-14 21:12:06 UTC
|
||||
--- CMakeLists.txt.orig 2025-02-16 08:54:15 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -6,12 +6,12 @@ add_definitions(-DVERSION=\"${VERSION}\")
|
||||
file (STRINGS "version" VERSION)
|
||||
add_definitions(-DVERSION=\"${VERSION}\")
|
||||
@@ -34,7 +34,7 @@ if(USE_TUI)
|
||||
include(FindPkgConfig)
|
||||
|
||||
-add_definitions(-DLOCALEDIR=\"/usr/local/share/locale\")
|
||||
+add_definitions(-DLOCALEDIR=\"${CMAKE_INSTALL_PREFIX}/share/locale\")
|
||||
|
||||
set(SOURCES colors.c cookies.c error.c fft.c gen.c help.c http.c io.c kalman.c main.c mssl.c nc.c res.c socks5.c tcp.c utils.c)
|
||||
add_executable(httping ${SOURCES})
|
||||
|
||||
-target_link_libraries(httping m)
|
||||
+target_link_libraries(httping intl m)
|
||||
|
||||
if (USE_GETTEXT)
|
||||
find_package(Intl REQUIRED)
|
||||
@@ -30,10 +30,12 @@ target_compile_options(httping PUBLIC ${NCURSES_CFLAGS
|
||||
target_include_directories(httping PUBLIC ${NCURSES_INCLUDE_DIRS})
|
||||
target_compile_options(httping PUBLIC ${NCURSES_CFLAGS_OTHER})
|
||||
|
||||
+if (USE_FFTW)
|
||||
pkg_check_modules(FFTW3 fftw3)
|
||||
target_link_libraries(httping ${FFTW3_LIBRARIES})
|
||||
target_include_directories(httping PUBLIC ${FFTW3_INCLUDE_DIRS})
|
||||
target_compile_options(httping PUBLIC ${FFTW3_CFLAGS_OTHER})
|
||||
+endif ()
|
||||
endif ()
|
||||
|
||||
pkg_check_modules(SSL libssl)
|
||||
if(USE_TUI)
|
||||
- pkg_check_modules(NCURSES REQUIRED ncurses)
|
||||
+ pkg_check_modules(NCURSES ncurses)
|
||||
target_link_libraries(httping ${NCURSES_LIBRARIES})
|
||||
target_include_directories(httping PUBLIC ${NCURSES_INCLUDE_DIRS})
|
||||
target_compile_options(httping PUBLIC ${NCURSES_CFLAGS_OTHER})
|
||||
|
|
Loading…
Add table
Reference in a new issue