mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
lang/p5-ePerl: remove the need to update patch-configure every 5 years
We have not had a Perl older than 5.003 for probably 3 decades, so no need to check if the current version is "new" enough.
This commit is contained in:
parent
070366381b
commit
0703664089
4 changed files with 37 additions and 24 deletions
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.PL.orig Wed Jan 26 09:49:43 2005
|
||||
+++ Makefile.PL Wed Jan 26 09:51:09 2005
|
||||
@@ -39,7 +39,8 @@
|
||||
--- Makefile.PL.orig 1998-07-10 08:06:41 UTC
|
||||
+++ Makefile.PL
|
||||
@@ -39,7 +39,8 @@ all:
|
||||
\@if [ ! -f mod/Makefile ]; then \\
|
||||
echo "cd mod && $perl Makefile.PL $args"; \\
|
||||
cd mod && $perl Makefile.PL $args; \\
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
--- configure.orig Sun Aug 2 15:48:40 1998
|
||||
+++ configure Wed Feb 25 12:10:13 2004
|
||||
@@ -571,7 +571,7 @@
|
||||
Allow recent Perl versions, and keep CFLAGS/LDFLAGS
|
||||
|
||||
--- configure.orig 1998-08-02 13:48:40 UTC
|
||||
+++ configure
|
||||
@@ -571,7 +571,7 @@ if test "${with_perl+set}" = set; then
|
||||
if test "${with_perl+set}" = set; then
|
||||
withval="$with_perl"
|
||||
perlprog=$with_perl
|
||||
|
@ -9,16 +11,27 @@
|
|||
|
||||
else
|
||||
TMPFILE=/tmp/x.$$
|
||||
@@ -600,7 +600,7 @@
|
||||
@@ -600,19 +600,6 @@ case $perlvers in
|
||||
PATH_PERL=$perlprog
|
||||
echo "$ac_t""$perlprog v$perlvers" 1>&6
|
||||
case $perlvers in
|
||||
- 5.003* | 5.004* | 5.005* | 5.006* )
|
||||
+ 5.003* | 5.004* | 5.005* | 5.006* | 5.008* | 5.01* | 5.02* | 5.03* )
|
||||
;;
|
||||
* ) echo ""
|
||||
echo "Latest Perl found on your system is $perlvers,"
|
||||
@@ -901,7 +901,6 @@
|
||||
- ;;
|
||||
- * ) echo ""
|
||||
- echo "Latest Perl found on your system is $perlvers,"
|
||||
- echo "but at least Perl version 5.003 is required."
|
||||
- echo "In case the newer one is not in PATH, just use"
|
||||
- echo "the option --with-perl=/path/to/bin/perl to"
|
||||
- echo "provide the correct executable."
|
||||
- echo ""
|
||||
- { echo "configure: error: Perl version too old" 1>&2; exit 1; }
|
||||
- ;;
|
||||
-esac
|
||||
-case $perlvers in
|
||||
5.00[3-6]_[0-9][0-9] )
|
||||
perlvnum=`echo $perlvers | sed -e 's/\.//' -e 's/_//'` ;;
|
||||
5.00[3-6] )
|
||||
@@ -901,7 +888,6 @@ if test $ac_cv_prog_gcc = yes; then
|
||||
GCC=yes
|
||||
ac_test_CFLAGS="${CFLAGS+set}"
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
|
@ -26,7 +39,7 @@
|
|||
echo $ac_n "checking whether ${CC-cc} accepts -g""... $ac_c" 1>&6
|
||||
echo "configure:907: checking whether ${CC-cc} accepts -g" >&5
|
||||
if eval "test \"`echo '$''{'ac_cv_prog_cc_g'+set}'`\" = set"; then
|
||||
@@ -918,16 +917,17 @@
|
||||
@@ -918,16 +904,17 @@ echo "$ac_t""$ac_cv_prog_cc_g" 1>&6
|
||||
fi
|
||||
|
||||
echo "$ac_t""$ac_cv_prog_cc_g" 1>&6
|
||||
|
@ -47,7 +60,7 @@
|
|||
fi
|
||||
|
||||
# Extract the first word of "ranlib", so it can be a program name with args.
|
||||
@@ -1025,11 +1025,8 @@
|
||||
@@ -1025,11 +1012,8 @@ if test "${enable_debug+set}" = set; then
|
||||
if test "${enable_debug+set}" = set; then
|
||||
enableval="$enable_debug"
|
||||
if test ".$ac_cv_prog_gcc" = ".yes"; then
|
||||
|
@ -60,7 +73,7 @@
|
|||
fi
|
||||
x="enabled"
|
||||
debug=on
|
||||
@@ -1039,8 +1036,6 @@
|
||||
@@ -1039,8 +1023,6 @@ else
|
||||
|
||||
|
||||
else
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- eperl_parse.c.orig 2009-02-27 12:23:36.000000000 +0000
|
||||
+++ eperl_parse.c 2009-02-27 12:25:38.000000000 +0000
|
||||
@@ -298,6 +298,7 @@
|
||||
--- eperl_parse.c.orig 1998-07-10 07:50:48 UTC
|
||||
+++ eperl_parse.c
|
||||
@@ -298,6 +298,7 @@ char *strnchr(char *buf, char chr, int n)
|
||||
return NULL;
|
||||
}
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
|||
char *strnstr(char *buf, char *str, int n)
|
||||
{
|
||||
char *cp;
|
||||
@@ -311,6 +312,7 @@
|
||||
@@ -311,6 +312,7 @@ char *strnstr(char *buf, char *str, int n)
|
||||
}
|
||||
return NULL;
|
||||
}
|
||||
|
@ -16,7 +16,7 @@
|
|||
|
||||
char *strncasestr(char *buf, char *str, int n)
|
||||
{
|
||||
@@ -326,6 +328,9 @@
|
||||
@@ -326,6 +328,9 @@ char *strncasestr(char *buf, char *str, int n)
|
||||
return NULL;
|
||||
}
|
||||
|
||||
|
@ -26,7 +26,7 @@
|
|||
char *strndup(char *buf, int n)
|
||||
{
|
||||
char *cp;
|
||||
@@ -334,7 +339,8 @@
|
||||
@@ -334,7 +339,8 @@ char *strndup(char *buf, int n)
|
||||
strncpy(cp, buf, n);
|
||||
return cp;
|
||||
}
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- eperl_proto.h.orig 2009-02-27 12:23:02.000000000 +0000
|
||||
+++ eperl_proto.h 2009-02-27 12:24:39.000000000 +0000
|
||||
--- eperl_proto.h.orig 1998-07-10 07:52:24 UTC
|
||||
+++ eperl_proto.h
|
||||
@@ -36,6 +36,7 @@
|
||||
#define EPERL_PROTO_H 1
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
|||
|
||||
/* eperl_main.c */
|
||||
extern int mode;
|
||||
@@ -79,9 +80,14 @@
|
||||
@@ -79,9 +80,14 @@ extern char *strnchr(char *buf, char chr, int n);
|
||||
extern char *ePerl_Efwrite(char *cpBuf, int nBuf, int cNum, char *cpOut);
|
||||
extern char *ePerl_Cfwrite(char *cpBuf, int nBuf, int cNum, char *cpOut);
|
||||
extern char *strnchr(char *buf, char chr, int n);
|
||||
|
|
Loading…
Add table
Reference in a new issue