mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
science/molsketch: update 0.7.3 → 0.8.1
This commit is contained in:
parent
2ab2779b53
commit
06026b86c6
5 changed files with 27 additions and 23 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= molsketch
|
||||
DISTVERSION= 0.7.3
|
||||
DISTVERSION= 0.8.1
|
||||
DISTVERSIONSUFFIX= -src
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= SF/${PORTNAME}/Molsketch/
|
||||
|
@ -14,17 +14,17 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
|||
|
||||
LIB_DEPENDS= libopenbabel.so:science/openbabel
|
||||
|
||||
USES= cmake:noninja compiler:c++14-lang desktop-file-utils localbase:ldflags \
|
||||
USES= cmake:noninja compiler:c++17-lang desktop-file-utils localbase:ldflags \
|
||||
pkgconfig qt:5 shared-mime-info # build fails with ninja, see https://sourceforge.net/p/molsketch/bugs/41/
|
||||
USE_QT= core gui network printsupport svg widgets buildtools:build linguisttools:build qmake:build
|
||||
USE_LDCONFIG= ${PREFIX}/lib/molsketch
|
||||
|
||||
CMAKE_ARGS= -DMSK_PREFIX:STRING=${PREFIX}
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
WRKSRC= ${WRKDIR}/Molsketch-${DISTVERSION}
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1664224961
|
||||
SHA256 (Molsketch-0.7.3-src.tar.gz) = 79c8e7c7d00246d7d9da4a11742dba02de3f96e701220709c16772e58178b44d
|
||||
SIZE (Molsketch-0.7.3-src.tar.gz) = 1907433
|
||||
TIMESTAMP = 1737708866
|
||||
SHA256 (Molsketch-0.8.1-src.tar.gz) = eb016f977024b6ff11804748d8436c29a9652a5632fdff13b26e42d0507f8a02
|
||||
SIZE (Molsketch-0.8.1-src.tar.gz) = 1852967
|
||||
|
|
|
@ -1,17 +1,8 @@
|
|||
--- CMakeLists.txt.orig 2021-03-07 18:40:16 UTC
|
||||
--- CMakeLists.txt.orig 2024-02-25 11:23:17 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -36,7 +36,7 @@ configure_file("${CMAKE_SOURCE_DIR}/cmake_uninstall.cm
|
||||
add_custom_target(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
|
||||
@@ -119,7 +119,7 @@ add_definitions(-DOBABEL_IFACE_LOCATION="${MSK_INSTALL
|
||||
|
||||
# Enabling debugging symbols
|
||||
-set(CMAKE_BUILD_TYPE Debug)
|
||||
+#set(CMAKE_BUILD_TYPE Debug)
|
||||
|
||||
# Enabling shared libraries
|
||||
set(BUILD_SHARED_LIBS ON)
|
||||
@@ -108,7 +108,7 @@ endif(WIN32 OR WIN64)
|
||||
|
||||
add_definitions(-DOBABEL_IFACE_LOCATION="\\\"${MSK_INSTALL_LIBS}/${OBABEL_IFACE_NAME}\\\"")
|
||||
add_definitions(-DOBABEL_IFACE_LOCATION="${MSK_INSTALL_LIBS}/${OBABEL_IFACE_NAME}")
|
||||
|
||||
-set(CMAKE_INSTALL_PREFIX ${MSK_PREFIX})
|
||||
+#set(CMAKE_INSTALL_PREFIX ${MSK_PREFIX})
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
--- buildvariables.orig 2018-10-24 03:59:40 UTC
|
||||
--- buildvariables.orig 2023-04-14 16:04:22 UTC
|
||||
+++ buildvariables
|
||||
@@ -2,6 +2,6 @@
|
||||
@@ -1,6 +1,6 @@
|
||||
"Global prefix";MSK_PREFIX;/usr;"C:/Program\ Files/MolsKetch"
|
||||
"Executable destination dir";MSK_INSTALL_BINS;/bin;/bin
|
||||
"Headers destination dir";MSK_INSTALL_INCLUDES;/include;/include
|
||||
"Documentation destination dir";MSK_INSTALL_DOCS;/share/doc/molsketch;/doc
|
||||
-"Libraries (64bit) destination dir";MSK_INSTALL_LIBS64;/lib64/molsketch;/lib
|
||||
+"Libraries (64bit) destination dir";MSK_INSTALL_LIBS64;/lib/molsketch;/lib
|
||||
"Libraries (32bit) destination dir";MSK_INSTALL_LIBS;/lib/molsketch;/lib
|
||||
|
|
|
@ -33,6 +33,7 @@ include/libmolsketch/actions/rotateaction.h
|
|||
include/libmolsketch/actions/textaction.h
|
||||
include/libmolsketch/actions/transformcommand.h
|
||||
include/libmolsketch/actions/zlevelaction.h
|
||||
include/libmolsketch/alignment.h
|
||||
include/libmolsketch/arrow.h
|
||||
include/libmolsketch/arrowpopup.h
|
||||
include/libmolsketch/atom.h
|
||||
|
@ -45,6 +46,10 @@ include/libmolsketch/constants.h
|
|||
include/libmolsketch/coordinatedelegate.h
|
||||
include/libmolsketch/coordinatemodel.h
|
||||
include/libmolsketch/coordinatetableview.h
|
||||
include/libmolsketch/core/coreatom.h
|
||||
include/libmolsketch/core/corebond.h
|
||||
include/libmolsketch/core/coremolecule.h
|
||||
include/libmolsketch/debuggable.h
|
||||
include/libmolsketch/electronsystem.h
|
||||
include/libmolsketch/element.h
|
||||
include/libmolsketch/elementalignment.h
|
||||
|
@ -56,6 +61,7 @@ include/libmolsketch/graphicsitem.h
|
|||
include/libmolsketch/grid.h
|
||||
include/libmolsketch/helptextemptydock.h
|
||||
include/libmolsketch/helptextonemptylabel.h
|
||||
include/libmolsketch/iconutils.h
|
||||
include/libmolsketch/librarymodel.h
|
||||
include/libmolsketch/libraryview.h
|
||||
include/libmolsketch/lonepair.h
|
||||
|
@ -66,6 +72,13 @@ include/libmolsketch/moleculepopup.h
|
|||
include/libmolsketch/molscene.h
|
||||
include/libmolsketch/molview.h
|
||||
include/libmolsketch/neighboralignment.h
|
||||
include/libmolsketch/painting/paintable.h
|
||||
include/libmolsketch/painting/paintableaggregate.h
|
||||
include/libmolsketch/painting/regulartextbox.h
|
||||
include/libmolsketch/painting/stackedtextbox.h
|
||||
include/libmolsketch/painting/textbox.h
|
||||
include/libmolsketch/painting/textfield.h
|
||||
include/libmolsketch/painting/textline.h
|
||||
include/libmolsketch/propertiesdock.h
|
||||
include/libmolsketch/propertieswidget.h
|
||||
include/libmolsketch/qtdeprecations.h
|
||||
|
@ -79,7 +92,7 @@ include/libmolsketch/stringify.h
|
|||
include/libmolsketch/sumformula.h
|
||||
include/libmolsketch/textitem.h
|
||||
include/libmolsketch/xmlobjectinterface.h
|
||||
lib/molsketch/libmolsketch.so
|
||||
lib/molsketch/libmskcore.so
|
||||
lib/molsketch/libobabeliface.so
|
||||
share/applications/molsketch.desktop
|
||||
share/icons/hicolor/scalable/apps/molsketch.svg
|
||||
|
|
Loading…
Add table
Reference in a new issue