mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
graphics/imlib2_loaders: Update to 1.12.1
- Switch to DISTVERSION - Use multi option since at least one needed to be selected or a empty install will happen - Pet portlint, portclippy, portfmt and Q/A check - Take maintainership ChangeLog: https://git.enlightenment.org/old/legacy-imlib2_loaders/src/branch/master/ChangeLog PR: 276399
This commit is contained in:
parent
026dc43063
commit
047c0a038f
4 changed files with 23 additions and 48 deletions
|
@ -1,38 +1,42 @@
|
|||
PORTNAME= imlib2_loaders
|
||||
PORTVERSION= 1.7.0
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 1.12.1
|
||||
PORTEPOCH= 2
|
||||
CATEGORIES= graphics enlightenment
|
||||
MASTER_SITES= SF/enlightenment/imlib2-src/${PORTVERSION}
|
||||
MASTER_SITES= SF/enlightenment/imlib2-src/${DISTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= eduardo@FreeBSD.org
|
||||
COMMENT= Extra image loader plugins for Imlib 2
|
||||
WWW= https://docs.enlightenment.org/api/imlib2/html/
|
||||
|
||||
LICENSE= imlib2 GPLv2
|
||||
LICENSE_COMB= multi
|
||||
LICENSE= GPLv2 imlib2
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_NAME_imlib2= imlib2 license
|
||||
LICENSE_FILE_imlib2= ${WRKSRC}/COPYING
|
||||
LICENSE_PERMS_imlib2= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
LIB_DEPENDS= libImlib2.so:graphics/imlib2
|
||||
BUILD_DEPENDS= imlib2>0:graphics/imlib2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
USES= libtool localbase pathfix pkgconfig tar:bzip2 xorg
|
||||
USES= libtool localbase pathfix pkgconfig tar:xz xorg
|
||||
USE_XORG= x11 xext
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-static
|
||||
|
||||
OPTIONS_DEFINE= EET XCF
|
||||
OPTIONS_DEFAULT= EET XCF
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
OPTIONS_DEFAULT= XCF
|
||||
OPTIONS_MULTI= LOADERS
|
||||
OPTIONS_MULTI_LOADERS= EET XCF
|
||||
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
EET_DESC= Enable eet loader
|
||||
EET_LIB_DEPENDS= libefl.so:devel/efl
|
||||
EET_CONFIGURE_OFF= --disable-eet
|
||||
|
||||
XCF_DESC= Enable XCF loader
|
||||
XCF_CONFIGURE_OFF= --disable-xcf
|
||||
|
||||
EET_BROKEN= eet loader broken since v1.7.2
|
||||
EET_LIB_DEPENDS= libefl.so:devel/efl
|
||||
EET_CONFIGURE_ENABLE= eet
|
||||
|
||||
XCF_CONFIGURE_ENABLE= xcf
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1596568222
|
||||
SHA256 (imlib2_loaders-1.7.0.tar.bz2) = 7af5490e9998de039f8234977c3f505c96dcf2d2c9887db811cbbdba492e95af
|
||||
SIZE (imlib2_loaders-1.7.0.tar.bz2) = 301990
|
||||
TIMESTAMP = 1705402335
|
||||
SHA256 (imlib2_loaders-1.12.1.tar.xz) = ca3a92b109b4a7ef0173a62ff91a8330b901eef85984ed591ec227d15251be0f
|
||||
SIZE (imlib2_loaders-1.12.1.tar.xz) = 254388
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
--- src/modules/loaders/loader_eet.c.orig 2020-08-05 10:54:15 UTC
|
||||
+++ src/modules/loaders/loader_eet.c
|
||||
@@ -6,11 +6,6 @@
|
||||
|
||||
#include "loader_common.h"
|
||||
|
||||
-#define SWAP32(x) (x) = \
|
||||
-((((x) & 0x000000ff ) << 24) |\
|
||||
- (((x) & 0x0000ff00 ) << 8) |\
|
||||
- (((x) & 0x00ff0000 ) >> 8) |\
|
||||
- (((x) & 0xff000000 ) >> 24))
|
||||
#include <Eet.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
@@ -379,11 +374,6 @@ void
|
||||
formats(ImlibLoader * l)
|
||||
{
|
||||
static const char *const list_formats[] = { "eet" };
|
||||
- int i;
|
||||
-
|
||||
- l->num_formats = sizeof(list_formats) / sizeof(char *);
|
||||
- l->formats = malloc(sizeof(char *) * l->num_formats);
|
||||
-
|
||||
- for (i = 0; i < l->num_formats; i++)
|
||||
- l->formats[i] = strdup(list_formats[i]);
|
||||
+ __imlib_LoaderSetFormats(l, list_formats,
|
||||
+ sizeof(list_formats) / sizeof(char *));
|
||||
}
|
|
@ -1,3 +1,2 @@
|
|||
lib/imlib2/loaders/ani.so
|
||||
%%EET%%lib/imlib2/loaders/eet.so
|
||||
%%XCF%%lib/imlib2/loaders/xcf.so
|
||||
|
|
Loading…
Add table
Reference in a new issue