finance/beancount: upgrade to 3.1.0

This commit is contained in:
Xin LI 2025-01-25 01:46:36 -08:00
parent c8cea35e38
commit 03d28a4516
3 changed files with 10 additions and 25 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= beancount
PORTVERSION= 3.0.0
PORTVERSION= 3.1.0
CATEGORIES= finance
DIST_SUBDIR= ${PORTNAME}
@ -12,9 +12,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bottle>=0:www/py-bottle@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-dateutil>=0:devel/py-python-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}meson-python>0:devel/meson-python@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-dateutil>=0:devel/py-python-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-magic>=0:devel/py-python-magic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
@ -29,9 +30,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_F
${PYTHON_PKGNAMEPREFIX}python-magic>=0:devel/py-python-magic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
USES= compiler:c11 python
USES= bison compiler:c11 python shebangfix
USE_GITHUB= yes
USE_PYTHON= autoplist distutils noflavors
USE_PYTHON= autoplist noflavors pep517
SHEBANG_GLOB= *.py
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/parser/_parser*.so

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1736645480
SHA256 (beancount/beancount-beancount-3.0.0_GH0.tar.gz) = 1f260ababb58d5976c7e51aacf54fa8bac0f89dca9365669eea1ec18a3bf3864
SIZE (beancount/beancount-beancount-3.0.0_GH0.tar.gz) = 1277638
TIMESTAMP = 1737797146
SHA256 (beancount/beancount-beancount-3.1.0_GH0.tar.gz) = 50ec6842de7a77928f94028b04f19b41685f0afab806dba98da7380023ebcaf3
SIZE (beancount/beancount-beancount-3.1.0_GH0.tar.gz) = 548025

View file

@ -1,18 +0,0 @@
--- setup.py.orig 2018-05-12 17:29:03 UTC
+++ setup.py
@@ -168,6 +168,7 @@ assert isinstance(version, str)
def get_hg_changeset():
"""Get the Mercurial changeset id."""
+ return None
try:
output = subprocess.check_output(['hg', 'parent', '--template', '{node} {date}'],
shell=False)
@@ -179,6 +180,7 @@ def get_hg_changeset():
def get_git_changeset():
"""Get the Git changeset id."""
+ return None
try:
output = subprocess.check_output(['git', 'log', '--pretty=%H %ct', '-1'],
shell=False)