mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
This module allows applications to send passive checks to Nagios both
locally and remotely. WWW: http://search.cpan.org/dist/Net-NSCA-Client/ Feature safe: yes Approved by: eadler (mentor)
This commit is contained in:
parent
138760a2b8
commit
025497985e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=305946
7 changed files with 115 additions and 0 deletions
|
@ -215,6 +215,7 @@
|
|||
SUBDIR += p5-Net-IP-Resolver
|
||||
SUBDIR += p5-Net-IPv4Addr
|
||||
SUBDIR += p5-Net-IPv6Addr
|
||||
SUBDIR += p5-Net-NSCA-Client
|
||||
SUBDIR += p5-Net-Netmask
|
||||
SUBDIR += p5-Net-SNMP
|
||||
SUBDIR += p5-Net-SNMP-Util
|
||||
|
|
62
net-mgmt/p5-Net-NSCA-Client/Makefile
Normal file
62
net-mgmt/p5-Net-NSCA-Client/Makefile
Normal file
|
@ -0,0 +1,62 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= Net-NSCA-Client
|
||||
PORTVERSION= 0.009002
|
||||
CATEGORIES= net-mgmt perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= tj@FreeBSD.org
|
||||
COMMENT= Perl extension for sending passive service checks to nagios
|
||||
|
||||
RUN_DEPENDS= p5-Const-Fast>=0.013:${PORTSDIR}/devel/p5-Const-Fast \
|
||||
p5-Convert-Binary-C>=0.76:${PORTSDIR}/converters/p5-Convert-Binary-C \
|
||||
p5-Data-Rand>=0.0.4:${PORTSDIR}/devel/p5-Data-Rand \
|
||||
p5-Data-Rand-Obscure>=0.021:${PORTSDIR}/devel/p5-Data-Rand-Obscure \
|
||||
p5-Data-Validate-Domain>=0.10:${PORTSDIR}/dns/p5-Data-Validate-Domain \
|
||||
p5-Digest-CRC>=0.18:${PORTSDIR}/security/p5-Digest-CRC \
|
||||
p5-Moose>=0.89:${PORTSDIR}/devel/p5-Moose \
|
||||
p5-MooseX-Clone>=0.05:${PORTSDIR}/devel/p5-MooseX-Clone \
|
||||
p5-MooseX-StrictConstructor>=0.08:${PORTSDIR}/devel/p5-MooseX-StrictConstructor \
|
||||
p5-MooseX-Types>=0.35:${PORTSDIR}/devel/p5-MooseX-Types \
|
||||
p5-MooseX-Types-PortNumber>=0.02:${PORTSDIR}/devel/p5-MooseX-Types-PortNumber \
|
||||
p5-namespace-clean>=0.04:${PORTSDIR}/devel/p5-namespace-clean
|
||||
BUILD_DEPENDS= p5-Const-Fast>=0.013:${PORTSDIR}/devel/p5-Const-Fast \
|
||||
p5-Convert-Binary-C>=0.76:${PORTSDIR}/converters/p5-Convert-Binary-C \
|
||||
p5-Data-Rand>=0.0.4:${PORTSDIR}/devel/p5-Data-Rand \
|
||||
p5-Data-Rand-Obscure>=0.021:${PORTSDIR}/devel/p5-Data-Rand-Obscure \
|
||||
p5-Data-Section>=0.101621:${PORTSDIR}/devel/p5-Data-Section \
|
||||
p5-Data-Validate-Domain>=0.10:${PORTSDIR}/dns/p5-Data-Validate-Domain \
|
||||
p5-Digest-CRC>=0.18:${PORTSDIR}/security/p5-Digest-CRC \
|
||||
p5-Moose>=0.89:${PORTSDIR}/devel/p5-Moose \
|
||||
p5-MooseX-Clone>=0.05:${PORTSDIR}/devel/p5-MooseX-Clone \
|
||||
p5-MooseX-StrictConstructor>=0.08:${PORTSDIR}/devel/p5-MooseX-StrictConstructor \
|
||||
p5-MooseX-Types>=0.35:${PORTSDIR}/devel/p5-MooseX-Types \
|
||||
p5-MooseX-Types-PortNumber>=0.02:${PORTSDIR}/devel/p5-MooseX-Types-PortNumber \
|
||||
p5-namespace-clean>=0.04:${PORTSDIR}/devel/p5-namespace-clean
|
||||
TEST_DEPENDS= p5-Test-Class>=0.37:${PORTSDIR}/devel/p5-Test-Class \
|
||||
p5-Test-Command>=0.08:${PORTSDIR}/devel/p5-Test-Command \
|
||||
p5-Test-Fatal>=0.010:${PORTSDIR}/devel/p5-Test-Fatal \
|
||||
p5-Test-Requires>=0.06:${PORTSDIR}/devel/p5-Test-Requires \
|
||||
p5-Test-TCP>=1.17:${PORTSDIR}/devel/p5-Test-TCP
|
||||
|
||||
PERL_MODBUILD= yes
|
||||
|
||||
MAN3= Net::NSCA::Client.3 \
|
||||
Net::NSCA::Client::DataPacket.3 \
|
||||
Net::NSCA::Client::Connection.3 \
|
||||
Net::NSCA::Client::Connection::TLS.3 \
|
||||
Net::NSCA::Client::InitialPacket.3 \
|
||||
Net::NSCA::Client::Library.3 \
|
||||
Net::NSCA::Client::ServerConfig.3 \
|
||||
Net::NSCA::Client::Troubleshooting.3 \
|
||||
Net::NSCA::Client::Utils.3
|
||||
|
||||
post-patch:
|
||||
@cd ${WRKSRC} && ${RM} -f bin/send_nsca
|
||||
@cd ${WRKSRC} && ${RM} -f t/send_nsca.t
|
||||
|
||||
regression-test: build
|
||||
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./Build test
|
||||
|
||||
.include <bsd.port.mk>
|
2
net-mgmt/p5-Net-NSCA-Client/distinfo
Normal file
2
net-mgmt/p5-Net-NSCA-Client/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (Net-NSCA-Client-0.009002.tar.gz) = 4d6144f725796b2a92d07fee9c180f7a3f94c578c1fd83f387b30407695b7bd5
|
||||
SIZE (Net-NSCA-Client-0.009002.tar.gz) = 47099
|
15
net-mgmt/p5-Net-NSCA-Client/files/patch-MANIFEST
Normal file
15
net-mgmt/p5-Net-NSCA-Client/files/patch-MANIFEST
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- MANIFEST.orig 2012-10-16 01:16:50.000000000 +0000
|
||||
+++ MANIFEST 2012-10-16 01:17:32.000000000 +0000
|
||||
@@ -1,4 +1,3 @@
|
||||
-bin/send_nsca
|
||||
Build.PL
|
||||
Changes
|
||||
lib/Net/NSCA/Client.pm
|
||||
@@ -18,7 +17,6 @@
|
||||
t/00-load.t
|
||||
t/live_server.t
|
||||
t/run.t
|
||||
-t/send_nsca.t
|
||||
t/tests/MyTest/Class.pm
|
||||
t/tests/MyTest/Net/NSCA/Client.pm
|
||||
t/tests/MyTest/Net/NSCA/Client/DataPacket.pm
|
18
net-mgmt/p5-Net-NSCA-Client/files/patch-SIGNATURE
Normal file
18
net-mgmt/p5-Net-NSCA-Client/files/patch-SIGNATURE
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- SIGNATURE.orig 2012-10-16 01:29:10.000000000 +0000
|
||||
+++ SIGNATURE 2012-10-16 01:29:40.000000000 +0000
|
||||
@@ -21,7 +21,6 @@
|
||||
SHA1 25374deef7e5c8e43ac3292102e2afbfef2d582d META.json
|
||||
SHA1 32774af2a7d8013f9895f99072f28a68b8d17b05 META.yml
|
||||
SHA1 6cf9983c8276ba78518d05f738a5b4fd1ebf0a7f README
|
||||
-SHA1 705ef2954530010a1c595dce068dccebe9ba3cdc bin/send_nsca
|
||||
SHA1 8029b3cc8e61c11074e14b7107564311e13ce75a lib/Net/NSCA/Client.pm
|
||||
SHA1 8bcfd32c5d953e4fb884835b2a6a46cb58e0840d lib/Net/NSCA/Client/Connection.pm
|
||||
SHA1 b788771cf65638e5065bf47bb9519eb7a32b67b9 lib/Net/NSCA/Client/Connection/TLS.pm
|
||||
@@ -34,7 +33,6 @@
|
||||
SHA1 d6966bb79264ca7bba1987e8b1db09daa1ab040f t/00-load.t
|
||||
SHA1 f439ed87c8d7d4c54e9bb248c83461e1ba5d42e3 t/live_server.t
|
||||
SHA1 8e97b73d24521fc341d1e0c56e8380efbc43007f t/run.t
|
||||
-SHA1 64527851d5cece080bacdbfcc7bed0418a4a41b9 t/send_nsca.t
|
||||
SHA1 05c5f452595881a225d21d3d114db69832d7cd76 t/tests/MyTest/Class.pm
|
||||
SHA1 6e94cf782c305b07587d9238d0624f23c5c60ac3 t/tests/MyTest/Net/NSCA/Client.pm
|
||||
SHA1 4d16d6f818e5a1efa147d6b22362c5f9c6cfe3f0 t/tests/MyTest/Net/NSCA/Client/DataPacket.pm
|
4
net-mgmt/p5-Net-NSCA-Client/pkg-descr
Normal file
4
net-mgmt/p5-Net-NSCA-Client/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
This module allows applications to send passive checks to Nagios both locally
|
||||
and remotely.
|
||||
|
||||
WWW: http://search.cpan.org/dist/Net-NSCA-Client/
|
13
net-mgmt/p5-Net-NSCA-Client/pkg-plist
Normal file
13
net-mgmt/p5-Net-NSCA-Client/pkg-plist
Normal file
|
@ -0,0 +1,13 @@
|
|||
%%SITE_PERL%%/Net/NSCA/Client.pm
|
||||
%%SITE_PERL%%/Net/NSCA/Client/Connection.pm
|
||||
%%SITE_PERL%%/Net/NSCA/Client/Connection/TLS.pm
|
||||
%%SITE_PERL%%/Net/NSCA/Client/DataPacket.pm
|
||||
%%SITE_PERL%%/Net/NSCA/Client/InitialPacket.pm
|
||||
%%SITE_PERL%%/Net/NSCA/Client/Library.pm
|
||||
%%SITE_PERL%%/Net/NSCA/Client/ServerConfig.pm
|
||||
%%SITE_PERL%%/Net/NSCA/Client/Troubleshooting.pod
|
||||
%%SITE_PERL%%/Net/NSCA/Client/Utils.pm
|
||||
@dirrm %%SITE_PERL%%/Net/NSCA/Client/Connection
|
||||
@dirrm %%SITE_PERL%%/Net/NSCA/Client
|
||||
@dirrmtry %%SITE_PERL%%/Net/NSCA
|
||||
@dirrmtry %%SITE_PERL%%/Net
|
Loading…
Add table
Reference in a new issue