mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
textproc/lttoolbox: Update version 3.7.6=>3.8.0
Changelog: https://github.com/apertium/lttoolbox/releases/tag/v3.8.0
This commit is contained in:
parent
3372460657
commit
00ac857cb0
4 changed files with 32 additions and 13 deletions
|
@ -1,6 +1,5 @@
|
||||||
PORTNAME= lttoolbox
|
PORTNAME= lttoolbox
|
||||||
DISTVERSION= 3.7.6
|
DISTVERSION= 3.8.0
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= textproc
|
CATEGORIES= textproc
|
||||||
MASTER_SITES= https://github.com/apertium/${PORTNAME}/releases/download/v${DISTVERSION}/
|
MASTER_SITES= https://github.com/apertium/${PORTNAME}/releases/download/v${DISTVERSION}/
|
||||||
|
|
||||||
|
@ -14,17 +13,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
BUILD_DEPENDS= utf8cpp>=4.0.3:devel/utf8cpp
|
BUILD_DEPENDS= utf8cpp>=4.0.3:devel/utf8cpp
|
||||||
LIB_DEPENDS= libicuio.so:devel/icu
|
LIB_DEPENDS= libicuio.so:devel/icu
|
||||||
|
|
||||||
USES= autoreconf compiler:c++14-lang gnome libtool pathfix pkgconfig \
|
USES= cmake compiler:c++14-lang gnome libtool localbase pathfix pkgconfig \
|
||||||
tar:bz2
|
tar:bz2
|
||||||
USE_GNOME= libxml2
|
USE_GNOME= libxml2
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
CFLAGS+= -I${LOCALBASE}/include/utf8cpp -D_XOPEN_SOURCE=600
|
||||||
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
|
|
||||||
|
|
||||||
INSTALL_TARGET= install-strip
|
|
||||||
|
|
||||||
CFLAGS+= -I${LOCALBASE}/include/utf8cpp
|
|
||||||
LDFLAGS+= -lpthread
|
LDFLAGS+= -lpthread
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1703739184
|
TIMESTAMP = 1744531039
|
||||||
SHA256 (lttoolbox-3.7.6.tar.bz2) = 5a862716be36444c10014fbe45ac4e17b8bc498135311d5c9ac948187f6630fd
|
SHA256 (lttoolbox-3.8.0.tar.bz2) = 0bbe13c9798b937acad902c2ff39e38c13c061ad2247ba44cde289ddc95e1534
|
||||||
SIZE (lttoolbox-3.7.6.tar.bz2) = 172685
|
SIZE (lttoolbox-3.8.0.tar.bz2) = 157338
|
||||||
|
|
23
textproc/lttoolbox/files/patch-lttoolbox_lt__comp.cc
Normal file
23
textproc/lttoolbox/files/patch-lttoolbox_lt__comp.cc
Normal file
|
@ -0,0 +1,23 @@
|
||||||
|
--- lttoolbox/lt_comp.cc.orig 2025-04-05 18:21:01 UTC
|
||||||
|
+++ lttoolbox/lt_comp.cc
|
||||||
|
@@ -19,6 +19,7 @@
|
||||||
|
#include <lttoolbox/lt_locale.h>
|
||||||
|
#include <lttoolbox/cli.h>
|
||||||
|
#include <lttoolbox/file_utils.h>
|
||||||
|
+#include <lttoolbox/xml_walk_util.h>
|
||||||
|
|
||||||
|
#include <iostream>
|
||||||
|
|
||||||
|
@@ -119,7 +120,11 @@ int main(int argc, char *argv[])
|
||||||
|
std::cerr << "Error: Cannot not open file '" << infile << "'." << std::endl << std::endl;
|
||||||
|
exit(EXIT_FAILURE);
|
||||||
|
}
|
||||||
|
- initGenericErrorDefaultFunc(NULL);
|
||||||
|
+#if LIBXML_VERSION < 21200
|
||||||
|
+ initGenericErrorDefaultFunc(NULL);
|
||||||
|
+#else
|
||||||
|
+ xmlSetGenericErrorFunc(NULL, handler); // match new signature if needed
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
|
||||||
|
if(opc == "lr")
|
|
@ -5,6 +5,7 @@ bin/lt-comp
|
||||||
bin/lt-compose
|
bin/lt-compose
|
||||||
bin/lt-expand
|
bin/lt-expand
|
||||||
bin/lt-invert
|
bin/lt-invert
|
||||||
|
bin/lt-merge
|
||||||
bin/lt-paradigm
|
bin/lt-paradigm
|
||||||
bin/lt-print
|
bin/lt-print
|
||||||
bin/lt-proc
|
bin/lt-proc
|
||||||
|
@ -38,6 +39,7 @@ include/lttoolbox/serialiser.h
|
||||||
include/lttoolbox/sorted_vector.h
|
include/lttoolbox/sorted_vector.h
|
||||||
include/lttoolbox/sorted_vector.hpp
|
include/lttoolbox/sorted_vector.hpp
|
||||||
include/lttoolbox/state.h
|
include/lttoolbox/state.h
|
||||||
|
include/lttoolbox/stream_reader.h
|
||||||
include/lttoolbox/string_utils.h
|
include/lttoolbox/string_utils.h
|
||||||
include/lttoolbox/symbol_iter.h
|
include/lttoolbox/symbol_iter.h
|
||||||
include/lttoolbox/tmx_compiler.h
|
include/lttoolbox/tmx_compiler.h
|
||||||
|
@ -46,7 +48,6 @@ include/lttoolbox/transducer.h
|
||||||
include/lttoolbox/ustring.h
|
include/lttoolbox/ustring.h
|
||||||
include/lttoolbox/xml_parse_util.h
|
include/lttoolbox/xml_parse_util.h
|
||||||
include/lttoolbox/xml_walk_util.h
|
include/lttoolbox/xml_walk_util.h
|
||||||
lib/liblttoolbox.a
|
|
||||||
lib/liblttoolbox.so
|
lib/liblttoolbox.so
|
||||||
lib/liblttoolbox.so.3
|
lib/liblttoolbox.so.3
|
||||||
lib/liblttoolbox.so.3.0.0
|
lib/liblttoolbox.so.3.0.0
|
||||||
|
@ -62,6 +63,7 @@ share/man/man1/lt-append.1.gz
|
||||||
share/man/man1/lt-comp.1.gz
|
share/man/man1/lt-comp.1.gz
|
||||||
share/man/man1/lt-compose.1.gz
|
share/man/man1/lt-compose.1.gz
|
||||||
share/man/man1/lt-expand.1.gz
|
share/man/man1/lt-expand.1.gz
|
||||||
|
share/man/man1/lt-merge.1.gz
|
||||||
share/man/man1/lt-paradigm.1.gz
|
share/man/man1/lt-paradigm.1.gz
|
||||||
share/man/man1/lt-print.1.gz
|
share/man/man1/lt-print.1.gz
|
||||||
share/man/man1/lt-proc.1.gz
|
share/man/man1/lt-proc.1.gz
|
||||||
|
|
Loading…
Add table
Reference in a new issue